summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-11-18 15:53:29 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-11-18 15:53:29 +0300
commit8f6c4b0033c72f8ac14694c419a99458339dd6a9 (patch)
tree06c106e622a58100aa85a381b9b65d222b076df4 /debian/rules
parent42156b5190f4fa150e1fab6777eb81e69d4db8c9 (diff)
downloadgcc-9-debian.tar.gz
Import gcc-9 (9.2.1-19)debian/9.2.1-19debian
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 9 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 91bbc0f..29377cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -41,7 +41,8 @@ build: pre-build control
build-arch: pre-build control
$(MAKE) $(NJOBS) -f debian/rules2 $@
build-indep: pre-build control
- $(MAKE) $(NJOBS) -f debian/rules2 $@
+ DEB_BUILD_OPTIONS="$(DEB_BUILD_OPTIONS) nostrap nohppa64 nonvptx nocheck nopgo nolto" \
+ $(MAKE) $(NJOBS) -f debian/rules2 $@
check: $(check_stamp)
$(check_stamp): $(build_stamp)
@@ -50,7 +51,7 @@ $(check_stamp): $(build_stamp)
clean:
rm -rf $(stampdir)
# remove temporary dirs used for unpacking
- rm -rf $(gcc_srcdir) $(gdc_srcdir)
+ rm -rf $(gcc_srcdir) $(gdc_srcdir) $(nl_nvptx_srcdir)
-$(MAKE) -f debian/rules2 $@
rm -rf $(srcdir)* $(builddir)* debian/tmp* html
rm -f bootstrap-* first-move-stamp
@@ -58,6 +59,7 @@ clean:
rm -f debian/soname-cache
find debian -name '.#*' | xargs -r rm -f
rm -f $(series_file)*
+ rm -rf .pc
dh_clean
install:
@@ -66,9 +68,13 @@ install:
html-docs doxygen-docs update-doxygen-docs update-ada-files xxx:
$(MAKE) -f debian/rules2 $@
-binary-indep binary-arch binary:
+binary-arch binary:
$(MAKE) -f debian/rules2 $@
+binary-indep:
+ DEB_BUILD_OPTIONS="$(DEB_BUILD_OPTIONS) nostrap nohppa64 nonvptx nocheck nopgo nolto" \
+ $(MAKE) -f debian/rules2 $@
+
source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false