summaryrefslogtreecommitdiff
path: root/debian/patches/libffi-pax.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/libffi-pax.diff')
-rw-r--r--debian/patches/libffi-pax.diff12
1 files changed, 6 insertions, 6 deletions
diff --git a/debian/patches/libffi-pax.diff b/debian/patches/libffi-pax.diff
index e8666f8..14a7049 100644
--- a/debian/patches/libffi-pax.diff
+++ b/debian/patches/libffi-pax.diff
@@ -16,7 +16,7 @@ on x86-64 right now -> experimental
--- a/src/libffi/configure.ac
+++ b/src/libffi/configure.ac
-@@ -177,12 +177,17 @@
+@@ -176,12 +176,17 @@ case "$TARGET" in
;;
esac
@@ -62,7 +62,7 @@ on x86-64 right now -> experimental
#if FFI_CLOSURES
-@@ -172,14 +176,18 @@
+@@ -172,14 +176,18 @@ selinux_enabled_check (void)
#endif /* !FFI_MMAP_EXEC_SELINUX */
@@ -85,7 +85,7 @@ on x86-64 right now -> experimental
{
char *buf = NULL;
size_t len = 0;
-@@ -193,9 +201,10 @@
+@@ -193,9 +201,10 @@ emutramp_enabled_check (void)
while (getline (&buf, &len, f) != -1)
if (!strncmp (buf, "PaX:", 4))
{
@@ -99,7 +99,7 @@ on x86-64 right now -> experimental
break;
}
free (buf);
-@@ -203,9 +212,13 @@
+@@ -203,9 +212,13 @@ emutramp_enabled_check (void)
return ret;
}
@@ -116,7 +116,7 @@ on x86-64 right now -> experimental
#elif defined (__CYGWIN__) || defined(__INTERIX)
-@@ -216,9 +229,10 @@
+@@ -216,9 +229,10 @@ emutramp_enabled_check (void)
#endif /* !defined(X86_WIN32) && !defined(X86_WIN64) */
@@ -130,7 +130,7 @@ on x86-64 right now -> experimental
/* Declare all functions defined in dlmalloc.c as static. */
static void *dlmalloc(size_t);
-@@ -525,13 +539,23 @@
+@@ -525,13 +539,23 @@ dlmmap (void *start, size_t length, int
printf ("mapping in %zi\n", length);
#endif