summaryrefslogtreecommitdiff
path: root/debian/patches/libobjc-system-gc.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/libobjc-system-gc.diff')
-rw-r--r--debian/patches/libobjc-system-gc.diff822
1 files changed, 0 insertions, 822 deletions
diff --git a/debian/patches/libobjc-system-gc.diff b/debian/patches/libobjc-system-gc.diff
deleted file mode 100644
index 6f96217..0000000
--- a/debian/patches/libobjc-system-gc.diff
+++ /dev/null
@@ -1,822 +0,0 @@
-# DP: Build the GC enabled libobjc using the system libgc when available
-
-<toplevel>
-
-2016-11-19 Matthias Klose <doko@ubuntu.com>
-
- * configure.ac: Include pkg.m4, check for bdw-gc pkg-config module.
- * configure: Regenerate.
-
-config/
-
-2016-11-19 Matthias Klose <doko@ubuntu.com>
-
- * pkg.m4: New file.
-
-libobjc/
-
-2016-11-19 Matthias Klose <doko@ubuntu.com>
-
- * configure.ac (--enable-objc-gc): Allow to configure with a
- system provided boehm-gc.
- * configure: Regenerate.
- * Makefile.in (OBJC_BOEHM_GC_LIBS): Get value from configure.
- * gc.c: Optionally include system boehm-gc headers.
- * memory.c: Likewise
- * objects.c: Likewise
-
-Index: b/src/config/pkg.m4
-===================================================================
---- /dev/null
-+++ b/src/config/pkg.m4
-@@ -0,0 +1,550 @@
-+dnl pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
-+dnl serial 11 (pkg-config-0.29)
-+dnl
-+dnl Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
-+dnl Copyright © 2012-2015 Dan Nicholson <dbn.lists@gmail.com>
-+dnl
-+dnl This program is free software; you can redistribute it and/or modify
-+dnl it under the terms of the GNU General Public License as published by
-+dnl the Free Software Foundation; either version 2 of the License, or
-+dnl (at your option) any later version.
-+dnl
-+dnl This program is distributed in the hope that it will be useful, but
-+dnl WITHOUT ANY WARRANTY; without even the implied warranty of
-+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+dnl General Public License for more details.
-+dnl
-+dnl You should have received a copy of the GNU General Public License
-+dnl along with this program; if not, write to the Free Software
-+dnl Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-+dnl 02111-1307, USA.
-+dnl
-+dnl As a special exception to the GNU General Public License, if you
-+dnl distribute this file as part of a program that contains a
-+dnl configuration script generated by Autoconf, you may include it under
-+dnl the same distribution terms that you use for the rest of that
-+dnl program.
-+
-+dnl PKG_PREREQ(MIN-VERSION)
-+dnl -----------------------
-+dnl Since: 0.29
-+dnl
-+dnl Verify that the version of the pkg-config macros are at least
-+dnl MIN-VERSION. Unlike PKG_PROG_PKG_CONFIG, which checks the user's
-+dnl installed version of pkg-config, this checks the developer's version
-+dnl of pkg.m4 when generating configure.
-+dnl
-+dnl To ensure that this macro is defined, also add:
-+dnl m4_ifndef([PKG_PREREQ],
-+dnl [m4_fatal([must install pkg-config 0.29 or later before running autoconf/autogen])])
-+dnl
-+dnl See the "Since" comment for each macro you use to see what version
-+dnl of the macros you require.
-+m4_defun([PKG_PREREQ],
-+[m4_define([PKG_MACROS_VERSION], [0.29])
-+m4_if(m4_version_compare(PKG_MACROS_VERSION, [$1]), -1,
-+ [m4_fatal([pkg.m4 version $1 or higher is required but ]PKG_MACROS_VERSION[ found])])
-+])dnl PKG_PREREQ
-+
-+dnl PKG_PROG_PKG_CONFIG([MIN-VERSION])
-+dnl ----------------------------------
-+dnl Since: 0.16
-+dnl
-+dnl Search for the pkg-config tool and set the PKG_CONFIG variable to
-+dnl first found in the path. Checks that the version of pkg-config found
-+dnl is at least MIN-VERSION. If MIN-VERSION is not specified, 0.9.0 is
-+dnl used since that's the first version where most current features of
-+dnl pkg-config existed.
-+AC_DEFUN([PKG_PROG_PKG_CONFIG],
-+[m4_pattern_forbid([^_?PKG_[A-Z_]+$])
-+m4_pattern_allow([^PKG_CONFIG(_(PATH|LIBDIR|SYSROOT_DIR|ALLOW_SYSTEM_(CFLAGS|LIBS)))?$])
-+m4_pattern_allow([^PKG_CONFIG_(DISABLE_UNINSTALLED|TOP_BUILD_DIR|DEBUG_SPEW)$])
-+AC_ARG_VAR([PKG_CONFIG], [path to pkg-config utility])
-+AC_ARG_VAR([PKG_CONFIG_PATH], [directories to add to pkg-config's search path])
-+AC_ARG_VAR([PKG_CONFIG_LIBDIR], [path overriding pkg-config's built-in search path])
-+
-+if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
-+ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
-+fi
-+if test -n "$PKG_CONFIG"; then
-+ _pkg_min_version=m4_default([$1], [0.9.0])
-+ AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
-+ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
-+ AC_MSG_RESULT([yes])
-+ else
-+ AC_MSG_RESULT([no])
-+ PKG_CONFIG=""
-+ fi
-+fi[]dnl
-+])dnl PKG_PROG_PKG_CONFIG
-+
-+dnl PKG_CHECK_EXISTS(MODULES, [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
-+dnl -------------------------------------------------------------------
-+dnl Since: 0.18
-+dnl
-+dnl Check to see whether a particular set of modules exists. Similar to
-+dnl PKG_CHECK_MODULES(), but does not set variables or print errors.
-+dnl
-+dnl Please remember that m4 expands AC_REQUIRE([PKG_PROG_PKG_CONFIG])
-+dnl only at the first occurence in configure.ac, so if the first place
-+dnl it's called might be skipped (such as if it is within an "if", you
-+dnl have to call PKG_CHECK_EXISTS manually
-+AC_DEFUN([PKG_CHECK_EXISTS],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
-+if test -n "$PKG_CONFIG" && \
-+ AC_RUN_LOG([$PKG_CONFIG --exists --print-errors "$1"]); then
-+ m4_default([$2], [:])
-+m4_ifvaln([$3], [else
-+ $3])dnl
-+fi])
-+
-+dnl _PKG_CONFIG([VARIABLE], [COMMAND], [MODULES])
-+dnl ---------------------------------------------
-+dnl Internal wrapper calling pkg-config via PKG_CONFIG and setting
-+dnl pkg_failed based on the result.
-+m4_define([_PKG_CONFIG],
-+[if test -n "$$1"; then
-+ pkg_cv_[]$1="$$1"
-+ elif test -n "$PKG_CONFIG"; then
-+ PKG_CHECK_EXISTS([$3],
-+ [pkg_cv_[]$1=`$PKG_CONFIG --[]$2 "$3" 2>/dev/null`
-+ test "x$?" != "x0" && pkg_failed=yes ],
-+ [pkg_failed=yes])
-+ else
-+ pkg_failed=untried
-+fi[]dnl
-+])dnl _PKG_CONFIG
-+
-+dnl _PKG_SHORT_ERRORS_SUPPORTED
-+dnl ---------------------------
-+dnl Internal check to see if pkg-config supports short errors.
-+AC_DEFUN([_PKG_SHORT_ERRORS_SUPPORTED],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])
-+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-+ _pkg_short_errors_supported=yes
-+else
-+ _pkg_short_errors_supported=no
-+fi[]dnl
-+])dnl _PKG_SHORT_ERRORS_SUPPORTED
-+
-+
-+dnl PKG_CHECK_MODULES(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
-+dnl [ACTION-IF-NOT-FOUND])
-+dnl --------------------------------------------------------------
-+dnl Since: 0.4.0
-+dnl
-+dnl Note that if there is a possibility the first call to
-+dnl PKG_CHECK_MODULES might not happen, you should be sure to include an
-+dnl explicit call to PKG_PROG_PKG_CONFIG in your configure.ac
-+AC_DEFUN([PKG_CHECK_MODULES],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
-+AC_ARG_VAR([$1][_CFLAGS], [C compiler flags for $1, overriding pkg-config])dnl
-+AC_ARG_VAR([$1][_LIBS], [linker flags for $1, overriding pkg-config])dnl
-+
-+pkg_failed=no
-+AC_MSG_CHECKING([for $1])
-+
-+_PKG_CONFIG([$1][_CFLAGS], [cflags], [$2])
-+_PKG_CONFIG([$1][_LIBS], [libs], [$2])
-+
-+m4_define([_PKG_TEXT], [Alternatively, you may set the environment variables $1[]_CFLAGS
-+and $1[]_LIBS to avoid the need to call pkg-config.
-+See the pkg-config man page for more details.])
-+
-+if test $pkg_failed = yes; then
-+ AC_MSG_RESULT([no])
-+ _PKG_SHORT_ERRORS_SUPPORTED
-+ if test $_pkg_short_errors_supported = yes; then
-+ $1[]_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "$2" 2>&1`
-+ else
-+ $1[]_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "$2" 2>&1`
-+ fi
-+ # Put the nasty error message in config.log where it belongs
-+ echo "$$1[]_PKG_ERRORS" >&AS_MESSAGE_LOG_FD
-+
-+ m4_default([$4], [AC_MSG_ERROR(
-+[Package requirements ($2) were not met:
-+
-+$$1_PKG_ERRORS
-+
-+Consider adjusting the PKG_CONFIG_PATH environment variable if you
-+installed software in a non-standard prefix.
-+
-+_PKG_TEXT])[]dnl
-+ ])
-+elif test $pkg_failed = untried; then
-+ AC_MSG_RESULT([no])
-+ m4_default([$4], [AC_MSG_FAILURE(
-+[The pkg-config script could not be found or is too old. Make sure it
-+is in your PATH or set the PKG_CONFIG environment variable to the full
-+path to pkg-config.
-+
-+_PKG_TEXT
-+
-+To get pkg-config, see <http://pkg-config.freedesktop.org/>.])[]dnl
-+ ])
-+else
-+ $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
-+ $1[]_LIBS=$pkg_cv_[]$1[]_LIBS
-+ AC_MSG_RESULT([yes])
-+ $3
-+fi[]dnl
-+])dnl PKG_CHECK_MODULES
-+
-+
-+dnl PKG_CHECK_MODULES_STATIC(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
-+dnl [ACTION-IF-NOT-FOUND])
-+dnl ---------------------------------------------------------------------
-+dnl Since: 0.29
-+dnl
-+dnl Checks for existence of MODULES and gathers its build flags with
-+dnl static libraries enabled. Sets VARIABLE-PREFIX_CFLAGS from --cflags
-+dnl and VARIABLE-PREFIX_LIBS from --libs.
-+dnl
-+dnl Note that if there is a possibility the first call to
-+dnl PKG_CHECK_MODULES_STATIC might not happen, you should be sure to
-+dnl include an explicit call to PKG_PROG_PKG_CONFIG in your
-+dnl configure.ac.
-+AC_DEFUN([PKG_CHECK_MODULES_STATIC],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
-+_save_PKG_CONFIG=$PKG_CONFIG
-+PKG_CONFIG="$PKG_CONFIG --static"
-+PKG_CHECK_MODULES($@)
-+PKG_CONFIG=$_save_PKG_CONFIG[]dnl
-+])dnl PKG_CHECK_MODULES_STATIC
-+
-+
-+dnl PKG_INSTALLDIR([DIRECTORY])
-+dnl -------------------------
-+dnl Since: 0.27
-+dnl
-+dnl Substitutes the variable pkgconfigdir as the location where a module
-+dnl should install pkg-config .pc files. By default the directory is
-+dnl $libdir/pkgconfig, but the default can be changed by passing
-+dnl DIRECTORY. The user can override through the --with-pkgconfigdir
-+dnl parameter.
-+AC_DEFUN([PKG_INSTALLDIR],
-+[m4_pushdef([pkg_default], [m4_default([$1], ['${libdir}/pkgconfig'])])
-+m4_pushdef([pkg_description],
-+ [pkg-config installation directory @<:@]pkg_default[@:>@])
-+AC_ARG_WITH([pkgconfigdir],
-+ [AS_HELP_STRING([--with-pkgconfigdir], pkg_description)],,
-+ [with_pkgconfigdir=]pkg_default)
-+AC_SUBST([pkgconfigdir], [$with_pkgconfigdir])
-+m4_popdef([pkg_default])
-+m4_popdef([pkg_description])
-+])dnl PKG_INSTALLDIR
-+
-+
-+dnl PKG_NOARCH_INSTALLDIR([DIRECTORY])
-+dnl --------------------------------
-+dnl Since: 0.27
-+dnl
-+dnl Substitutes the variable noarch_pkgconfigdir as the location where a
-+dnl module should install arch-independent pkg-config .pc files. By
-+dnl default the directory is $datadir/pkgconfig, but the default can be
-+dnl changed by passing DIRECTORY. The user can override through the
-+dnl --with-noarch-pkgconfigdir parameter.
-+AC_DEFUN([PKG_NOARCH_INSTALLDIR],
-+[m4_pushdef([pkg_default], [m4_default([$1], ['${datadir}/pkgconfig'])])
-+m4_pushdef([pkg_description],
-+ [pkg-config arch-independent installation directory @<:@]pkg_default[@:>@])
-+AC_ARG_WITH([noarch-pkgconfigdir],
-+ [AS_HELP_STRING([--with-noarch-pkgconfigdir], pkg_description)],,
-+ [with_noarch_pkgconfigdir=]pkg_default)
-+AC_SUBST([noarch_pkgconfigdir], [$with_noarch_pkgconfigdir])
-+m4_popdef([pkg_default])
-+m4_popdef([pkg_description])
-+])dnl PKG_NOARCH_INSTALLDIR
-+
-+
-+dnl PKG_CHECK_VAR(VARIABLE, MODULE, CONFIG-VARIABLE,
-+dnl [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
-+dnl -------------------------------------------
-+dnl Since: 0.28
-+dnl
-+dnl Retrieves the value of the pkg-config variable for the given module.
-+AC_DEFUN([PKG_CHECK_VAR],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
-+AC_ARG_VAR([$1], [value of $3 for $2, overriding pkg-config])dnl
-+
-+_PKG_CONFIG([$1], [variable="][$3]["], [$2])
-+AS_VAR_COPY([$1], [pkg_cv_][$1])
-+
-+AS_VAR_IF([$1], [""], [$5], [$4])dnl
-+])dnl PKG_CHECK_VAR
-+dnl pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
-+dnl serial 11 (pkg-config-0.29)
-+dnl
-+dnl Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
-+dnl Copyright © 2012-2015 Dan Nicholson <dbn.lists@gmail.com>
-+dnl
-+dnl This program is free software; you can redistribute it and/or modify
-+dnl it under the terms of the GNU General Public License as published by
-+dnl the Free Software Foundation; either version 2 of the License, or
-+dnl (at your option) any later version.
-+dnl
-+dnl This program is distributed in the hope that it will be useful, but
-+dnl WITHOUT ANY WARRANTY; without even the implied warranty of
-+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+dnl General Public License for more details.
-+dnl
-+dnl You should have received a copy of the GNU General Public License
-+dnl along with this program; if not, write to the Free Software
-+dnl Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-+dnl 02111-1307, USA.
-+dnl
-+dnl As a special exception to the GNU General Public License, if you
-+dnl distribute this file as part of a program that contains a
-+dnl configuration script generated by Autoconf, you may include it under
-+dnl the same distribution terms that you use for the rest of that
-+dnl program.
-+
-+dnl PKG_PREREQ(MIN-VERSION)
-+dnl -----------------------
-+dnl Since: 0.29
-+dnl
-+dnl Verify that the version of the pkg-config macros are at least
-+dnl MIN-VERSION. Unlike PKG_PROG_PKG_CONFIG, which checks the user's
-+dnl installed version of pkg-config, this checks the developer's version
-+dnl of pkg.m4 when generating configure.
-+dnl
-+dnl To ensure that this macro is defined, also add:
-+dnl m4_ifndef([PKG_PREREQ],
-+dnl [m4_fatal([must install pkg-config 0.29 or later before running autoconf/autogen])])
-+dnl
-+dnl See the "Since" comment for each macro you use to see what version
-+dnl of the macros you require.
-+m4_defun([PKG_PREREQ],
-+[m4_define([PKG_MACROS_VERSION], [0.29])
-+m4_if(m4_version_compare(PKG_MACROS_VERSION, [$1]), -1,
-+ [m4_fatal([pkg.m4 version $1 or higher is required but ]PKG_MACROS_VERSION[ found])])
-+])dnl PKG_PREREQ
-+
-+dnl PKG_PROG_PKG_CONFIG([MIN-VERSION])
-+dnl ----------------------------------
-+dnl Since: 0.16
-+dnl
-+dnl Search for the pkg-config tool and set the PKG_CONFIG variable to
-+dnl first found in the path. Checks that the version of pkg-config found
-+dnl is at least MIN-VERSION. If MIN-VERSION is not specified, 0.9.0 is
-+dnl used since that's the first version where most current features of
-+dnl pkg-config existed.
-+AC_DEFUN([PKG_PROG_PKG_CONFIG],
-+[m4_pattern_forbid([^_?PKG_[A-Z_]+$])
-+m4_pattern_allow([^PKG_CONFIG(_(PATH|LIBDIR|SYSROOT_DIR|ALLOW_SYSTEM_(CFLAGS|LIBS)))?$])
-+m4_pattern_allow([^PKG_CONFIG_(DISABLE_UNINSTALLED|TOP_BUILD_DIR|DEBUG_SPEW)$])
-+AC_ARG_VAR([PKG_CONFIG], [path to pkg-config utility])
-+AC_ARG_VAR([PKG_CONFIG_PATH], [directories to add to pkg-config's search path])
-+AC_ARG_VAR([PKG_CONFIG_LIBDIR], [path overriding pkg-config's built-in search path])
-+
-+if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
-+ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
-+fi
-+if test -n "$PKG_CONFIG"; then
-+ _pkg_min_version=m4_default([$1], [0.9.0])
-+ AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
-+ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
-+ AC_MSG_RESULT([yes])
-+ else
-+ AC_MSG_RESULT([no])
-+ PKG_CONFIG=""
-+ fi
-+fi[]dnl
-+])dnl PKG_PROG_PKG_CONFIG
-+
-+dnl PKG_CHECK_EXISTS(MODULES, [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
-+dnl -------------------------------------------------------------------
-+dnl Since: 0.18
-+dnl
-+dnl Check to see whether a particular set of modules exists. Similar to
-+dnl PKG_CHECK_MODULES(), but does not set variables or print errors.
-+dnl
-+dnl Please remember that m4 expands AC_REQUIRE([PKG_PROG_PKG_CONFIG])
-+dnl only at the first occurence in configure.ac, so if the first place
-+dnl it's called might be skipped (such as if it is within an "if", you
-+dnl have to call PKG_CHECK_EXISTS manually
-+AC_DEFUN([PKG_CHECK_EXISTS],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
-+if test -n "$PKG_CONFIG" && \
-+ AC_RUN_LOG([$PKG_CONFIG --exists --print-errors "$1"]); then
-+ m4_default([$2], [:])
-+m4_ifvaln([$3], [else
-+ $3])dnl
-+fi])
-+
-+dnl _PKG_CONFIG([VARIABLE], [COMMAND], [MODULES])
-+dnl ---------------------------------------------
-+dnl Internal wrapper calling pkg-config via PKG_CONFIG and setting
-+dnl pkg_failed based on the result.
-+m4_define([_PKG_CONFIG],
-+[if test -n "$$1"; then
-+ pkg_cv_[]$1="$$1"
-+ elif test -n "$PKG_CONFIG"; then
-+ PKG_CHECK_EXISTS([$3],
-+ [pkg_cv_[]$1=`$PKG_CONFIG --[]$2 "$3" 2>/dev/null`
-+ test "x$?" != "x0" && pkg_failed=yes ],
-+ [pkg_failed=yes])
-+ else
-+ pkg_failed=untried
-+fi[]dnl
-+])dnl _PKG_CONFIG
-+
-+dnl _PKG_SHORT_ERRORS_SUPPORTED
-+dnl ---------------------------
-+dnl Internal check to see if pkg-config supports short errors.
-+AC_DEFUN([_PKG_SHORT_ERRORS_SUPPORTED],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])
-+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-+ _pkg_short_errors_supported=yes
-+else
-+ _pkg_short_errors_supported=no
-+fi[]dnl
-+])dnl _PKG_SHORT_ERRORS_SUPPORTED
-+
-+
-+dnl PKG_CHECK_MODULES(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
-+dnl [ACTION-IF-NOT-FOUND])
-+dnl --------------------------------------------------------------
-+dnl Since: 0.4.0
-+dnl
-+dnl Note that if there is a possibility the first call to
-+dnl PKG_CHECK_MODULES might not happen, you should be sure to include an
-+dnl explicit call to PKG_PROG_PKG_CONFIG in your configure.ac
-+AC_DEFUN([PKG_CHECK_MODULES],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
-+AC_ARG_VAR([$1][_CFLAGS], [C compiler flags for $1, overriding pkg-config])dnl
-+AC_ARG_VAR([$1][_LIBS], [linker flags for $1, overriding pkg-config])dnl
-+
-+pkg_failed=no
-+AC_MSG_CHECKING([for $1])
-+
-+_PKG_CONFIG([$1][_CFLAGS], [cflags], [$2])
-+_PKG_CONFIG([$1][_LIBS], [libs], [$2])
-+
-+m4_define([_PKG_TEXT], [Alternatively, you may set the environment variables $1[]_CFLAGS
-+and $1[]_LIBS to avoid the need to call pkg-config.
-+See the pkg-config man page for more details.])
-+
-+if test $pkg_failed = yes; then
-+ AC_MSG_RESULT([no])
-+ _PKG_SHORT_ERRORS_SUPPORTED
-+ if test $_pkg_short_errors_supported = yes; then
-+ $1[]_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "$2" 2>&1`
-+ else
-+ $1[]_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "$2" 2>&1`
-+ fi
-+ # Put the nasty error message in config.log where it belongs
-+ echo "$$1[]_PKG_ERRORS" >&AS_MESSAGE_LOG_FD
-+
-+ m4_default([$4], [AC_MSG_ERROR(
-+[Package requirements ($2) were not met:
-+
-+$$1_PKG_ERRORS
-+
-+Consider adjusting the PKG_CONFIG_PATH environment variable if you
-+installed software in a non-standard prefix.
-+
-+_PKG_TEXT])[]dnl
-+ ])
-+elif test $pkg_failed = untried; then
-+ AC_MSG_RESULT([no])
-+ m4_default([$4], [AC_MSG_FAILURE(
-+[The pkg-config script could not be found or is too old. Make sure it
-+is in your PATH or set the PKG_CONFIG environment variable to the full
-+path to pkg-config.
-+
-+_PKG_TEXT
-+
-+To get pkg-config, see <http://pkg-config.freedesktop.org/>.])[]dnl
-+ ])
-+else
-+ $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
-+ $1[]_LIBS=$pkg_cv_[]$1[]_LIBS
-+ AC_MSG_RESULT([yes])
-+ $3
-+fi[]dnl
-+])dnl PKG_CHECK_MODULES
-+
-+
-+dnl PKG_CHECK_MODULES_STATIC(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
-+dnl [ACTION-IF-NOT-FOUND])
-+dnl ---------------------------------------------------------------------
-+dnl Since: 0.29
-+dnl
-+dnl Checks for existence of MODULES and gathers its build flags with
-+dnl static libraries enabled. Sets VARIABLE-PREFIX_CFLAGS from --cflags
-+dnl and VARIABLE-PREFIX_LIBS from --libs.
-+dnl
-+dnl Note that if there is a possibility the first call to
-+dnl PKG_CHECK_MODULES_STATIC might not happen, you should be sure to
-+dnl include an explicit call to PKG_PROG_PKG_CONFIG in your
-+dnl configure.ac.
-+AC_DEFUN([PKG_CHECK_MODULES_STATIC],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
-+_save_PKG_CONFIG=$PKG_CONFIG
-+PKG_CONFIG="$PKG_CONFIG --static"
-+PKG_CHECK_MODULES($@)
-+PKG_CONFIG=$_save_PKG_CONFIG[]dnl
-+])dnl PKG_CHECK_MODULES_STATIC
-+
-+
-+dnl PKG_INSTALLDIR([DIRECTORY])
-+dnl -------------------------
-+dnl Since: 0.27
-+dnl
-+dnl Substitutes the variable pkgconfigdir as the location where a module
-+dnl should install pkg-config .pc files. By default the directory is
-+dnl $libdir/pkgconfig, but the default can be changed by passing
-+dnl DIRECTORY. The user can override through the --with-pkgconfigdir
-+dnl parameter.
-+AC_DEFUN([PKG_INSTALLDIR],
-+[m4_pushdef([pkg_default], [m4_default([$1], ['${libdir}/pkgconfig'])])
-+m4_pushdef([pkg_description],
-+ [pkg-config installation directory @<:@]pkg_default[@:>@])
-+AC_ARG_WITH([pkgconfigdir],
-+ [AS_HELP_STRING([--with-pkgconfigdir], pkg_description)],,
-+ [with_pkgconfigdir=]pkg_default)
-+AC_SUBST([pkgconfigdir], [$with_pkgconfigdir])
-+m4_popdef([pkg_default])
-+m4_popdef([pkg_description])
-+])dnl PKG_INSTALLDIR
-+
-+
-+dnl PKG_NOARCH_INSTALLDIR([DIRECTORY])
-+dnl --------------------------------
-+dnl Since: 0.27
-+dnl
-+dnl Substitutes the variable noarch_pkgconfigdir as the location where a
-+dnl module should install arch-independent pkg-config .pc files. By
-+dnl default the directory is $datadir/pkgconfig, but the default can be
-+dnl changed by passing DIRECTORY. The user can override through the
-+dnl --with-noarch-pkgconfigdir parameter.
-+AC_DEFUN([PKG_NOARCH_INSTALLDIR],
-+[m4_pushdef([pkg_default], [m4_default([$1], ['${datadir}/pkgconfig'])])
-+m4_pushdef([pkg_description],
-+ [pkg-config arch-independent installation directory @<:@]pkg_default[@:>@])
-+AC_ARG_WITH([noarch-pkgconfigdir],
-+ [AS_HELP_STRING([--with-noarch-pkgconfigdir], pkg_description)],,
-+ [with_noarch_pkgconfigdir=]pkg_default)
-+AC_SUBST([noarch_pkgconfigdir], [$with_noarch_pkgconfigdir])
-+m4_popdef([pkg_default])
-+m4_popdef([pkg_description])
-+])dnl PKG_NOARCH_INSTALLDIR
-+
-+
-+dnl PKG_CHECK_VAR(VARIABLE, MODULE, CONFIG-VARIABLE,
-+dnl [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
-+dnl -------------------------------------------
-+dnl Since: 0.28
-+dnl
-+dnl Retrieves the value of the pkg-config variable for the given module.
-+AC_DEFUN([PKG_CHECK_VAR],
-+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
-+AC_ARG_VAR([$1], [value of $3 for $2, overriding pkg-config])dnl
-+
-+_PKG_CONFIG([$1], [variable="][$3]["], [$2])
-+AS_VAR_COPY([$1], [pkg_cv_][$1])
-+
-+AS_VAR_IF([$1], [""], [$5], [$4])dnl
-+])dnl PKG_CHECK_VAR
-Index: b/src/configure.ac
-===================================================================
---- a/src/configure.ac
-+++ b/src/configure.ac
-@@ -29,6 +29,7 @@ m4_include([ltsugar.m4])
- m4_include([ltversion.m4])
- m4_include([lt~obsolete.m4])
- m4_include([config/isl.m4])
-+m4_include([config/pkg.m4])
-
- AC_INIT(move-if-change)
- AC_PREREQ(2.64)
-@@ -2169,14 +2170,20 @@ AC_ARG_ENABLE(objc-gc,
- [enable use of Boehm's garbage collector with the
- GNU Objective-C runtime])],
- [case ,${enable_languages},:${enable_objc_gc}:${noconfigdirs} in
-- *,objc,*:*:yes:*target-boehm-gc*)
-+ *,objc,*:*:yes:*target-boehm-gc*|*,objc,*:*:auto:*target-boehm-gc*|*,objc,*:*:system:*target-boehm-gc*)
- AC_MSG_ERROR([Boehm's garbage collector was requested yet not supported in this configuration])
-+esac
-+case ,${enable_languages},:${enable_objc_gc} in
-+ *,objc,*:auto|*,objc,*:system)
-+ PKG_CHECK_EXISTS(bdw-gc,
-+ AC_MSG_RESULT([found]),
-+ AC_MSG_ERROR([bdw-gc pkg-config module not found]))
- ;;
- esac])
-
- # Make sure we only build Boehm's garbage collector if required.
- case ,${enable_languages},:${enable_objc_gc} in
-- *,objc,*:yes)
-+ *,objc,*:yes|*,objc,*:auto)
- # Keep target-boehm-gc if requested for Objective-C.
- ;;
- *)
-Index: b/src/libobjc/Makefile.in
-===================================================================
---- a/src/libobjc/Makefile.in
-+++ b/src/libobjc/Makefile.in
-@@ -95,7 +95,7 @@ LIBTOOL_CLEAN = $(LIBTOOL) --mode=clea
- OBJC_GCFLAGS=@OBJC_GCFLAGS@
- OBJC_BOEHM_GC=@OBJC_BOEHM_GC@
- OBJC_BOEHM_GC_INCLUDES=@OBJC_BOEHM_GC_INCLUDES@
--OBJC_BOEHM_GC_LIBS=../boehm-gc/libgcjgc_convenience.la $(thread_libs_and_flags)
-+OBJC_BOEHM_GC_LIBS=@OBJC_BOEHM_GC_LIBS@
-
- INCLUDES = -I$(srcdir)/$(MULTISRCTOP)../gcc \
- -I$(srcdir)/$(MULTISRCTOP)../gcc/config \
-Index: b/src/libobjc/configure.ac
-===================================================================
---- a/src/libobjc/configure.ac
-+++ b/src/libobjc/configure.ac
-@@ -18,6 +18,8 @@
- #along with GCC; see the file COPYING3. If not see
- #<http://www.gnu.org/licenses/>.
-
-+m4_include([../config/pkg.m4])
-+
- AC_PREREQ(2.64)
- AC_INIT(package-unused, version-unused,, libobjc)
- AC_CONFIG_SRCDIR([objc/objc.h])
-@@ -57,26 +59,6 @@ AC_ARG_ENABLE(version-specific-runtime-l
- [version_specific_libs=no])
- AC_MSG_RESULT($version_specific_libs)
-
--AC_ARG_ENABLE(objc-gc,
--[ --enable-objc-gc enable the use of Boehm's garbage collector with
-- the GNU Objective-C runtime.],
--[case $enable_objc_gc in
-- no)
-- OBJC_GCFLAGS=''
-- OBJC_BOEHM_GC=''
-- OBJC_BOEHM_GC_INCLUDES=''
-- ;;
-- *)
-- OBJC_GCFLAGS='-DOBJC_WITH_GC=1'
-- OBJC_BOEHM_GC='libobjc_gc$(libsuffix).la'
-- OBJC_BOEHM_GC_INCLUDES='-I$(top_srcdir)/../boehm-gc/include -I../boehm-gc/include'
-- ;;
--esac],
--[OBJC_GCFLAGS=''; OBJC_BOEHM_GC=''; OBJC_BOEHM_GC_INCLUDES=''])
--AC_SUBST(OBJC_GCFLAGS)
--AC_SUBST(OBJC_BOEHM_GC)
--AC_SUBST(OBJC_BOEHM_GC_INCLUDES)
--
- # -----------
- # Directories
- # -----------
-@@ -214,6 +196,87 @@ GCC_CHECK_TLS
-
- gt_BITFIELD_TYPE_MATTERS
-
-+# -----------
-+# boehm-gc
-+# -----------
-+
-+AC_ARG_ENABLE(objc-gc,
-+[ --enable-objc-gc enable the use of Boehm's garbage collector with
-+ the GNU Objective-C runtime. Valid values are
-+ yes, no, system or auto],
-+[case $enable_objc_gc in
-+ no)
-+ use_boehm_gc=no
-+ ;;
-+ auto|system)
-+ PKG_CHECK_MODULES(BDW_GC, bdw-gc >= 7)
-+ AC_MSG_CHECKING([for system boehm-gc])
-+ save_CFLAGS=$CFLAGS
-+ save_LIBS=$LIBS
-+ CFLAGS="$CFLAGS $BDW_GC_CFLAGS"
-+ LIBS="$LIBS $BDW_GC_LIBS"
-+ dnl the link test is not good enough for ARM32 multilib detection,
-+ dnl first check to link, then to run
-+ AC_LINK_IFELSE(
-+ [AC_LANG_PROGRAM([#include <gc/gc.h>],[GC_init()])],
-+ [
-+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
-+ #include <gc/gc.h>
-+ int main() {
-+ GC_init();
-+ return 0;
-+ }
-+ ]])],
-+ [system_boehm_gc_found=yes],
-+ [system_boehm_gc_found=no],
-+ dnl assume no system boehm-gc for cross builds ...
-+ [system_boehm_gc_found=no]
-+ )
-+ ],
-+ [system_boehm_gc_found=no])
-+ CFLAGS=$save_CFLAGS
-+ LIBS=$save_LIBS
-+ if test x$enable_objc_gc = xsystem && test x$system_boehm_gc_found = xno; then
-+ AC_MSG_ERROR([system boehm-gc required but not found])
-+ elif test x$system_boehm_gc_found = xno; then
-+ use_boehm_gc=internal
-+ AC_MSG_RESULT([not found, falling back to internal boehm-gc])
-+ else
-+ use_boehm_gc=system
-+ AC_MSG_RESULT([found])
-+ fi
-+ ;;
-+ *)
-+ use_boehm_gc=internal
-+ ;;
-+esac],
-+[use_boehm_gc=no])
-+
-+case "$use_boehm_gc" in
-+ internal)
-+ OBJC_GCFLAGS='-DOBJC_WITH_GC=1'
-+ OBJC_BOEHM_GC='libobjc_gc$(libsuffix).la'
-+ OBJC_BOEHM_GC_INCLUDES='-I$(top_srcdir)/../boehm-gc/include -I../boehm-gc/include'
-+ OBJC_BOEHM_GC_LIBS='../boehm-gc/libgcjgc_convenience.la $(thread_libs_and_flags)'
-+ ;;
-+ system)
-+ OBJC_GCFLAGS='-DOBJC_WITH_GC=1 -DSYSTEM_BOEHM_GC=1'
-+ OBJC_BOEHM_GC='libobjc_gc$(libsuffix).la'
-+ OBJC_BOEHM_GC_INCLUDES=$BDW_GC_CFLAGS
-+ OBJC_BOEHM_GC_LIBS=$BDW_GC_LIBS
-+ ;;
-+ *)
-+ OBJC_GCFLAGS=''
-+ OBJC_BOEHM_GC=''
-+ OBJC_BOEHM_GC_INCLUDES=''
-+ OBJC_BOEHM_GC_LIBS=''
-+ ;;
-+esac
-+AC_SUBST(OBJC_GCFLAGS)
-+AC_SUBST(OBJC_BOEHM_GC)
-+AC_SUBST(OBJC_BOEHM_GC_INCLUDES)
-+AC_SUBST(OBJC_BOEHM_GC_LIBS)
-+
- # ------
- # Output
- # ------
-Index: b/src/libobjc/gc.c
-===================================================================
---- a/src/libobjc/gc.c
-+++ b/src/libobjc/gc.c
-@@ -36,7 +36,11 @@ see the files COPYING3 and COPYING.RUNTI
- #include "objc/runtime.h"
- #include "objc-private/module-abi-8.h"
-
-+#if SYSTEM_BOEHM_GC
-+#include <gc/gc.h>
-+#else
- #include <gc.h>
-+#endif
- #include <limits.h>
-
- /* gc_typed.h uses the following but doesn't declare them */
-@@ -44,7 +48,11 @@ typedef GC_word word;
- typedef GC_signed_word signed_word;
- #define BITS_PER_WORD (CHAR_BIT * sizeof (word))
-
-+#if SYSTEM_BOEHM_GC
-+#include <gc/gc_typed.h>
-+#else
- #include <gc_typed.h>
-+#endif
-
- /* The following functions set up in `mask` the corresponding pointers.
- The offset is incremented with the size of the type. */
-Index: b/src/libobjc/memory.c
-===================================================================
---- a/src/libobjc/memory.c
-+++ b/src/libobjc/memory.c
-@@ -41,7 +41,11 @@ see the files COPYING3 and COPYING.RUNTI
- #include "objc/runtime.h"
-
- #if OBJC_WITH_GC
-+#if SYSTEM_BOEHM_GC
-+#include <gc/gc.h>
-+#else
- #include <gc.h>
-+#endif
-
- void *
- objc_malloc (size_t size)
-Index: b/src/libobjc/objects.c
-===================================================================
---- a/src/libobjc/objects.c
-+++ b/src/libobjc/objects.c
-@@ -31,8 +31,13 @@ see the files COPYING3 and COPYING.RUNTI
- #include <string.h> /* For memcpy() */
-
- #if OBJC_WITH_GC
--# include <gc.h>
--# include <gc_typed.h>
-+# if SYSTEM_BOEHM_GC
-+# include <gc/gc.h>
-+# include <gc/gc_typed.h>
-+# else
-+# include <gc.h>
-+# include <gc_typed.h>
-+# endif
- #endif
-
- /* FIXME: The semantics of extraBytes are not really clear. */