summaryrefslogtreecommitdiff
path: root/debian/patches/rename-info-files.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/rename-info-files.diff')
-rw-r--r--debian/patches/rename-info-files.diff278
1 files changed, 45 insertions, 233 deletions
diff --git a/debian/patches/rename-info-files.diff b/debian/patches/rename-info-files.diff
index ad4871d..77b1431 100644
--- a/debian/patches/rename-info-files.diff
+++ b/debian/patches/rename-info-files.diff
@@ -27,12 +27,6 @@ gcc/fortran/ChangeLog:
names to makeinfo.
* gfortran.texi: Use macros defined in MAKEINFODEFS for references.
-gcc/java/ChangeLog:
- * Make-lang.in: Allow transformations on info file names.
- Pass macros of transformated info file defined in MAKEINFODEFS
-
-Index: b/src/gcc/fortran/gfortran.texi
-===================================================================
--- a/src/gcc/fortran/gfortran.texi
+++ b/src/gcc/fortran/gfortran.texi
@@ -101,7 +101,7 @@ Texts being (a) (see below), and with th
@@ -44,8 +38,6 @@ Index: b/src/gcc/fortran/gfortran.texi
@end direntry
This file documents the use and the internals of
the GNU Fortran compiler, (@command{gfortran}).
-Index: b/src/gcc/fortran/Make-lang.in
-===================================================================
--- a/src/gcc/fortran/Make-lang.in
+++ b/src/gcc/fortran/Make-lang.in
@@ -114,7 +114,8 @@ fortran.tags: force
@@ -58,7 +50,7 @@ Index: b/src/gcc/fortran/Make-lang.in
fortran.dvi: doc/gfortran.dvi doc/gfc-internals.dvi
F95_HTMLFILES = $(build_htmldir)/gfortran
-@@ -181,10 +182,10 @@ GFORTRAN_TEXI = \
+@@ -184,10 +185,10 @@ GFORTRAN_TEXI = \
$(srcdir)/doc/include/gcc-common.texi \
gcc-vers.texi
@@ -71,7 +63,7 @@ Index: b/src/gcc/fortran/Make-lang.in
-o $@ $<; \
else true; fi
-@@ -249,7 +250,7 @@ fortran.install-common: install-finclude
+@@ -252,7 +253,7 @@ fortran.install-common: install-finclude
fortran.install-plugin:
@@ -80,7 +72,7 @@ Index: b/src/gcc/fortran/Make-lang.in
fortran.install-man: $(DESTDIR)$(man1dir)/$(GFORTRAN_INSTALL_NAME)$(man1ext)
-@@ -267,7 +268,7 @@ fortran.uninstall:
+@@ -270,7 +271,7 @@ fortran.uninstall:
rm -rf $(DESTDIR)$(bindir)/$(GFORTRAN_INSTALL_NAME)$(exeext); \
rm -rf $(DESTDIR)$(man1dir)/$(GFORTRAN_INSTALL_NAME)$(man1ext); \
rm -rf $(DESTDIR)$(bindir)/$(GFORTRAN_TARGET_INSTALL_NAME)$(exeext); \
@@ -89,11 +81,9 @@ Index: b/src/gcc/fortran/Make-lang.in
#
# Clean hooks:
-Index: b/src/gcc/Makefile.in
-===================================================================
--- a/src/gcc/Makefile.in
+++ b/src/gcc/Makefile.in
-@@ -2961,8 +2961,33 @@ install-no-fixedincludes:
+@@ -3138,8 +3138,31 @@ install-no-fixedincludes:
doc: $(BUILD_INFO) $(GENERATED_MANPAGES)
@@ -107,7 +97,6 @@ Index: b/src/gcc/Makefile.in
+INFO_CPPINT_NAME = $(shell echo cppinternals|sed '$(program_transform_name)')
+
+INFO_FORTRAN_NAME = $(shell echo gfortran|sed '$(program_transform_name)')
-+INFO_GCJ_NAME = $(shell echo gcj|sed '$(program_transform_name)')
+INFO_GCCGO_NAME = $(shell echo gccgo|sed '$(program_transform_name)')
+
+INFOFILES = doc/$(INFO_CPP_NAME).info doc/$(INFO_GCC_NAME).info \
@@ -124,12 +113,11 @@ Index: b/src/gcc/Makefile.in
+ -D 'fngccinstall $(INFO_GCCINSTALL_NAME)' \
+ -D 'fncppint $(INFO_CPPINT_NAME)' \
+ -D 'fngfortran $(INFO_FORTRAN_NAME)' \
-+ -D 'fngcj $(INFO_GCJ_NAME)' \
+ -D 'fngccgo $(INFO_GCCGO_NAME)'
info: $(INFOFILES) lang.info @GENINSRC@ srcinfo lang.srcinfo
-@@ -3009,7 +3034,21 @@ gcc-vers.texi: $(BASEVER) $(DEVPHASE)
+@@ -3186,7 +3209,20 @@ gcc-vers.texi: $(BASEVER) $(DEVPHASE)
if [ -n "$(PKGVERSION)" ]; then \
echo "@set VERSION_PACKAGE $(PKGVERSION)" >> $@T; \
fi
@@ -146,13 +134,12 @@ Index: b/src/gcc/Makefile.in
+ echo '@set fngccinstall $(INFO_GCCINSTALL_NAME)'; \
+ echo '@set fncppint $(INFO_CPPINT_NAME)'; \
+ echo '@set fngfortran $(INFO_FORTRAN_NAME)'; \
-+ echo '@set fngcj $(INFO_GCJ_NAME)'; \
+ echo '@set fngccgo $(INFO_GCCGO_NAME)'; \
+ ) >> $@T
mv -f $@T $@
-@@ -3017,21 +3056,41 @@ gcc-vers.texi: $(BASEVER) $(DEVPHASE)
+@@ -3194,21 +3230,41 @@ gcc-vers.texi: $(BASEVER) $(DEVPHASE)
# patterns. To use them, put each of the specific targets with its
# specific dependencies but no build commands.
@@ -201,7 +188,7 @@ Index: b/src/gcc/Makefile.in
-I $(gcc_docdir)/include -o $@ $<; \
fi
-@@ -3443,11 +3502,11 @@ install-driver: installdirs xgcc$(exeext
+@@ -3627,11 +3683,11 @@ install-driver: installdirs xgcc$(exeext
# $(INSTALL_DATA) might be a relative pathname, so we can't cd into srcdir
# to do the install.
install-info:: doc installdirs \
@@ -218,7 +205,7 @@ Index: b/src/gcc/Makefile.in
lang.install-info
$(DESTDIR)$(infodir)/%.info: doc/%.info installdirs
-@@ -3668,8 +3727,11 @@ uninstall: lang.uninstall
+@@ -3852,8 +3908,11 @@ uninstall: lang.uninstall
-rm -rf $(DESTDIR)$(bindir)/$(GCOV_INSTALL_NAME)$(exeext)
-rm -rf $(DESTDIR)$(man1dir)/$(GCC_INSTALL_NAME)$(man1ext)
-rm -rf $(DESTDIR)$(man1dir)/cpp$(man1ext)
@@ -232,96 +219,6 @@ Index: b/src/gcc/Makefile.in
for i in ar nm ranlib ; do \
install_name=`echo gcc-$$i|sed '$(program_transform_name)'`$(exeext) ;\
target_install_name=$(target_noncanonical)-`echo gcc-$$i|sed '$(program_transform_name)'`$(exeext) ; \
-Index: b/src/gcc/java/gcj.texi
-===================================================================
---- a/src/gcc/java/gcj.texi
-+++ b/src/gcc/java/gcj.texi
-@@ -55,25 +55,25 @@ man page gfdl(7).
- @format
- @dircategory Software development
- @direntry
--* Gcj: (gcj). Ahead-of-time compiler for the Java language
-+* @value{fngcj}: (@value{fngcj}). Ahead-of-time compiler for the Java language
- @end direntry
-
- @dircategory Individual utilities
- @direntry
--* jcf-dump: (gcj)Invoking jcf-dump.
-+* jcf-dump: (@value{fngcj}) Invoking jcf-dump.
- Print information about Java class files
--* gij: (gcj)Invoking gij. GNU interpreter for Java bytecode
--* gcj-dbtool: (gcj)Invoking gcj-dbtool.
-+* gij: (@value{fngcj}) Invoking gij. GNU interpreter for Java bytecode
-+* gcj-dbtool: (@value{fngcj}) Invoking gcj-dbtool.
- Tool for manipulating class file databases.
--* jv-convert: (gcj)Invoking jv-convert.
-+* jv-convert: (@value{fngcj}) Invoking jv-convert.
- Convert file from one encoding to another
--* grmic: (gcj)Invoking grmic.
-+* grmic: (@value{fngcj}) Invoking grmic.
- Generate stubs for Remote Method Invocation.
--* gc-analyze: (gcj)Invoking gc-analyze.
-+* gc-analyze: (@value{fngcj}) Invoking gc-analyze.
- Analyze Garbage Collector (GC) memory dumps.
--* aot-compile: (gcj)Invoking aot-compile.
-+* aot-compile: (@value{fngcj})Invoking aot-compile.
- Compile bytecode to native and generate databases.
--* rebuild-gcj-db: (gcj)Invoking rebuild-gcj-db.
-+* rebuild-gcj-db: (@value{fngcj})Invoking rebuild-gcj-db.
- Merge the per-solib databases made by aot-compile
- into one system-wide database.
- @end direntry
-@@ -159,7 +159,7 @@ and the Info entries for @file{gcj} and
-
- As @command{gcj} is just another front end to @command{gcc}, it supports many
- of the same options as gcc. @xref{Option Summary, , Option Summary,
--gcc, Using the GNU Compiler Collection (GCC)}. This manual only documents the
-+@value{fngcc}, Using the GNU Compiler Collection (GCC)}. This manual only documents the
- options specific to @command{gcj}.
-
- @c man end
-Index: b/src/gcc/java/Make-lang.in
-===================================================================
---- a/src/gcc/java/Make-lang.in
-+++ b/src/gcc/java/Make-lang.in
-@@ -122,9 +122,10 @@ java.tags: force
- etags --include TAGS.sub --include ../TAGS.sub
-
-
--java.info: doc/gcj.info
-+INFO_GCJ_NAME = $(shell echo gcj|sed '$(program_transform_name)')
-+java.info: doc/$(INFO_GCJ_NAME).info
-
--java.srcinfo: doc/gcj.info
-+java.srcinfo: doc/$(INFO_GCJ_NAME).info
- -cp -p $^ $(srcdir)/doc
-
- java.dvi: doc/gcj.dvi
-@@ -190,7 +191,7 @@ java.uninstall:
- -rm -rf $(DESTDIR)$(man1dir)/aot-compile$(man1ext)
- -rm -rf $(DESTDIR)$(man1dir)/rebuild-gcj-db$(man1ext)
-
--java.install-info: $(DESTDIR)$(infodir)/gcj.info
-+java.install-info: $(DESTDIR)$(infodir)/$(INFO_GCJ_NAME).info
-
- java.install-pdf: $(JAVA_PDFFILES)
- @$(NORMAL_INSTALL)
-@@ -273,10 +274,10 @@ TEXI_JAVA_FILES = java/gcj.texi $(gcc_do
- gcc-vers.texi
-
- # Documentation
--doc/gcj.info: $(TEXI_JAVA_FILES)
-+doc/$(INFO_GCJ_NAME).info: $(TEXI_JAVA_FILES)
- if test "x$(BUILD_INFO)" = xinfo; then \
-- rm -f doc/gcj.info*; \
-- $(MAKEINFO) $(MAKEINFOFLAGS) -I $(gcc_docdir) \
-+ rm -f doc/$(INFO_GCJ_NAME).info*; \
-+ $(MAKEINFO) $(MAKEINFOFLAGS) $(MAKEINFODEFS) -I $(gcc_docdir) \
- -I $(gcc_docdir)/include -o $@ $<; \
- else true; fi
-
-Index: b/src/gcc/ada/gnat-style.texi
-===================================================================
--- a/src/gcc/ada/gnat-style.texi
+++ b/src/gcc/ada/gnat-style.texi
@@ -31,7 +31,7 @@ Texts. A copy of the license is include
@@ -329,12 +226,10 @@ Index: b/src/gcc/ada/gnat-style.texi
@dircategory Software development
@direntry
-* gnat-style: (gnat-style). GNAT Coding Style
-+* gnat-style: (gnat-style-6). GNAT Coding Style
++* gnat-style: (gnat-style-9). GNAT Coding Style
@end direntry
@macro syntax{element}
-Index: b/src/gcc/ada/gnat_rm.texi
-===================================================================
--- a/src/gcc/ada/gnat_rm.texi
+++ b/src/gcc/ada/gnat_rm.texi
@@ -12,7 +12,7 @@
@@ -342,15 +237,13 @@ Index: b/src/gcc/ada/gnat_rm.texi
@dircategory GNU Ada Tools
@direntry
-* gnat_rm: (gnat_rm.info). gnat_rm
-+* GNAT Reference Manual: (gnat_rm-6). Reference Manual for GNU Ada tools.
++* GNAT Reference Manual: (gnat_rm-9). Reference Manual for GNU Ada tools.
@end direntry
@definfoenclose strong,`,'
-Index: b/src/gcc/doc/invoke.texi
-===================================================================
--- a/src/gcc/doc/invoke.texi
+++ b/src/gcc/doc/invoke.texi
-@@ -10585,7 +10585,7 @@ One of the standard libraries bypassed b
+@@ -12688,7 +12688,7 @@ One of the standard libraries bypassed b
@option{-nodefaultlibs} is @file{libgcc.a}, a library of internal subroutines
which GCC uses to overcome shortcomings of particular machines, or special
needs for some languages.
@@ -359,7 +252,7 @@ Index: b/src/gcc/doc/invoke.texi
Collection (GCC) Internals},
for more discussion of @file{libgcc.a}.)
In most cases, you need @file{libgcc.a} even when you want to avoid
-@@ -10594,7 +10594,7 @@ or @option{-nodefaultlibs} you should us
+@@ -12697,7 +12697,7 @@ or @option{-nodefaultlibs} you should us
This ensures that you have no unresolved references to internal GCC
library subroutines.
(An example of such an internal subroutine is @code{__main}, used to ensure C++
@@ -368,7 +261,7 @@ Index: b/src/gcc/doc/invoke.texi
GNU Compiler Collection (GCC) Internals}.)
@item -pie
-@@ -25102,7 +25102,7 @@ Note that you can also specify places to
+@@ -29425,7 +29425,7 @@ Note that you can also specify places to
@option{-B}, @option{-I} and @option{-L} (@pxref{Directory Options}). These
take precedence over places specified using environment variables, which
in turn take precedence over those specified by the configuration of GCC@.
@@ -377,7 +270,7 @@ Index: b/src/gcc/doc/invoke.texi
GNU Compiler Collection (GCC) Internals}.
@table @env
-@@ -25262,7 +25262,7 @@ the headers it contains change.
+@@ -29585,7 +29585,7 @@ the headers it contains change.
A precompiled header file is searched for when @code{#include} is
seen in the compilation. As it searches for the included file
@@ -386,11 +279,9 @@ Index: b/src/gcc/doc/invoke.texi
compiler looks for a precompiled header in each directory just before it
looks for the include file in that directory. The name searched for is
the name specified in the @code{#include} with @samp{.gch} appended. If
-Index: b/src/gcc/doc/extend.texi
-===================================================================
--- a/src/gcc/doc/extend.texi
+++ b/src/gcc/doc/extend.texi
-@@ -20136,7 +20136,7 @@ want to write code that checks whether t
+@@ -22892,7 +22892,7 @@ want to write code that checks whether t
test for the GNU compiler the same way as for C programs: check for a
predefined macro @code{__GNUC__}. You can also use @code{__GNUG__} to
test specifically for GNU C++ (@pxref{Common Predefined Macros,,
@@ -399,23 +290,15 @@ Index: b/src/gcc/doc/extend.texi
@menu
* C++ Volatiles:: What constitutes an access to a volatile object.
-Index: b/src/gcc/doc/standards.texi
-===================================================================
--- a/src/gcc/doc/standards.texi
+++ b/src/gcc/doc/standards.texi
-@@ -313,8 +313,8 @@ described at @uref{http://golang.org/doc
+@@ -332,5 +332,5 @@ specification, described at @uref{https:
GNAT Reference Manual}, for information on standard
conformance and compatibility of the Ada compiler.
-@xref{Standards,,Standards, gfortran, The GNU Fortran Compiler}, for details
+@xref{Standards,,Standards, @value{fngfortran}, The GNU Fortran Compiler}, for details
of standards supported by GNU Fortran.
-
--@xref{Compatibility,,Compatibility with the Java Platform, gcj, GNU gcj},
-+@xref{Compatibility,,Compatibility with the Java Platform, @value{fngcj}, GNU gcj},
- for details of compatibility between @command{gcj} and the Java Platform.
-Index: b/src/gcc/doc/libgcc.texi
-===================================================================
--- a/src/gcc/doc/libgcc.texi
+++ b/src/gcc/doc/libgcc.texi
@@ -24,7 +24,7 @@ that needs them.
@@ -427,8 +310,6 @@ Index: b/src/gcc/doc/libgcc.texi
These routines take arguments and return values of a specific machine
mode, not a specific C type. @xref{Machine Modes}, for an explanation
-Index: b/src/gcc/doc/gccint.texi
-===================================================================
--- a/src/gcc/doc/gccint.texi
+++ b/src/gcc/doc/gccint.texi
@@ -49,7 +49,7 @@ Texts being (a) (see below), and with th
@@ -449,8 +330,6 @@ Index: b/src/gcc/doc/gccint.texi
Compiler Collection (GCC)}.
This manual is mainly a reference manual rather than a tutorial. It
-Index: b/src/gcc/doc/cpp.texi
-===================================================================
--- a/src/gcc/doc/cpp.texi
+++ b/src/gcc/doc/cpp.texi
@@ -50,7 +50,7 @@ This manual contains no Invariant Sectio
@@ -462,27 +341,8 @@ Index: b/src/gcc/doc/cpp.texi
@end direntry
@end ifinfo
-Index: b/src/gcc/doc/gcc.texi
-===================================================================
--- a/src/gcc/doc/gcc.texi
+++ b/src/gcc/doc/gcc.texi
-@@ -63,11 +63,11 @@ Texts being (a) (see below), and with th
- @ifnottex
- @dircategory Software development
- @direntry
--* gcc: (gcc). The GNU Compiler Collection.
--* g++: (gcc). The GNU C++ compiler.
--* gcov: (gcc) Gcov. @command{gcov}---a test coverage program.
--* gcov-tool: (gcc) Gcov-tool. @command{gcov-tool}---an offline gcda profile processing program.
--* gcov-dump: (gcc) Gcov-dump. @command{gcov-dump}---an offline gcda and gcno profile dump tool.
-+* @value{fngcc}: (@value{fngcc}). The GNU Compiler Collection.
-+* @value{fngxx}: (@value{fngcc}). The GNU C++ compiler.
-+* @value{fngcov}: (@value{fngcc}) Gcov. @command{gcov}---a test coverage program.
-+* @value{fngcovtool}: (@value{fngcc}) Gcov. @command{gcov-tool}---an offline gcda profile processing program.
-+* @value{fngcovdump}: (@value{fngcc}) Gcov. @command{gcov-dump}---an offline gcda and gcno profile dump tool.
- @end direntry
- This file documents the use of the GNU compilers.
- @sp 1
@@ -127,7 +127,7 @@ version @value{version-GCC}.
The internals of the GNU compilers, including how to port them to new
targets and some information about how to write front ends for new
@@ -492,21 +352,6 @@ Index: b/src/gcc/doc/gcc.texi
@menu
* G++ and GCC:: You can compile C or C++ programs.
-Index: b/src/gcc/doc/makefile.texi
-===================================================================
---- a/src/gcc/doc/makefile.texi
-+++ b/src/gcc/doc/makefile.texi
-@@ -139,7 +139,7 @@ regardless of how it itself was compiled
- Builds a compiler with profiling feedback information. In this case,
- the second and third stages are named @samp{profile} and @samp{feedback},
- respectively. For more information, see
--@ref{Building,,Building with profile feedback,gccinstall,Installing GCC}.
-+@ref{Building,,Building with profile feedback,@value{fngccinstall},Installing GCC}.
-
- @item restrap
- Restart a bootstrap, so that everything that was not built with
-Index: b/src/gcc/doc/install.texi
-===================================================================
--- a/src/gcc/doc/install.texi
+++ b/src/gcc/doc/install.texi
@@ -94,7 +94,7 @@ Free Documentation License}''.
@@ -518,8 +363,6 @@ Index: b/src/gcc/doc/install.texi
@end direntry
@c Part 3 Titlepage and Copyright
-Index: b/src/gcc/doc/cppinternals.texi
-===================================================================
--- a/src/gcc/doc/cppinternals.texi
+++ b/src/gcc/doc/cppinternals.texi
@@ -7,7 +7,7 @@
@@ -531,8 +374,6 @@ Index: b/src/gcc/doc/cppinternals.texi
@end direntry
@end ifinfo
-Index: b/src/libgomp/libgomp.texi
-===================================================================
--- a/src/libgomp/libgomp.texi
+++ b/src/libgomp/libgomp.texi
@@ -31,7 +31,7 @@ texts being (a) (see below), and with th
@@ -544,21 +385,19 @@ Index: b/src/libgomp/libgomp.texi
@end direntry
This manual documents libgomp, the GNU Offloading and Multi Processing
-Index: b/src/libgomp/Makefile.in
-===================================================================
--- a/src/libgomp/Makefile.in
+++ b/src/libgomp/Makefile.in
-@@ -484,7 +484,8 @@ info_TEXINFOS = libgomp.texi
+@@ -600,7 +600,8 @@ info_TEXINFOS = libgomp.texi
# AM_CONDITIONAL on configure check ACX_CHECK_PROG_VER([MAKEINFO])
@BUILD_INFO_TRUE@STAMP_BUILD_INFO = stamp-build-info
--CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libgomp.info
+-CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO)
+INFO_LIBGOMP_NAME = $(shell echo libgomp|sed '$(program_transform_name)')
+CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) $(INFO_LIBGOMP_NAME).info
MAINTAINERCLEANFILES = $(srcdir)/libgomp.info
- all: config.h
- $(MAKE) $(AM_MAKEFLAGS) all-recursive
-@@ -1296,15 +1297,16 @@ env.lo: libgomp_f.h
+ MULTISRCTOP =
+ MULTIBUILDTOP =
+@@ -1374,15 +1375,16 @@ env.lo: libgomp_f.h
env.o: libgomp_f.h
all-local: $(STAMP_GENINSRC)
@@ -579,18 +418,15 @@ Index: b/src/libgomp/Makefile.in
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -D 'fnlibgomp $(INFO_LIBGOMP_NAME)' -I $(srcdir) -o $(INFO_LIBGOMP_NAME).info $(srcdir)/libgomp.texi
@touch $@
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
-Index: b/src/libgomp/Makefile.am
-===================================================================
+ # GNU Make needs to see an explicit $(MAKE) variable in the command it
--- a/src/libgomp/Makefile.am
+++ b/src/libgomp/Makefile.am
-@@ -125,16 +125,19 @@ endif
+@@ -126,14 +126,16 @@ endif
all-local: $(STAMP_GENINSRC)
-stamp-geninsrc: libgomp.info
- cp -p $(top_builddir)/libgomp.info $(srcdir)/libgomp.info
-+INFO_LIBGOMP_NAME = $(shell echo libgomp|sed '$(program_transform_name)')
+stamp-geninsrc: $(INFO_LIBGOMP_NAME).info
+ cp -p $(top_builddir)/$(INFO_LIBGOMP_NAME).info $(srcdir)/libgomp.info
@touch $@
@@ -606,11 +442,6 @@ Index: b/src/libgomp/Makefile.am
@touch $@
--CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libgomp.info
-+CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) $(INFO_LIBGOMP_NAME).info
- MAINTAINERCLEANFILES = $(srcdir)/libgomp.info
-Index: b/src/libitm/libitm.texi
-===================================================================
--- a/src/libitm/libitm.texi
+++ b/src/libitm/libitm.texi
@@ -20,7 +20,7 @@ Free Documentation License''.
@@ -622,11 +453,9 @@ Index: b/src/libitm/libitm.texi
@end direntry
This manual documents the GNU Transactional Memory Library.
-Index: b/src/libitm/Makefile.am
-===================================================================
--- a/src/libitm/Makefile.am
+++ b/src/libitm/Makefile.am
-@@ -107,14 +107,17 @@ endif
+@@ -108,14 +108,17 @@ endif
all-local: $(STAMP_GENINSRC)
@@ -648,11 +477,9 @@ Index: b/src/libitm/Makefile.am
@touch $@
-Index: b/src/libitm/Makefile.in
-===================================================================
--- a/src/libitm/Makefile.in
+++ b/src/libitm/Makefile.in
-@@ -1103,14 +1103,17 @@ vpath % $(strip $(search_path))
+@@ -1186,14 +1186,17 @@ vpath % $(strip $(search_path))
all-local: $(STAMP_GENINSRC)
@@ -673,12 +500,10 @@ Index: b/src/libitm/Makefile.in
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -D 'fnlibitm $(INFO_LIBITM_NAME)' -o $(INFO_LIBITM_NAME).info $(srcdir)/libitm.texi
@touch $@
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
-Index: b/src/gcc/go/Make-lang.in
-===================================================================
+ # GNU Make needs to see an explicit $(MAKE) variable in the command it
--- a/src/gcc/go/Make-lang.in
+++ b/src/gcc/go/Make-lang.in
-@@ -86,10 +86,11 @@ GO_TEXI_FILES = \
+@@ -91,10 +91,11 @@ GO_TEXI_FILES = \
$(gcc_docdir)/include/gcc-common.texi \
gcc-vers.texi
@@ -693,7 +518,7 @@ Index: b/src/gcc/go/Make-lang.in
-I $(gcc_docdir)/include -o $@ $<; \
else true; fi
-@@ -115,7 +116,7 @@ gccgo.pod: go/gccgo.texi
+@@ -120,7 +121,7 @@ gccgo.pod: go/gccgo.texi
go.all.cross: gccgo-cross$(exeext)
go.start.encap: gccgo$(exeext)
go.rest.encap:
@@ -702,7 +527,7 @@ Index: b/src/gcc/go/Make-lang.in
go.dvi: doc/gccgo.dvi
go.pdf: doc/gccgo.pdf
go.html: $(build_htmldir)/go/index.html
-@@ -151,7 +152,7 @@ go.install-common: installdirs
+@@ -159,7 +160,7 @@ go.install-common: installdirs
go.install-plugin:
@@ -711,7 +536,7 @@ Index: b/src/gcc/go/Make-lang.in
go.install-pdf: doc/gccgo.pdf
@$(NORMAL_INSTALL)
-@@ -191,7 +192,7 @@ go.uninstall:
+@@ -199,7 +200,7 @@ go.uninstall:
rm -rf $(DESTDIR)$(bindir)/$(GCCGO_INSTALL_NAME)$(exeext)
rm -rf $(DESTDIR)$(man1dir)/$(GCCGO_INSTALL_NAME)$(man1ext)
rm -rf $(DESTDIR)$(bindir)/$(GCCGO_TARGET_INSTALL_NAME)$(exeext)
@@ -720,8 +545,6 @@ Index: b/src/gcc/go/Make-lang.in
# Clean hooks.
-Index: b/src/gcc/go/gccgo.texi
-===================================================================
--- a/src/gcc/go/gccgo.texi
+++ b/src/gcc/go/gccgo.texi
@@ -50,7 +50,7 @@ man page gfdl(7).
@@ -733,7 +556,7 @@ Index: b/src/gcc/go/gccgo.texi
@end direntry
@end format
-@@ -123,7 +123,7 @@ and the Info entries for @file{gccgo} an
+@@ -124,7 +124,7 @@ and the Info entries for @file{gccgo} an
The @command{gccgo} command is a frontend to @command{gcc} and
supports many of the same options. @xref{Option Summary, , Option
@@ -742,8 +565,6 @@ Index: b/src/gcc/go/gccgo.texi
only documents the options specific to @command{gccgo}.
The @command{gccgo} command may be used to compile Go source code into
-Index: b/src/libquadmath/libquadmath.texi
-===================================================================
--- a/src/libquadmath/libquadmath.texi
+++ b/src/libquadmath/libquadmath.texi
@@ -25,7 +25,7 @@ copy and modify this GNU manual.
@@ -755,13 +576,11 @@ Index: b/src/libquadmath/libquadmath.texi
@end direntry
This manual documents the GCC Quad-Precision Math Library API.
-Index: b/src/libquadmath/Makefile.am
-===================================================================
--- a/src/libquadmath/Makefile.am
+++ b/src/libquadmath/Makefile.am
-@@ -133,22 +133,24 @@ endif
+@@ -132,16 +132,18 @@ STAMP_BUILD_INFO =
+ endif
- all-local: $(STAMP_GENINSRC)
-stamp-geninsrc: libquadmath.info
- cp -p $(top_builddir)/libquadmath.info $(srcdir)/libquadmath.info
@@ -776,48 +595,39 @@ Index: b/src/libquadmath/Makefile.am
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o $(INFO_LIBQMATH_NAME).info $(srcdir)/libquadmath.texi
@touch $@
--CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libquadmath.info
+-CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO)
-MAINTAINERCLEANFILES = $(srcdir)/libquadmath.info
+CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) $(INFO_LIBQMATH_NAME).info
+MAINTAINERCLEANFILES = $(srcdir)/$(INFO_LIBQMATH_NAME).info
endif BUILD_LIBQUADMATH
- # Unconditionally override this target, so that automake's definition
- # does not wrongly interfere.
--libquadmath.info: $(STAMP_BUILD_INFO)
-+$(INFO_LIBQMATH_NAME).info: $(STAMP_BUILD_INFO)
-
-
- # Automake Documentation:
-Index: b/src/libquadmath/Makefile.in
-===================================================================
--- a/src/libquadmath/Makefile.in
+++ b/src/libquadmath/Makefile.in
-@@ -193,7 +193,8 @@ MULTIDIRS =
- MULTISUBDIR =
- MULTIDO = true
- MULTICLEAN = true
+@@ -277,7 +277,8 @@ AM_V_texidevnull = $(am__v_texidevnull_@
+ am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V@)
+ am__v_texidevnull_0 = > /dev/null
+ am__v_texidevnull_1 =
-INFO_DEPS = libquadmath.info
+INFO_LIBQMATH_NAME = $(shell echo libquadmath|sed '$(program_transform_name)')
+INFO_DEPS = $(INFO_LIBQMATH_NAME).info
am__TEXINFO_TEX_DIR = $(srcdir)/../gcc/doc/include
DVIS = libquadmath.dvi
PDFS = libquadmath.pdf
-@@ -435,8 +436,8 @@ AUTOMAKE_OPTIONS = 1.8 foreign
+@@ -544,8 +545,8 @@ AUTOMAKE_OPTIONS = foreign info-in-build
# AM_CONDITIONAL on configure check ACX_CHECK_PROG_VER([MAKEINFO])
@BUILD_INFO_TRUE@@BUILD_LIBQUADMATH_TRUE@STAMP_BUILD_INFO = stamp-build-info
--@BUILD_LIBQUADMATH_TRUE@CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libquadmath.info
+-@BUILD_LIBQUADMATH_TRUE@CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO)
-@BUILD_LIBQUADMATH_TRUE@MAINTAINERCLEANFILES = $(srcdir)/libquadmath.info
+@BUILD_LIBQUADMATH_TRUE@CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) $(INFO_LIBQMATH_NAME).info
+@BUILD_LIBQUADMATH_TRUE@MAINTAINERCLEANFILES = $(srcdir)/$(INFO_LIBQMATH_NAME).info
# Automake Documentation:
# If your package has Texinfo files in many directories, you can use the
-@@ -1517,17 +1518,17 @@ uninstall-am: uninstall-dvi-am uninstall
-
- @BUILD_LIBQUADMATH_TRUE@all-local: $(STAMP_GENINSRC)
+@@ -1408,19 +1409,19 @@ uninstall-am: uninstall-dvi-am uninstall
+ @BUILD_LIBQUADMATH_TRUE@@LIBQUAD_USE_SYMVER_SUN_TRUE@@LIBQUAD_USE_SYMVER_TRUE@ sed 's,\([^/ ]*\)\.l\([ao]\),.libs/\1.\2,g'` \
+ @BUILD_LIBQUADMATH_TRUE@@LIBQUAD_USE_SYMVER_SUN_TRUE@@LIBQUAD_USE_SYMVER_TRUE@ > $@ || (rm -f $@ ; exit 1)
-@BUILD_LIBQUADMATH_TRUE@stamp-geninsrc: libquadmath.info
-@BUILD_LIBQUADMATH_TRUE@ cp -p $(top_builddir)/libquadmath.info $(srcdir)/libquadmath.info
@@ -830,6 +640,8 @@ Index: b/src/libquadmath/Makefile.in
+@BUILD_LIBQUADMATH_TRUE@ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o $(INFO_LIBQMATH_NAME).info $(srcdir)/libquadmath.texi
@BUILD_LIBQUADMATH_TRUE@ @touch $@
+ all-local: $(ALL_LOCAL_DEPS)
+
# Unconditionally override this target, so that automake's definition
# does not wrongly interfere.
-libquadmath.info: $(STAMP_BUILD_INFO)