summaryrefslogtreecommitdiff
path: root/debian/rules.conf
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.conf')
-rw-r--r--debian/rules.conf16
1 files changed, 14 insertions, 2 deletions
diff --git a/debian/rules.conf b/debian/rules.conf
index 923fe01..e4aff86 100644
--- a/debian/rules.conf
+++ b/debian/rules.conf
@@ -140,7 +140,7 @@ endef
base_deb_cpus := amd64 i386 alpha
base_deb_systems :=
$(foreach x,ada java java_plugin fortran libgphobos libgc check locale,$(eval $(call gen_no_archs,$(x),$(base_deb_cpus),$(base_deb_systems))))
-linux_no_archs := !hurd-any !kfreebsd-any
+linux_no_archs := !hurd-any !kfreebsd-any !illumos-any
GCC_VERSION := $(strip $(shell cat $(firstword $(wildcard $(srcdir)/gcc/FULL-VER $(srcdir)/gcc/BASE-VER))))
NEXT_GCC_VERSION := $(shell echo $(GCC_VERSION) | \
@@ -253,6 +253,12 @@ ifeq ($(with_multiarch_lib),yes)
else
libc_dev_ver := 2.13-0ubuntu6
endif
+ ifeq ($(DEB_TARGET_ARCH_OS),illumos)
+ LIBC_DEP = libc1
+ libc_ver := 4.3+17
+ libc_dev_ver := 4.3+17
+ libc_dev := 4.3+17
+ endif
endif
# first set LIBC_DEP/LIBC_DEV_DEP for native builds only
ifeq ($(DEB_TARGET_ARCH_OS),linux)
@@ -287,6 +293,7 @@ biarch_deb_map := \
sparc=sparc64 sparc64=sparc\
s390=s390x s390x=s390 \
kfreebsd-amd64=i386 \
+ illumos-amd64=illumos-i386 \
armel=armhf \
armhf=armel
biarch_deb_arch := $(patsubst $(DEB_TARGET_ARCH)=%,%, \
@@ -341,16 +348,18 @@ LIBC_DEP := $(LIBC_DEP)$(LS)$(AQ)
LIBC_DEV_DEP := $(LIBC_DEV_DEP)$(LS)$(AQ) (>= $(libc_dev_ver))
ifneq (,$(filter $(build_type), build-native cross-build-native))
- LIBC_DBG_DEP = libc6.1-dbg [alpha ia64] | libc0.3-dbg [hurd-i386] | libc0.1-dbg [kfreebsd-i386 kfreebsd-amd64] | libc6-dbg,
+ LIBC_DBG_DEP = libc6.1-dbg [alpha ia64] | libc0.3-dbg [hurd-i386] | libc0.1-dbg [kfreebsd-i386 kfreebsd-amd64] | libc6-dbg [!illumos-any],
endif
# TODO: make this automatic, there must be a better way to define LIBC_DEP.
ifneq ($(DEB_CROSS),yes)
LIBC_BUILD_DEP = libc6.1-dev (>= $(libc_dev_ver)) [alpha ia64] | libc0.3-dev (>= $(libc_dev_ver)) [hurd-i386] | libc0.1-dev (>= $(libc_dev_ver)) [kfreebsd-i386 kfreebsd-amd64] | libc6-dev (>= $(libc_dev_ver))
+ LIBC_BUILD_DEP += | libc1-dev (>= $(libc_dev_ver)) [illumos-amd64]
ifeq (,$(filter $(distrelease),lenny etch squeeze dapper hardy jaunty karmic lucid maverick natty oneiric))
LIBC_BUILD_DEP += , libc6-dev (>= 2.13-31) [armel armhf]
endif
LIBC_BIARCH_BUILD_DEP = libc6-dev-amd64 [i386 x32], libc6-dev-sparc64 [sparc], libc6-dev-sparc [sparc64], libc6-dev-s390 [s390x], libc6-dev-s390x [s390], libc6-dev-i386 [amd64 x32], libc6-dev-powerpc [ppc64], libc6-dev-ppc64 [powerpc], libc0.1-dev-i386 [kfreebsd-amd64], lib32gcc1 [amd64 ppc64 kfreebsd-amd64 mipsn32 mipsn32el mips64 mips64el s390x sparc64 x32], libn32gcc1 [mips mipsel mips64 mips64el], lib64gcc1 [i386 mips mipsel mipsn32 mipsn32el powerpc sparc s390 x32], libc6-dev-mips64 [mips mipsel mipsn32 mipsn32el], libc6-dev-mipsn32 [mips mipsel mips64 mips64el], libc6-dev-mips32 [mipsn32 mipsn32el mips64 mips64el],
+ LIBC_BIARCH_BUILD_DEP += libc1-dev-illumos-i386 (>= $(libc_dev_ver)) [illumos-amd64],
ifneq (,$(findstring amd64,$(biarchx32archs)))
LIBC_BIARCH_BUILD_DEP += libc6-dev-x32 [amd64 i386], libx32gcc1 [amd64 i386],
endif
@@ -839,6 +848,9 @@ ifeq ($(with_libgomp),yes)
addons += $(if $(findstring armel,$(biarchhfarchs)),libhfgomp)
addons += $(if $(findstring armhf,$(biarchsfarchs)),libsfgomp)
endif
+ifeq ($(with_ssp),yes)
+ addons += libssp lib32ssp lib64ssp
+endif
ifeq ($(with_libitm),yes)
addons += libitm lib32itm lib64itm libn32itm
addons += $(if $(findstring amd64,$(biarchx32archs)),libx32itm)