summaryrefslogtreecommitdiff
path: root/beadm/debian/patches/illumos-3352-lib64be.patch
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2013-01-09 01:12:33 +0400
committerIgor Pashev <pashev.igor@gmail.com>2013-01-09 01:12:33 +0400
commitb1ee29e12b62103c942f7e27938e2b8560ae7b9f (patch)
treee1ac97adfc6016705e1e24a5bb34c52e600f0a25 /beadm/debian/patches/illumos-3352-lib64be.patch
parent40624c920f83478792cb9dfdf3600e9376b6a779 (diff)
downloadillumos-packaging-b1ee29e12b62103c942f7e27938e2b8560ae7b9f.tar.gz
beadm
Diffstat (limited to 'beadm/debian/patches/illumos-3352-lib64be.patch')
-rw-r--r--beadm/debian/patches/illumos-3352-lib64be.patch122
1 files changed, 122 insertions, 0 deletions
diff --git a/beadm/debian/patches/illumos-3352-lib64be.patch b/beadm/debian/patches/illumos-3352-lib64be.patch
new file mode 100644
index 0000000..51b8fd4
--- /dev/null
+++ b/beadm/debian/patches/illumos-3352-lib64be.patch
@@ -0,0 +1,122 @@
+commit f5c2e7ea56aaa46a9976476fb0cb1f02b9426f07
+Author: Theo Schlossnagle <jesus@omniti.com>
+Date: Thu Dec 6 16:29:54 2012 -0800
+
+ 3352 would like 64bit install libraries
+ Reviewed by: Garrett D'Amore <garrett@damore.org>
+ Reviewed by: Richard Lowe <richlowe@richlowe.net>
+ Reviewed by: Igor Kozhukhov <ikozhukhov@gmail.com>
+ Reviewed by: Christopher Siden <chris.siden@delphix.com>
+ Approved by: Garrett D'Amore <garrett@damore.org>
+
+diff --git a/usr/src/lib/libbe/Makefile b/usr/src/lib/libbe/Makefile
+index 9dd98e3..0e68a32 100644
+--- a/usr/src/lib/libbe/Makefile
++++ b/usr/src/lib/libbe/Makefile
+@@ -21,6 +21,7 @@
+
+ #
+ # Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
++# Copyright 2012 OmniTI Computer Consulting, Inc. All rights reserved.
+ #
+
+ include ../Makefile.lib
+@@ -31,6 +32,7 @@ HDRS= libbe.h \
+ HDRDIR= common
+
+ SUBDIRS= $(MACH)
++$(BUILD64)SUBDIRS += $(MACH64)
+
+ all := TARGET= all
+ clean := TARGET= clean
+diff --git a/usr/src/lib/libbe/Makefile.com b/usr/src/lib/libbe/Makefile.com
+index b8349c1..013d2bd 100644
+--- a/usr/src/lib/libbe/Makefile.com
++++ b/usr/src/lib/libbe/Makefile.com
+@@ -23,6 +23,7 @@
+ # Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
+ #
+ # Copyright 2011 Nexenta Systems, Inc. All rights reserved.
++# Copyright 2012 OmniTI Computer Consulting, Inc. All rights reserved.
+ #
+
+
+@@ -63,6 +64,4 @@ all: $(LIBS) $(LIBRARY)
+
+ lint: lintcheck
+
+-install: $(ROOTLIBS)
+-
+ include ../../Makefile.targ
+diff --git a/usr/src/lib/libbe/amd64/Makefile b/usr/src/lib/libbe/amd64/Makefile
+new file mode 100644
+index 0000000..5d3fa15
+--- /dev/null
++++ b/usr/src/lib/libbe/amd64/Makefile
+@@ -0,0 +1,30 @@
++#
++# CDDL HEADER START
++#
++# The contents of this file are subject to the terms of the
++# Common Development and Distribution License, Version 1.0 only
++# (the "License"). You may not use this file except in compliance
++# with the License.
++#
++# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
++# or http://www.opensolaris.org/os/licensing.
++# See the License for the specific language governing permissions
++# and limitations under the License.
++#
++# When distributing Covered Code, include this CDDL HEADER in each
++# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
++# If applicable, add the following below this CDDL HEADER, with the
++# fields enclosed by brackets "[]" replaced with your own identifying
++# information: Portions Copyright [yyyy] [name of copyright owner]
++#
++# CDDL HEADER END
++#
++#
++# Copyright 2011 OmniTI Computer Consulting, Inc. All rights reserved.
++# Use is subject to license terms.
++#
++
++include ../Makefile.com
++include ../../Makefile.lib.64
++
++install: all $(ROOTLIBS64) $(ROOTLINKS64) $(ROOTLINT64)
+diff --git a/usr/src/lib/libbe/sparcv9/Makefile b/usr/src/lib/libbe/sparcv9/Makefile
+new file mode 100644
+index 0000000..5d3fa15
+--- /dev/null
++++ b/usr/src/lib/libbe/sparcv9/Makefile
+@@ -0,0 +1,30 @@
++#
++# CDDL HEADER START
++#
++# The contents of this file are subject to the terms of the
++# Common Development and Distribution License, Version 1.0 only
++# (the "License"). You may not use this file except in compliance
++# with the License.
++#
++# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
++# or http://www.opensolaris.org/os/licensing.
++# See the License for the specific language governing permissions
++# and limitations under the License.
++#
++# When distributing Covered Code, include this CDDL HEADER in each
++# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
++# If applicable, add the following below this CDDL HEADER, with the
++# fields enclosed by brackets "[]" replaced with your own identifying
++# information: Portions Copyright [yyyy] [name of copyright owner]
++#
++# CDDL HEADER END
++#
++#
++# Copyright 2011 OmniTI Computer Consulting, Inc. All rights reserved.
++# Use is subject to license terms.
++#
++
++include ../Makefile.com
++include ../../Makefile.lib.64
++
++install: all $(ROOTLIBS64) $(ROOTLINKS64) $(ROOTLINT64)