summaryrefslogtreecommitdiff
path: root/libc/debian/patches/localedef.patch
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2015-10-21 11:46:19 +0300
committerIgor Pashev <pashev.igor@gmail.com>2015-10-21 11:46:19 +0300
commitb01ba1daf4b36ff92a96415075dcb2e3cb7c2fb7 (patch)
tree95a23c0b9a42532fa8f5edc0112278f979d8066c /libc/debian/patches/localedef.patch
parenta26e5b562d25b5391aab278be9bed8096b8d238c (diff)
downloadillumos-packaging-b01ba1daf4b36ff92a96415075dcb2e3cb7c2fb7.tar.gz
Updated patches
Diffstat (limited to 'libc/debian/patches/localedef.patch')
-rw-r--r--libc/debian/patches/localedef.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/libc/debian/patches/localedef.patch b/libc/debian/patches/localedef.patch
new file mode 100644
index 0000000..ece575f
--- /dev/null
+++ b/libc/debian/patches/localedef.patch
@@ -0,0 +1,24 @@
+Description:
+ 1. yylex() - implicit declaration
+ 2. yydebug() - undefined at link time (fixed with -t)
+Index: libc/usr/src/cmd/localedef/Makefile
+===================================================================
+--- libc.orig/usr/src/cmd/localedef/Makefile
++++ libc/usr/src/cmd/localedef/Makefile
+@@ -36,6 +36,7 @@ NATIVE_CPPFLAGS += -I $(SRC)/lib/libc/po
+ CERRWARN += -_gcc=-Wno-char-subscripts
+ CERRWARN += -_gcc=-Wno-uninitialized
+ CERRWARN += -_gcc=-Wno-unused-label
++CERRWARN += -_gcc=-Wno-implicit-function-declaration
+ LDLIBS += -lgen
+ LDLIBS += -lavl
+ NATIVELDLIBS += -lgen
+@@ -48,7 +49,7 @@ NATIVELDLIBS += -lgen
+ # we regrettably have to link explicitly against the full library path. Sorry.
+ #
+ NATIVELDLIBS += /usr/lib/libavl.so.1
+-YFLAGS = -d -b parser
++YFLAGS = -t -d -b parser
+
+ CLEANFILES = $(NOBJS) $(OBJS) parser.tab.c parser.tab.h
+ CLEANFILES += \