summaryrefslogtreecommitdiff
path: root/libc/debian/patches
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2015-03-27 12:39:22 +0300
committerIgor Pashev <pashev.igor@gmail.com>2015-03-27 12:39:22 +0300
commit24f010c6b691a7f655b3249626b1a9ca9acfedad (patch)
tree526e11aaf88863bc9dbe999fec9d7d0fdfc0465b /libc/debian/patches
parenta01819f4e528ab0832a71321e0716ee546b65e3d (diff)
downloadillumos-packaging-24f010c6b691a7f655b3249626b1a9ca9acfedad.tar.gz
libc (4.3+12) unstable; urgency=medium
* Added execvpe (debian/patches/execvpe.patch) * Removed statfs (debian/patches/remove-statfs.patch)
Diffstat (limited to 'libc/debian/patches')
-rw-r--r--libc/debian/patches/execvpe.patch70
-rw-r--r--libc/debian/patches/remove-statfs.patch60
-rw-r--r--libc/debian/patches/series2
3 files changed, 132 insertions, 0 deletions
diff --git a/libc/debian/patches/execvpe.patch b/libc/debian/patches/execvpe.patch
new file mode 100644
index 0000000..918ac11
--- /dev/null
+++ b/libc/debian/patches/execvpe.patch
@@ -0,0 +1,70 @@
+Index: libc/usr/src/lib/libc/port/gen/execvp.c
+===================================================================
+--- libc.orig/usr/src/lib/libc/port/gen/execvp.c
++++ libc/usr/src/lib/libc/port/gen/execvp.c
+@@ -104,7 +104,7 @@ execlp(const char *name, const char *arg
+ }
+
+ int
+-execvp(const char *name, char *const *argv)
++execvpe(const char *name, char *const *argv, char *const *envp)
+ {
+ const char *pathstr;
+ char fname[PATH_MAX+2];
+@@ -164,7 +164,7 @@ execvp(const char *name, char *const *ar
+ fname[0] = '.';
+ fname[1] = '/';
+ }
+- (void) execv(fname, argv);
++ (void) execve(fname, argv, envp);
+ switch (errno) {
+ case ENOEXEC:
+ newargs[0] = "sh";
+@@ -175,7 +175,7 @@ execvp(const char *name, char *const *ar
+ return (-1);
+ }
+ }
+- (void) execv(_PATH_BSHELL, newargs);
++ (void) execve(_PATH_BSHELL, newargs, envp);
+ return (-1);
+ case ETXTBSY:
+ if (++etxtbsy > 5)
+@@ -196,6 +196,12 @@ execvp(const char *name, char *const *ar
+ return (-1);
+ }
+
++int
++execvp(const char *name, char *const *argv)
++{
++ return execvpe(name, argv, NULL);
++}
++
+ static const char *
+ execat(const char *s1, const char *s2, char *si)
+ {
+Index: libc/usr/src/lib/libc/port/mapfile-vers
+===================================================================
+--- libc.orig/usr/src/lib/libc/port/mapfile-vers
++++ libc/usr/src/lib/libc/port/mapfile-vers
+@@ -127,6 +127,7 @@ SYMBOL_VERSION DYSON_1 {
+ error_message_count;
+ error_one_per_line;
+ error_print_progname;
++ execvpe;
+ flock;
+ fts_children;
+ fts_close;
+Index: libc/usr/src/head/unistd.h
+===================================================================
+--- libc.orig/usr/src/head/unistd.h
++++ libc/usr/src/head/unistd.h
+@@ -291,6 +291,9 @@ extern int execlp(const char *, const ch
+ extern int execv(const char *, char *const *);
+ extern int execve(const char *, char *const *, char *const *);
+ extern int execvp(const char *, char *const *);
++#if defined(_GNU_SOURCE) || defined(__EXTENSIONS__)
++extern int execvpe(const char *, char *const *, char *const *);
++#endif
+ extern void _exit(int)
+ __NORETURN;
+ /*
diff --git a/libc/debian/patches/remove-statfs.patch b/libc/debian/patches/remove-statfs.patch
new file mode 100644
index 0000000..b3e0c9b
--- /dev/null
+++ b/libc/debian/patches/remove-statfs.patch
@@ -0,0 +1,60 @@
+Index: libc/usr/src/lib/libc/port/mapfile-vers
+===================================================================
+--- libc.orig/usr/src/lib/libc/port/mapfile-vers
++++ libc/usr/src/lib/libc/port/mapfile-vers
+@@ -1628,7 +1628,6 @@ $endif
+ fpgetsticky;
+ fpsetmask;
+ fpsetsticky;
+- fstatfs;
+ ftruncate;
+ ftw;
+ func_to_decimal;
+@@ -1760,7 +1759,6 @@ $endif
+ single_to_decimal;
+ srand48;
+ ssignal;
+- statfs;
+ str2sig;
+ strcasecmp;
+ string_to_decimal;
+Index: libc/usr/src/lib/libc/amd64/Makefile
+===================================================================
+--- libc.orig/usr/src/lib/libc/amd64/Makefile
++++ libc/usr/src/lib/libc/amd64/Makefile
+@@ -190,7 +190,6 @@ COMSYSOBJS= \
+ fdsync.o \
+ flock.o \
+ fpathconf.o \
+- fstatfs.o \
+ fstatvfs.o \
+ getcpuid.o \
+ getdents.o \
+@@ -253,7 +252,6 @@ COMSYSOBJS= \
+ sigprocmsk.o \
+ sigsendset.o \
+ sigsuspend.o \
+- statfs.o \
+ statvfs.o \
+ stty.o \
+ sync.o \
+Index: libc/usr/src/lib/libc/i386/Makefile.com
+===================================================================
+--- libc.orig/usr/src/lib/libc/i386/Makefile.com
++++ libc/usr/src/lib/libc/i386/Makefile.com
+@@ -212,7 +212,6 @@ COMSYSOBJS= \
+ fdsync.o \
+ flock.o \
+ fpathconf.o \
+- fstatfs.o \
+ fstatvfs.o \
+ getcpuid.o \
+ getdents.o \
+@@ -274,7 +273,6 @@ COMSYSOBJS= \
+ sigprocmsk.o \
+ sigsendset.o \
+ sigsuspend.o \
+- statfs.o \
+ statvfs.o \
+ stty.o \
+ sync.o \
diff --git a/libc/debian/patches/series b/libc/debian/patches/series
index 1241add..42a3cac 100644
--- a/libc/debian/patches/series
+++ b/libc/debian/patches/series
@@ -118,3 +118,5 @@ gnu-basename.patch
struct-tm.patch
i386-regset.patch
libnsl-getdomainname.patch
+execvpe.patch
+remove-statfs.patch