summaryrefslogtreecommitdiff
path: root/libproject/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2012-10-30 22:19:17 +0400
committerIgor Pashev <pashev.igor@gmail.com>2012-10-30 22:28:09 +0400
commitc6b7ec93cbd3e15fab1a2a2244d0f006f8d21823 (patch)
treeaf1072f6cfa98bc5589c2a4cc6c8db5e46a5848a /libproject/debian/rules
parent7a228b5ba16edd1663dcf173ac403c9ee925da09 (diff)
downloadillumos-packaging-c6b7ec93cbd3e15fab1a2a2244d0f006f8d21823.tar.gz
libproject
Diffstat (limited to 'libproject/debian/rules')
-rwxr-xr-xlibproject/debian/rules92
1 files changed, 92 insertions, 0 deletions
diff --git a/libproject/debian/rules b/libproject/debian/rules
new file mode 100755
index 0000000..c6465b5
--- /dev/null
+++ b/libproject/debian/rules
@@ -0,0 +1,92 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/architecture.mk
+export DH_VERBOSE = 1
+
+# libs having "install_h" target to install headers:
+libs_headers := \
+libproject \
+
+# All libraries to build and to package.
+# Order is important:
+libs := $(libs_headers) \
+
+
+unpack: unpack-stamp
+unpack-stamp:
+ dh_testdir
+ dh_illumos_gate --build \
+ $(libs:%=usr/src/lib/%) \
+ usr/src/head/project.h
+
+ # Not used and buggy:
+ echo > usr/src/Makefile.msg.targ
+ touch $@
+
+patch: patch-stamp
+patch-stamp: unpack-stamp
+ dh_testdir
+ [ ! -f debian/patches/series ] || QUILT_PATCHES=debian/patches quilt push -a || test $$? = 2
+ touch $@
+
+unpatch:
+ dh_testdir
+ [ ! -f debian/patches/series ] || QUILT_PATCHES=debian/patches quilt pop -a -f || test $$? = 2
+ rm -f patch-stamp
+
+dirs-stamp:
+ . usr/env.sh; mkdir -p \
+ debian/tmp/usr/include \
+ debian/tmp$$DEB_LIBDIR_32 \
+ debian/tmp$$DEB_LIBDIR_64 \
+ debian/tmp$$DEB_USRLIBDIR_32 \
+ debian/tmp$$DEB_USRLIBDIR_64 \
+
+headers-stamp: patch-stamp dirs-stamp
+ cp usr/src/head/project.h debian/tmp/usr/include/
+ touch $@
+
+install build build-arch build-indep: build-stamp
+build-stamp: patch-stamp dirs-stamp headers-stamp
+ dh_illumos_make $(libs:%=usr/src/lib/%)
+ # Move dev symlink from /lib into /usr/lib:
+ for l in `find debian/tmp/lib32 -maxdepth 1 -type l -name \*.so`; do \
+ ln -sf `readlink -f $$l` debian/tmp/usr/lib32/`basename $$l`; \
+ rm $$l; \
+ done
+ for l in `find debian/tmp/lib/$(DEB_HOST_MULTIARCH) -maxdepth 1 -type l -name \*.so`; do \
+ ln -sf `readlink -f $$l` debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/`basename $$l`; \
+ rm $$l; \
+ done
+ # Make symlinks relative:
+ symlinks -c debian/tmp/usr/lib32
+ symlinks -c debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
+ touch $@
+
+binary binary-arch binary-indep: binary-stamp
+binary-stamp: build-stamp
+ dh_testdir
+ dh_testroot
+ dh_installdirs
+ dh_install
+ dh_installman
+ dh_installdocs
+ dh_installexamples
+ dh_installchangelogs
+ dh_link
+ dh_compress
+ dh_fixperms
+ dh_makeshlibs -- -c4
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+ touch $@
+
+clean: unpatch
+ dh_testdir
+ dh_testroot
+ dh_clean
+ rm -rf usr
+