summaryrefslogtreecommitdiff
path: root/onbld/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2012-10-19 09:34:08 +0400
committerIgor Pashev <pashev.igor@gmail.com>2012-10-19 09:34:08 +0400
commit139969e1bccfc63cdc37afc5e4185d864fc72d30 (patch)
tree91f90f059735383fbbc14e06486938950c8b62d8 /onbld/debian/rules
parent51715c96b755bc336fa13384dc5620172453502c (diff)
downloadillumos-packaging-139969e1bccfc63cdc37afc5e4185d864fc72d30.tar.gz
onbld: strip illumos-gate/ to ease importing patches
Diffstat (limited to 'onbld/debian/rules')
-rwxr-xr-xonbld/debian/rules14
1 files changed, 7 insertions, 7 deletions
diff --git a/onbld/debian/rules b/onbld/debian/rules
index daf7700..846d9ac 100755
--- a/onbld/debian/rules
+++ b/onbld/debian/rules
@@ -7,8 +7,8 @@ unpack-stamp:
dh_testdir
dh_illumos_gate
# install into debian/tmp:
- echo 'export TOOLS_PROTO="$$ROOT"' >> illumos-gate/env.sh
- sed -i '/^TOOLS_PROTO=/d' illumos-gate/bldenv.sh
+ echo 'export TOOLS_PROTO="$$ROOT"' >> usr/env.sh
+ sed -i '/^TOOLS_PROTO=/d' usr/bldenv.sh
touch $@
patch: patch-stamp
@@ -31,20 +31,20 @@ build-stamp: patch-stamp
# libncurses.so is actually linker script
# and sunld does not understand it,
# but we do not need sunld here ;-)
- sed -i -r 's/.*(export +LD_ALTEXEC.*)/#\1/' illumos-gate/env.sh
+ sed -i -r 's/.*(export +LD_ALTEXEC.*)/#\1/' usr/env.sh
dh_illumos_make --no-onbld --native usr/src/tools
# Then we need sunld:
- sed -i -r 's/#(export +LD_ALTEXEC.*)/\1/' illumos-gate/env.sh
+ sed -i -r 's/#(export +LD_ALTEXEC.*)/\1/' usr/env.sh
mkdir -p debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
mkdir -p debian/tmp/usr/lib32
mkdir -p debian/tmp/usr/include
# install into /usr:
sed -i -r '/Makefile\.rootfs/d' \
- illumos-gate/usr/src/lib/libctf/Makefile.com
+ usr/src/lib/libctf/Makefile.com
dh_illumos_make --no-onbld usr/src/lib/libctf
dh_illumos_make --no-onbld usr/src/lib/libctf -t install_h
# Then - don't:
- sed -i -r 's/(export +LD_ALTEXEC.*)/#\1/' illumos-gate/env.sh
+ sed -i -r 's/(export +LD_ALTEXEC.*)/#\1/' usr/env.sh
dh_illumos_make --no-onbld --native usr/src/tools/ctf/stabs
touch $@
@@ -76,5 +76,5 @@ clean: unpatch
dh_testdir
dh_testroot
dh_clean
- rm -rf illumos-gate
+ rm -rf usr