summaryrefslogtreecommitdiff
path: root/onbld/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2012-10-27 23:03:45 +0400
committerIgor Pashev <pashev.igor@gmail.com>2012-10-27 23:03:45 +0400
commitb5a4dcb09769234a3a3f40ece3cce4bace6ef1a4 (patch)
treed8486daf9450a20281e5fc77ea9cbb536bb2c638 /onbld/debian/rules
parent20658a384acf071a08e2823ef677aac036cd0dc4 (diff)
downloadillumos-packaging-b5a4dcb09769234a3a3f40ece3cce4bace6ef1a4.tar.gz
onbld (2.10-3) unstable; urgency=low
* Unpack only required sources * Put headers from usr/src/uts into /usr/include/libctf/ * Put libctf into /lib, not /usr/lib * Added multi-arch * Build depends on 'symlinks'
Diffstat (limited to 'onbld/debian/rules')
-rwxr-xr-xonbld/debian/rules53
1 files changed, 41 insertions, 12 deletions
diff --git a/onbld/debian/rules b/onbld/debian/rules
index 846d9ac..6c19aac 100755
--- a/onbld/debian/rules
+++ b/onbld/debian/rules
@@ -2,10 +2,19 @@
include /usr/share/dpkg/architecture.mk
+export DH_VERBOSE = 1
+
unpack: unpack-stamp
unpack-stamp:
dh_testdir
- dh_illumos_gate
+ dh_illumos_gate --build \
+ usr/src/tools \
+ usr/src/lib/libctf \
+ usr/src/common/ctf \
+ usr/src/lib/Makefile\* \
+ usr/src/uts/common/sys/ctf.h \
+ usr/src/uts/common/sys/ctf_api.h \
+
# install into debian/tmp:
echo 'export TOOLS_PROTO="$$ROOT"' >> usr/env.sh
sed -i '/^TOOLS_PROTO=/d' usr/bldenv.sh
@@ -22,8 +31,24 @@ unpatch:
[ ! -f debian/patches/series ] || QUILT_PATCHES=debian/patches quilt pop -a -f || test $$? = 2
rm -f patch-stamp
+dirs-stamp:
+ . usr/env.sh; mkdir -p \
+ debian/tmp/usr/include \
+ debian/tmp/usr/include/libctf \
+ debian/tmp$$DEB_LIBDIR_32 \
+ debian/tmp$$DEB_LIBDIR_64 \
+ debian/tmp$$DEB_USRLIBDIR_32 \
+ debian/tmp$$DEB_USRLIBDIR_64
+ touch $@
+
+headers-stamp: patch-stamp dirs-stamp
+ dh_illumos_make usr/src/lib/libctf -t install_h
+ cp usr/src/uts/common/sys/*.h debian/tmp/usr/include/libctf/
+ touch $@
+
+
install build build-arch build-indep: build-stamp
-build-stamp: patch-stamp
+build-stamp: patch-stamp headers-stamp dirs-stamp
# ctfstabs needs libctf, libctf needs ctfconvert
# We've disabled ctfstabs via patch to build all tools
# not requiring libctf, then build libctf, then - ctfstabs:
@@ -35,17 +60,24 @@ build-stamp: patch-stamp
dh_illumos_make --no-onbld --native usr/src/tools
# Then we need sunld:
sed -i -r 's/#(export +LD_ALTEXEC.*)/\1/' usr/env.sh
- mkdir -p debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
- mkdir -p debian/tmp/usr/lib32
- mkdir -p debian/tmp/usr/include
- # install into /usr:
- sed -i -r '/Makefile\.rootfs/d' \
- usr/src/lib/libctf/Makefile.com
- dh_illumos_make --no-onbld usr/src/lib/libctf
dh_illumos_make --no-onbld usr/src/lib/libctf -t install_h
+ dh_illumos_make --no-onbld usr/src/lib/libctf
# Then - don't:
sed -i -r 's/(export +LD_ALTEXEC.*)/#\1/' usr/env.sh
dh_illumos_make --no-onbld --native usr/src/tools/ctf/stabs
+
+ # Move dev symlink from /lib into /usr/lib:
+ for l in `find debian/tmp/lib32 -maxdepth 1 -type l -name \*.so`; do \
+ ln -sf `readlink -f $$l` debian/tmp/usr/lib32/`basename $$l`; \
+ rm $$l; \
+ done
+ for l in `find debian/tmp/lib/$(DEB_HOST_MULTIARCH) -maxdepth 1 -type l -name \*.so`; do \
+ ln -sf `readlink -f $$l` debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/`basename $$l`; \
+ rm $$l; \
+ done
+ # Make symlinks relative:
+ symlinks -c debian/tmp/usr/lib32
+ symlinks -c debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
touch $@
binary binary-arch binary-indep: binary-stamp
@@ -55,9 +87,6 @@ binary-stamp: build-stamp
dh_install
dh_python2
dh_installman
- dh_installdocs -plibctf1-dev --link-doc=libctf1
- dh_installdocs -plib32ctf1 --link-doc=libctf1
- dh_installdocs -plib32ctf1-dev --link-doc=libctf1
dh_installdocs
dh_installexamples
dh_installchangelogs