summaryrefslogtreecommitdiff
path: root/onbld/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2012-09-02 07:15:05 +0000
committerIgor Pashev <pashev.igor@gmail.com>2012-09-02 07:15:05 +0000
commitcd3767d9b9a44adb35a59ecf5df88b0f10cfc038 (patch)
tree255c0debe14545fbb0db51d773efc15240923032 /onbld/debian/rules
parent8c3991e85803ad09496a93d10fc2425fd57dec8f (diff)
downloadillumos-packaging-cd3767d9b9a44adb35a59ecf5df88b0f10cfc038.tar.gz
Added lib32ctf
Diffstat (limited to 'onbld/debian/rules')
-rwxr-xr-xonbld/debian/rules17
1 files changed, 9 insertions, 8 deletions
diff --git a/onbld/debian/rules b/onbld/debian/rules
index a2729ff..7dbe716 100755
--- a/onbld/debian/rules
+++ b/onbld/debian/rules
@@ -6,9 +6,6 @@ unpack: unpack-stamp
unpack-stamp:
dh_testdir
dh_illumos_gate
- # i386_XARCH is set to -m32 by dh_illumos_gate,
- # but we want native arch (64-bit):
- sed -i -r "s/.*(export i386_XARCH=).*/\1/" illumos-gate/env.sh
# install into debian/tmp:
echo 'export TOOLS_PROTO="$$ROOT"' >> illumos-gate/env.sh
sed -i '/^TOOLS_PROTO=/d' illumos-gate/bldenv.sh
@@ -35,19 +32,20 @@ build-stamp: patch-stamp
# and sunld does not understand it,
# but we do not need sunld here ;-)
sed -i -r 's/.*(export +LD_ALTEXEC.*)/#\1/' illumos-gate/env.sh
- dh_illumos_make --no-onbld usr/src/tools
+ dh_illumos_make --no-onbld --native usr/src/tools
# Then we need sunld:
sed -i -r 's/#(export +LD_ALTEXEC.*)/\1/' illumos-gate/env.sh
- mkdir -p debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) \
- debian/tmp/usr/include
+ mkdir -p debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
+ mkdir -p debian/tmp/usr/lib32
+ mkdir -p debian/tmp/usr/include
# install into /usr:
sed -i -r '/Makefile\.rootfs/d' \
illumos-gate/usr/src/lib/libctf/Makefile.com
- dh_illumos_make --no-onbld --without-mcs usr/src/lib/libctf/amd64
+ dh_illumos_make --no-onbld --without-mcs usr/src/lib/libctf
dh_illumos_make --no-onbld --without-mcs usr/src/lib/libctf -t install_h
# Then - don't:
sed -i -r 's/(export +LD_ALTEXEC.*)/#\1/' illumos-gate/env.sh
- dh_illumos_make --no-onbld usr/src/tools/ctf/stabs
+ dh_illumos_make --no-onbld --native usr/src/tools/ctf/stabs
touch $@
binary binary-arch binary-indep: binary-stamp
@@ -57,6 +55,9 @@ binary-stamp: build-stamp
dh_install
dh_python2
dh_installman
+ dh_installdocs -plibctf1-dev --link-doc=libctf1
+ dh_installdocs -plib32ctf1 --link-doc=libctf1
+ dh_installdocs -plib32ctf1-dev --link-doc=libctf1
dh_installdocs
dh_installexamples
dh_installchangelogs