summaryrefslogtreecommitdiff
path: root/libc/debian/patches/add-memrchr.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libc/debian/patches/add-memrchr.patch')
-rw-r--r--libc/debian/patches/add-memrchr.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/libc/debian/patches/add-memrchr.patch b/libc/debian/patches/add-memrchr.patch
index f75926e..41dfbc4 100644
--- a/libc/debian/patches/add-memrchr.patch
+++ b/libc/debian/patches/add-memrchr.patch
@@ -1,8 +1,8 @@
Index: b/usr/src/head/string.h
===================================================================
---- a/usr/src/head/string.h 2014-03-02 23:23:14.072577470 +0400
-+++ b/usr/src/head/string.h 2014-03-02 23:23:35.767723294 +0400
-@@ -126,6 +126,7 @@
+--- a/usr/src/head/string.h
++++ b/usr/src/head/string.h
+@@ -140,6 +140,7 @@ extern char *strdup(const char *);
#if defined(__EXTENSIONS__) || defined(_GNU_SOURCE)
#define __mempcpy mempcpy
extern void *mempcpy(void *, const void *, size_t);
@@ -12,9 +12,9 @@ Index: b/usr/src/head/string.h
#if defined(__EXTENSIONS__) || \
Index: b/usr/src/lib/libc/amd64/Makefile
===================================================================
---- a/usr/src/lib/libc/amd64/Makefile 2014-03-02 23:23:28.527980233 +0400
-+++ b/usr/src/lib/libc/amd64/Makefile 2014-03-02 23:23:35.771315039 +0400
-@@ -448,6 +448,7 @@
+--- a/usr/src/lib/libc/amd64/Makefile
++++ b/usr/src/lib/libc/amd64/Makefile
+@@ -460,6 +460,7 @@ PORTGEN= \
memalign.o \
memmem.o \
mempcpy.o \
@@ -24,9 +24,9 @@ Index: b/usr/src/lib/libc/amd64/Makefile
mkfifo.o \
Index: b/usr/src/lib/libc/i386/Makefile.com
===================================================================
---- a/usr/src/lib/libc/i386/Makefile.com 2014-03-02 23:23:28.530105789 +0400
-+++ b/usr/src/lib/libc/i386/Makefile.com 2014-03-02 23:23:35.774056030 +0400
-@@ -479,6 +479,7 @@
+--- a/usr/src/lib/libc/i386/Makefile.com
++++ b/usr/src/lib/libc/i386/Makefile.com
+@@ -493,6 +493,7 @@ PORTGEN= \
memalign.o \
memmem.o \
mempcpy.o \
@@ -36,9 +36,9 @@ Index: b/usr/src/lib/libc/i386/Makefile.com
mkfifo.o \
Index: b/usr/src/lib/libc/port/mapfile-vers
===================================================================
---- a/usr/src/lib/libc/port/mapfile-vers 2014-03-02 23:23:28.533322797 +0400
-+++ b/usr/src/lib/libc/port/mapfile-vers 2014-03-02 23:23:35.777427998 +0400
-@@ -134,6 +134,7 @@
+--- a/usr/src/lib/libc/port/mapfile-vers
++++ b/usr/src/lib/libc/port/mapfile-vers
+@@ -276,6 +276,7 @@ SYMBOL_VERSION DYSON_1 {
error_print_progname;
flock;
mempcpy;
@@ -48,8 +48,8 @@ Index: b/usr/src/lib/libc/port/mapfile-vers
} ILLUMOS_0.3;
Index: b/usr/src/lib/libc/port/gen/memrchr.c
===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ b/usr/src/lib/libc/port/gen/memrchr.c 2014-03-02 23:23:35.779333256 +0400
+--- /dev/null
++++ b/usr/src/lib/libc/port/gen/memrchr.c
@@ -0,0 +1,18 @@
+#include<string.h>
+