summaryrefslogtreecommitdiff
path: root/libc/debian/patches/binaries-use-gnu-ld.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libc/debian/patches/binaries-use-gnu-ld.patch')
-rw-r--r--libc/debian/patches/binaries-use-gnu-ld.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/libc/debian/patches/binaries-use-gnu-ld.patch b/libc/debian/patches/binaries-use-gnu-ld.patch
index 51b4e02..bd6f4dc 100644
--- a/libc/debian/patches/binaries-use-gnu-ld.patch
+++ b/libc/debian/patches/binaries-use-gnu-ld.patch
@@ -1,9 +1,9 @@
Description: crt1.o: R_AMD64_GOT32 not supported by sunld
Probably, caused by crt1.o-amd64-PIE.patch
-Index: libc/usr/src/cmd/sgs/ld/Makefile.com
+Index: b/usr/src/cmd/sgs/ld/Makefile.com
===================================================================
---- libc.orig/usr/src/cmd/sgs/ld/Makefile.com
-+++ libc/usr/src/cmd/sgs/ld/Makefile.com
+--- a/usr/src/cmd/sgs/ld/Makefile.com
++++ b/usr/src/cmd/sgs/ld/Makefile.com
@@ -34,7 +34,6 @@ BLTOBJ = msg.o
OBJS = $(BLTOBJ) $(COMOBJS)
.PARALLEL: $(OBJS)
@@ -12,10 +12,10 @@ Index: libc/usr/src/cmd/sgs/ld/Makefile.com
MAPOPTS = $(MAPFILES:%=-M%)
LDFLAGS += $(VERSREF) $(CC_USE_PROTO) $(MAPOPTS) $(VAR_LD_LLDFLAGS)
-Index: libc/usr/src/cmd/Makefile.cmd
+Index: b/usr/src/cmd/Makefile.cmd
===================================================================
---- libc.orig/usr/src/cmd/Makefile.cmd
-+++ libc/usr/src/cmd/Makefile.cmd
+--- a/usr/src/cmd/Makefile.cmd
++++ b/usr/src/cmd/Makefile.cmd
@@ -508,3 +508,10 @@ CLOBBERFILES += $(XPG4) $(XPG6) $(DCFILE
# This flag is for programs which should not build a 32-bit binary
sparc_64ONLY= $(POUND_SIGN)
@@ -27,10 +27,10 @@ Index: libc/usr/src/cmd/Makefile.cmd
+MAPFILE.PGA=
+MAPFILE.NED=
+
-Index: libc/usr/src/cmd/sgs/lddstub/i386/Makefile
+Index: b/usr/src/cmd/sgs/lddstub/i386/Makefile
===================================================================
---- libc.orig/usr/src/cmd/sgs/lddstub/i386/Makefile
-+++ libc/usr/src/cmd/sgs/lddstub/i386/Makefile
+--- a/usr/src/cmd/sgs/lddstub/i386/Makefile
++++ b/usr/src/cmd/sgs/lddstub/i386/Makefile
@@ -29,6 +29,8 @@ include ../Makefile.com
.KEEP_STATE:
@@ -40,10 +40,10 @@ Index: libc/usr/src/cmd/sgs/lddstub/i386/Makefile
install: all .WAIT $(ROOT)/$(DEB_USRLIBDIR_32)/$(PROG)
$(ROOT)/$(DEB_USRLIBDIR_32)/$(PROG): $(PROG)
$(INS.file)
-Index: libc/usr/src/cmd/sgs/lddstub/Makefile.com
+Index: b/usr/src/cmd/sgs/lddstub/Makefile.com
===================================================================
---- libc.orig/usr/src/cmd/sgs/lddstub/Makefile.com
-+++ libc/usr/src/cmd/sgs/lddstub/Makefile.com
+--- a/usr/src/cmd/sgs/lddstub/Makefile.com
++++ b/usr/src/cmd/sgs/lddstub/Makefile.com
@@ -36,5 +36,5 @@ include ../../Makefile.com
# As of Solaris 9 the kernel accepts $ORIGIN within the interpreter field.