summaryrefslogtreecommitdiff
path: root/libc/debian/patches/libm-i386-regs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libc/debian/patches/libm-i386-regs.patch')
-rw-r--r--libc/debian/patches/libm-i386-regs.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/libc/debian/patches/libm-i386-regs.patch b/libc/debian/patches/libm-i386-regs.patch
new file mode 100644
index 0000000..86ac881
--- /dev/null
+++ b/libc/debian/patches/libm-i386-regs.patch
@@ -0,0 +1,26 @@
+Description: some macros in /usr/include/sys/regset.h
+were causing conflicts in a lot of applications.
+We have hidden them by the _I386_REGS macros,
+and need them anyway for libm
+Index: libc/usr/src/lib/libm/Makefile.com
+===================================================================
+--- libc.orig/usr/src/lib/libm/Makefile.com
++++ libc/usr/src/lib/libm/Makefile.com
+@@ -327,7 +327,7 @@ ROBJS_amd64 = \
+ #
+ # atan2pif.o, sincosf.o, sincospif.o are for internal use only
+ #
+-# LSARC/2003/279 adds the following:
++ LSARC/2003/279 adds the following:
+ # besself.o 6
+ # scalbf.o 1
+ # gammaf.o 1
+@@ -514,6 +514,8 @@ LINTFLAGS64 += -errchk=longptr64
+ CFLAGS += $(C_BIGPICFLAGS)
+ CFLAGS64 += $(C_BIGPICFLAGS)
+
++CFLAGS += -D_I386_REGS
++
+ m9x_IL = $(LIBMDIR)/common/m9x/__fenv_$(TARGET_ARCH).il
+
+ SRCS_LD_i386_amd64 = \