summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4085ac4..427f2e3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-EXTRA_DIST = COPYRIGHT OPENSOLARIS.LICENSE umem.spec
+EXTRA_DIST = COPYRIGHT OPENSOLARIS.LICENSE umem.spec Doxyfile
lib_LTLIBRARIES = libumem.la
noinst_PROGRAMS = umem_test
@@ -33,6 +33,17 @@ nobase_include_HEADERS = umem.h sys/vmem.h
TESTS = umem_test
+html-local:
+ mkdir -p docs
+ doxygen Doxyfile
+
+clean-local:
+ rm -rf docs
+
+.PHONY: rpm
+rpm: $(distdir).tar.bz2
+ rpmbuild -ta $<
+
# malloc.c
# XXX: Standalone version?