summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2005-12-12 01:52:17 +0000
committerGuillem Jover <guillem@hadrons.org>2010-06-10 23:21:18 +0200
commitd5cc2fa4085454be4d8a122bdd507f800f36a1f7 (patch)
tree033849e0b98423dc7d9e4bfaa0a710b3ae1268a4 /debian
parentebcf94b56cec8bb1f7aa9bc104cb74410ec2010e (diff)
downloadinetutils-d5cc2fa4085454be4d8a122bdd507f800f36a1f7.tar.gz
Mark new upstream spanshot 1.4.3+20051212
Add tarball.sh.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/tarball.sh57
2 files changed, 60 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ad096d4..c8e5e72 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
-inetutils (2:1.4.2+20040207-7) UNRELEASED; urgency=low
+inetutils (2:1.4.3+20051212-1) UNRELEASED; urgency=low
+ * New upstream snapshot.
+ - debian/tarball.sh: New file.
* Switch back to plain debhelper.
- Remove cdbs workaround for not being able to set per package specific
rc.d priority.
diff --git a/debian/tarball.sh b/debian/tarball.sh
new file mode 100755
index 0000000..0f1d513
--- /dev/null
+++ b/debian/tarball.sh
@@ -0,0 +1,57 @@
+#!/bin/sh
+#
+# $Id$
+#
+# Copyright (C) 2004, 2005 Guillem Jover <guillem@debian.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+
+PKG=inetutils
+export CVSROOT=":pserver:anonymous@cvs.sv.gnu.org:/sources/$PKG"
+
+set -e
+
+SRCDIR="$PKG-snapshot"
+
+case "$1" in
+ snapshot)
+ echo "-> getting new snapshot."
+# cvs login
+ cvs -z3 co -d $SRCDIR $PKG
+ ;;
+ update)
+ echo "-> updating snapshot."
+ cvs -z3 up -dP $SRCDIR
+ ;;
+esac
+
+if ! [ -e $SRCDIR/libinetutils ]
+then
+ echo "error: no $PKG source dir available."
+ exit 1
+fi
+
+echo "-> creating new directory tree."
+VERSION=$(grep ^AC_INIT $SRCDIR/configure.ac | \
+ sed -e 's/.*, *\[\([^,]*\)\] *,.*/\1/')
+SNAPSHOTVERSION="$VERSION+$(date +%Y%m%d)"
+TARBALLDIR="$PKG-$SNAPSHOTVERSION"
+cp -al $SRCDIR $TARBALLDIR
+
+echo "-> cleaning snapshot."
+# Clean non-free stuff
+:
+
+# Clean cvs stuff
+find $TARBALLDIR -name 'CVS' -o -name '.cvsignore' | xargs rm -rf
+
+echo "-> creating new tarball."
+tar czf ${PKG}_$SNAPSHOTVERSION.orig.tar.gz $TARBALLDIR
+
+echo "-> cleaning directory tree."
+rm -rf $TARBALLDIR
+