summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xscript/deb-systemd-helper8
2 files changed, 12 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 494862b..9859f01 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+init-system-helpers (1.16) unstable; urgency=low
+
+ * Don’t delete /etc/systemd/, only the hierarchy below /etc/systemd/system/.
+ This is necessary to fix piuparts warnings since we ship
+ /etc/systemd/system since i-s-h 1.15 (Thanks Andreas Beckmann).
+
+ -- Michael Stapelberg <stapelberg@debian.org> Mon, 17 Feb 2014 20:32:54 +0100
+
init-system-helpers (1.15) unstable; urgency=low
* ship /etc/systemd/system to avoid piuparts warnings
diff --git a/script/deb-systemd-helper b/script/deb-systemd-helper
index 9149d18..f6b0fe7 100755
--- a/script/deb-systemd-helper
+++ b/script/deb-systemd-helper
@@ -496,10 +496,10 @@ for my $scriptname (@ARGV) {
# subdirectories. Necessary to cleanly pass a piuparts run.
rmdir_if_empty('/var/lib/systemd/deb-systemd-helper-enabled');
- # Same with /etc/systemd, where we create symlinks. If systemd is not
- # installed (and no other package shipping service files), this would
- # make piuparts fail, too.
- rmdir_if_empty('/etc/systemd');
+ # Same with directories below /etc/systemd, where we create symlinks.
+ # If systemd is not installed (and no other package shipping service
+ # files), this would make piuparts fail, too.
+ rmdir_if_empty($_) for (grep { -d } </etc/systemd/system/*>);
}
if ($action eq 'enable') {