summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a542399..46fe292 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,8 +8,8 @@ noinst_LTLIBRARIES = libknot.la libknotd.la libknots.la libzscanner.la
# $(YACC) will generate header file
AM_CPPFLAGS = -I$(top_srcdir)/src/libknot -DSYSCONFDIR='"$(sysconfdir)"' \
- -DSBINDIR='"$(sbindir)"' -DSTORAGE_DIR='"${storage_dir}"' \
- -DRUN_DIR='"${run_dir}"'
+ -DSBINDIR='"$(sbindir)"' -DCONFIG_DIR='"${config_dir}"' \
+ -DSTORAGE_DIR='"${storage_dir}"' -DRUN_DIR='"${run_dir}"'
AM_YFLAGS = -d
libknotd_la_YFLAGS = -pcf_ -d
libknotd_la_LFLAGS = # TODO: reentrant parser, prefix
@@ -218,12 +218,6 @@ libknots_la_SOURCES = \
common/prng.c \
common/fdset.h \
common/fdset.c \
- common/fdset_poll.h \
- common/fdset_poll.c \
- common/fdset_kqueue.h \
- common/fdset_kqueue.c \
- common/fdset_epoll.h \
- common/fdset_epoll.c \
common/getline.h \
common/getline.c \
common/log.c \
@@ -316,5 +310,6 @@ zscanner_tool_LDADD = libknots.la libknot.la libknotd.la libzscanner.la @LIBOBJS
# Create storage and run-time directories
install-data-hook:
+ $(INSTALL) -d $(DESTDIR)/@config_dir@
$(INSTALL) -d $(DESTDIR)/@run_dir@
$(INSTALL) -d $(DESTDIR)/@storage_dir@