summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2012-06-24 22:32:55 +0000
committerIgor Pashev <pashev.igor@gmail.com>2012-06-24 22:32:55 +0000
commitf5c1f1e76951691b4e9fd7f522ed0a9d0726a5ba (patch)
tree8b20462e0dd8c8326c7a2b14d260dc9d41a93560 /debian/rules
parent3950ffe2a485479f6561c27364d3d7df5a21d124 (diff)
downloadksh-f5c1f1e76951691b4e9fd7f522ed0a9d0726a5ba.tar.gz
Added debian-dir (original, from Debian)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules87
1 files changed, 87 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f9e11bd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,87 @@
+#!/usr/bin/make -f
+PACKAGE = ksh
+SRC_VERSION := 93u+
+DL_VERSION = 2012-02-29
+SRC_DIR = $(PACKAGE)-$(SRC_VERSION)
+TARBALL = $(SRC_DIR).tar.gz
+
+CFLAGS = -g
+LDFLAGS =
+SHELL = /bin/sh
+ARCH = $(shell bin/package)
+INSTALL = install
+INSTALL_FILE = $(INSTALL) -p -o root -g root -m 644
+INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
+
+package=ksh
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+CFLAGS += -O0
+else
+CFLAGS += -O2
+endif
+
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+INSTALL_PROGRAM += -s
+endif
+
+export CCFLAGS = $(CFLAGS)
+
+build: build-stamp
+build-stamp:
+ bin/package make strip=0
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_clean
+ -test -f bin/ignore.old && mv bin/ignore.old bin/ignore
+ -test -f bin/silent.old && mv bin/silent.old bin/silent
+ -test -f bin/package.old && mv bin/package.old bin/package
+ -test -f bin/mamprobe.old && mv bin/mamprobe.old bin/mamprobe
+ -rm -rf arch/$(ARCH)
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_installdirs
+ $(INSTALL_PROGRAM) arch/$(ARCH)/bin/ksh debian/ksh/bin/ksh93
+ $(INSTALL_PROGRAM) arch/$(ARCH)/bin/shcomp debian/ksh/usr/bin/shcomp
+ $(INSTALL_FILE) arch/$(ARCH)/man/man1/sh.1 debian/ksh/usr/share/man/man1/ksh93.1
+ $(INSTALL_FILE) arch/$(ARCH)/fun/* debian/ksh/usr/share/ksh/functions
+ $(INSTALL_FILE) debian/shcomp.1 debian/ksh/usr/share/man/man1/shcomp.1
+ $(INSTALL_FILE) debian/fr-shcomp.1 debian/ksh/usr/share/man/fr/man1/shcomp.1
+ dh_installdocs
+ dh_installmenu
+ dh_installchangelogs
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+
+get-orig-source:
+ rm -rf $(SRC_DIR) $(TARBALL)
+ mkdir $(SRC_DIR)
+ wget --http-user 'I accept www.opensource.org/licenses/cpl' \
+ --http-password . -O - \
+ http://www.research.att.com/~gsf/download/tgz/INIT.$(DL_VERSION).tgz | \
+ tar xzf - -C $(SRC_DIR)
+ wget --http-user 'I accept www.opensource.org/licenses/cpl' \
+ --http-password . -O - \
+ http://www.research.att.com/~gsf/download/tgz/ast-ksh.$(DL_VERSION).tgz | \
+ tar xzf - -C $(SRC_DIR)
+ tar cf - $(SRC_DIR) | tardy -group 0 -user 0 - - | gzip -c9 > $(TARBALL)
+
+.PHONY: build clean binary-indep binary-arch binary install get-orig-source