summaryrefslogtreecommitdiff
path: root/debian/patches/0001-shell-options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-shell-options.patch')
-rw-r--r--debian/patches/0001-shell-options.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/patches/0001-shell-options.patch b/debian/patches/0001-shell-options.patch
new file mode 100644
index 0000000..7fbb807
--- /dev/null
+++ b/debian/patches/0001-shell-options.patch
@@ -0,0 +1,23 @@
+From: Oliver Kiddle <okiddle@yahoo.co.uk>
+Date: Sun, 24 Jun 2012 22:33:38 +0000
+Subject: shell-options
+
+---
+ src/cmd/ksh93/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/cmd/ksh93/Makefile b/src/cmd/ksh93/Makefile
+index 3ad44c6..2d98480 100644
+--- a/src/cmd/ksh93/Makefile
++++ b/src/cmd/ksh93/Makefile
+@@ -48,8 +48,8 @@ SHOPT_REMOTE == /* enable --rc if running as a remote shell */
+ SHOPT_SEVENBIT == /* strip the eigth bit from characters */
+ SHOPT_SPAWN == /* use spawnveg for fork/exec */
+ SHOPT_STATS == 1 /* add .sh.stats variable */
+-SHOPT_SUID_EXEC == 1 /* allow (safe) suid/sgid shell scripts */
+-SHOPT_SYSRC == /* attempt . /etc/ksh.kshrc if interactive */
++SHOPT_SUID_EXEC == 0 /* allow (safe) suid/sgid shell scripts */
++SHOPT_SYSRC == 1 /* attempt . /etc/ksh.kshrc if interactive */
+ SHOPT_TIMEOUT == /* number of seconds for shell timeout */
+ SHOPT_TYPEDEF == 1 /* enable typeset type definitions */
+ SHOPT_VSH == 1 /* vi edit mode */