summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Vogt <egon@debian-devbox>2012-01-24 14:14:55 +0100
committerMichael Vogt <egon@debian-devbox>2012-01-24 14:31:50 +0100
commite723bd9ef784ec2516cd36a2dfcfd57d74ef453a (patch)
tree287ecaec1437b3a0ae7844d5afce98feab472787 /CMakeLists.txt
parent9e7d767a9af5fa2f18cbd12b8f81dc3b0253f938 (diff)
downloadlibept-e723bd9ef784ec2516cd36a2dfcfd57d74ef453a.tar.gz
* build against libapt in experimental
* debian/control: - encode apt ABI version in libept1 package name * ept/CMakeLists.txt: - do not set "SOVERSION 1" anymore, use full VERSION instead
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5de36f1..1154891 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,8 @@ include( FindDoxygen )
add_custom_target( unit )
-set( EPT_VERSION "1.0.5" )
+set( LIBAPT_ABI_VERSION "4.12" )
+set( EPT_VERSION "1.0.5.${LIBAPT_ABI_VERSION}" )
set( APT_INCLUDES "/usr/include/" CACHE STRING "apt include path" )
set( APT_LINKDIRS "/usr/lib/" CACHE STRING "apt library path" )
set( OPT_FLAGS "-O0 -g" CACHE STRING "optimization level" )