summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 9a8d522..37484a8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,9 @@
BUILDDIR = $(CURDIR)/debian/build
+libwibble_source = $(shell dpkg-query -f '$${source:Package} (= $${source:Version}), ' -W libwibble-dev)
+tagcoll2_source = $(shell dpkg-query -f '$${source:Package} (= $${source:Version}), ' -W libtagcoll2-dev)
+
%:
dh $@ --buildsystem=cmake --builddirectory=$(BUILDDIR)
@@ -19,6 +22,11 @@ override_dh_auto_install:
dh_installdocs -plibept-dev -n $(BUILDDIR)/doc/html
dh_installdocs -plibept-dev -n $(BUILDDIR)/doc/libept.doxytags
+override_dh_gencontrol:
+ dh_gencontrol -- \
+ -Vlibwibble:Source="$(libwibble_source)" \
+ -Vtagcoll2:Source="$(tagcoll2_source)"
+
debsrc:
debian/check_versions
gbp buildpackage --git-pristine-tar -S -us -uc