summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2009-03-01 10:54:34 +0100
committerMike Hommey <glandium@debian.org>2009-03-01 10:54:34 +0100
commit0c1d871e4c5e46a2945cccb2ce765f9be2fe01fb (patch)
tree982382b30eb118c65e1a06b25757dac5c3c69b8d /Makefile.am
parentd03a853bb0370d89552eceee59df1746da4a37f8 (diff)
downloadlibxml2-0c1d871e4c5e46a2945cccb2ce765f9be2fe01fb.tar.gz
Import upstream version 2.7.1upstream/2.7.1.dfsg
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index de57c46..800a766 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -157,7 +157,7 @@ rebuild_testapi:
# that one is just to make sure it is rebuilt if missing
# but adding the dependances generate mess
-testapi.c:
+testapi.c: $(srcdir)/gentest.py
-@(if [ "$(PYTHON)" != "" ] ; then \
$(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
@@ -178,6 +178,8 @@ runxmlconf_LDADD= $(LDADDS)
runtests:
$(CHECKER) ./runtest$(EXEEXT) && $(CHECKER) ./testrecurse$(EXEEXT) &&$(CHECKER) ./testapi$(EXEEXT) && $(CHECKER) ./testchar$(EXEEXT)&& $(CHECKER) ./testdict$(EXEEXT) && $(CHECKER) ./runxmlconf$(EXEEXT)
+ @(if [ "@PYTHON_SUBDIR@" != "" ] ; then cd python ; \
+ $(MAKE) MAKEFLAGS+=--silent tests ; fi)
check: all runtests