summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2005-09-05 17:10:35 +0000
committerMike Hommey <glandium@debian.org>2005-09-05 17:10:35 +0000
commita464d9993e2acd5b8e1089b218ba74c6fcf215c5 (patch)
tree72fe00eb59147367a1d660b90d08172357e0dffc /configure.in
parent112cb5bb5475afec1c1cbf1d6728ce4880d0fee8 (diff)
downloadlibxml2-a464d9993e2acd5b8e1089b218ba74c6fcf215c5.tar.gz
Load /usr/tmp/tmp.CMoFff/libxml2-2.6.21 intoupstream/2.6.21
packages/libxml2/branches/upstream/current.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in98
1 files changed, 79 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 6777c94..ad902eb 100644
--- a/configure.in
+++ b/configure.in
@@ -5,7 +5,7 @@ AC_CANONICAL_HOST
LIBXML_MAJOR_VERSION=2
LIBXML_MINOR_VERSION=6
-LIBXML_MICRO_VERSION=20
+LIBXML_MICRO_VERSION=21
LIBXML_MICRO_VERSION_SUFFIX=
LIBXML_VERSION=$LIBXML_MAJOR_VERSION.$LIBXML_MINOR_VERSION.$LIBXML_MICRO_VERSION$LIBXML_MICRO_VERSION_SUFFIX
LIBXML_VERSION_INFO=`expr $LIBXML_MAJOR_VERSION + $LIBXML_MINOR_VERSION`:$LIBXML_MICRO_VERSION:$LIBXML_MINOR_VERSION
@@ -128,6 +128,8 @@ AC_ARG_WITH(sax1,
[ --with-sax1 add the older SAX1 interface (on)])
AC_ARG_WITH(schemas,
[ --with-schemas add Relax-NG and Schemas support (on)])
+AC_ARG_WITH(schematron,
+[ --with-schematron add Schematron support (on)])
AC_ARG_WITH(threads,
[ --with-threads add multithread support(on)])
AC_ARG_WITH(thread-alloc,
@@ -163,6 +165,11 @@ then
with_pattern=yes
with_regexp=yes
fi
+if test "$with_schematron" = "yes"
+then
+ with_pattern=yes
+ with_xpath=yes
+fi
if test "$with_reader" = "yes"
then
with_push=yes
@@ -270,6 +277,10 @@ then
then
with_schemas=no
fi
+ if test "$with_schematron" = ""
+ then
+ with_schematron=no
+ fi
if test "$with_threads" = ""
then
with_threads=no
@@ -602,7 +613,6 @@ dnl
dnl check for python
dnl
-PYTHON=
PYTHON_VERSION=
PYTHON_INCLUDES=
PYTHON_SITE_PACKAGES=
@@ -619,7 +629,12 @@ if test "$with_python" != "no" ; then
echo Found python in $with_python
PYTHON="$with_python"
else
- AC_PATH_PROG(PYTHON, python python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5)
+ if test -x "$PYTHON"
+ then
+ echo Found python in environment PYTHON=$PYTHON
+ else
+ AC_PATH_PROG(PYTHON, python python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5)
+ fi
fi
fi
if test "$PYTHON" != ""
@@ -660,6 +675,8 @@ if test "$with_python" != "no" ; then
else
pythondir='$(libdir)/python${PYTHON_VERSION}/site-packages'
fi
+else
+ PYTHON=
fi
AM_CONDITIONAL(WITH_PYTHON, test "$PYTHON_INCLUDES" != "")
if test "$PYTHON_INCLUDES" != ""
@@ -673,21 +690,33 @@ AC_SUBST(PYTHON_SUBDIR)
dnl check for dso support
WITH_MODULES=0
-MODULE_EXTENSION=".so"
TEST_MODULES=
if test "$with_modules" != "no" ; then
-AC_CHECK_LIB(dld, shl_load, [
- WITH_MODULES=1
- MODULE_PLATFORM_LIBS="-ldld"
- AC_DEFINE([HAVE_SHLLOAD], [], [Have shl_load based dso])
-])
-
-AC_CHECK_LIB(dl, dlopen, [
- WITH_MODULES=1
- MODULE_PLATFORM_LIBS="-ldl"
- AC_DEFINE([HAVE_DLOPEN], [], [Have dlopen based dso])
-])
+ case "$host" in
+ *-*-cygwin*)
+ MODULE_EXTENSION=".dll"
+ AC_CHECK_LIB(cygwin, dlopen, [
+ WITH_MODULES=1
+ MODULE_PLATFORM_LIBS=
+ AC_DEFINE([HAVE_DLOPEN], [], [Have dlopen based dso])
+ ])
+ ;;
+ *)
+ MODULE_EXTENSION=".so"
+ AC_CHECK_LIB(dld, shl_load, [
+ WITH_MODULES=1
+ MODULE_PLATFORM_LIBS="-ldld"
+ AC_DEFINE([HAVE_SHLLOAD], [], [Have shl_load based dso])
+ ])
+
+ AC_CHECK_LIB(dl, dlopen, [
+ WITH_MODULES=1
+ MODULE_PLATFORM_LIBS="-ldl"
+ AC_DEFINE([HAVE_DLOPEN], [], [Have dlopen based dso])
+ ])
+ ;;
+ esac
fi
if test "${WITH_MODULES}" = "1"; then
@@ -715,6 +744,7 @@ if [[ "${LOGNAME}" = "veillard" -a "`pwd`" = "/u/veillard/XML" ]] || \
if test "$with_minimum" != "yes"
then
if test "${with_mem_debug}" = "" ; then
+ echo Activating memory debugging
with_mem_debug="yes"
with_run_debug="yes"
fi
@@ -722,7 +752,7 @@ if [[ "${LOGNAME}" = "veillard" -a "`pwd`" = "/u/veillard/XML" ]] || \
with_docbook="yes"
fi
fi
- if test "${CC}" = "gcc" ; then
+ if test "${GCC}" = "yes" ; then
CFLAGS="-g -O -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls -Wall"
fi
STATIC_BINARIES="-static"
@@ -782,9 +812,25 @@ else
THREAD_CFLAGS="$THREAD_CFLAGS -DHAVE_BEOS_THREADS"
;;
*linux*)
- if test "${CC}" = "gcc" -a "${THREAD_LIBS}" = "-lpthread" ; then
- THREAD_LIBS=""
- BASE_THREAD_LIBS="-lpthread"
+ if test "${GCC}" = "yes" ; then
+ GCC_VERSION=`${CC} --version | head -1 | awk '{print $3}'`
+ GCC_MAJOR=`echo ${GCC_VERSION} | sed 's+\..*++'`
+ GCC_MEDIUM=`echo ${GCC_VERSION} | sed 's+[[0-9]]*\.++' | sed 's+\..*++'`
+ if test "${THREAD_LIBS}" = "-lpthread" ; then
+ if expr ${GCC_MEDIUM} \> 2 \& ${GCC_MAJOR} = 3 > /dev/null
+ then
+ THREAD_LIBS=""
+ BASE_THREAD_LIBS="-lpthread"
+ else
+ if expr ${GCC_MAJOR} \> 3 > /dev/null
+ then
+ THREAD_LIBS=""
+ BASE_THREAD_LIBS="-lpthread"
+ else
+ echo old GCC disabling weak symbols for pthread
+ fi
+ fi
+ fi
fi
;;
esac
@@ -1140,6 +1186,20 @@ fi
fi
AC_SUBST(WITH_ISO8859X)
+if test "$with_schematron" = "no" ; then
+ echo "Disabling Schematron support"
+ WITH_SCHEMATRON=0
+ TEST_SCHEMATRON=
+else
+ echo "Enabled Schematron support"
+ WITH_SCHEMATRON=1
+ TEST_SCHEMATRON="Schematrontests"
+ with_xpath=yes
+ with_pattern=yes
+fi
+AC_SUBST(WITH_SCHEMATRON)
+AC_SUBST(TEST_SCHEMATRON)
+
if test "$with_schemas" = "no" ; then
echo "Disabling Schemas/Relax-NG support"
WITH_SCHEMAS=0