summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2010-03-19 22:58:56 +0100
committerMike Hommey <glandium@debian.org>2010-03-21 09:51:05 +0100
commit28643e917f2764dec0e94b1703493e9ae26322e9 (patch)
treeb8978ea2cfb07e66ce10b14933b2398f2d2f887c /debian/rules
parent3cf68730b9f0502123c3bac5b3c2b33114a41ed9 (diff)
downloadlibxml2-28643e917f2764dec0e94b1703493e9ae26322e9.tar.gz
Use a common cache for main and python configure passes
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 4af686a..d2ed9f3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,10 +16,10 @@ endif
override_dh_auto_configure: configure-main $(PYVERS:%=configure-%)
configure-main:
- dh_auto_configure --builddirectory=build -- --with-history --without-python CC="gcc -Wl,--as-needed" CFLAGS="$(CFLAGS)"
+ dh_auto_configure --builddirectory=build -- --with-history --without-python CC="gcc -Wl,--as-needed" CFLAGS="$(CFLAGS)" --cache-file="$(CURDIR)/build/config.cache"
configure-python%: configure-main
- dh_auto_configure --builddirectory=build-python$* -- --with-history --with-python=/usr/bin/python$* CC="gcc -Wl,--as-needed" CFLAGS="$(CFLAGS)"
+ dh_auto_configure --builddirectory=build-python$* -- --with-history --with-python=/usr/bin/python$* CC="gcc -Wl,--as-needed" CFLAGS="$(CFLAGS)" --cache-file="$(CURDIR)/build/config.cache"
mv build-python$*/python build/python$*
override_dh_auto_build: build-main $(PYVERS:%=build-%)