summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2008-04-09 11:14:46 +0200
committerMike Hommey <glandium@debian.org>2008-04-09 11:14:46 +0200
commit3dbe8156e35fb7302e22dde9b3edc636c8adb0ec (patch)
tree07fc11850106b44534924a8e9825c8df1f5c3c87 /debian/rules
parent581c523ded3dcc80ef5b039099b557d8d90ce79f (diff)
downloadlibxml2-3dbe8156e35fb7302e22dde9b3edc636c8adb0ec.tar.gz
* debian/rules:
+ Removed the workaround for removed and modified files during build. The former was for svn-buildpackage that I don't use anymore, and the latter for a file that isn't in the .orig.tar.gz anymore. + Bump shlibs to current version, since a new symbol was added. * debian/libxml2.symbols: Reference the new symbol.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 1 insertions, 13 deletions
diff --git a/debian/rules b/debian/rules
index ed65fef..4143965 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,9 +20,6 @@ PYVERS=$(shell pyversions -s)
# The current default version of python
PYVER=$(shell pyversions -d)
-WORKAROUND_REMOVED_FILES=include/libxml/xmlversion.h libxml2.spec python/setup.py doc/xmlcatalog.1
-WORKAROUND_MODIFIED_FILES=python/libxml2-py.c
-
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -35,10 +32,6 @@ build: build-stamp
build-stamp:
dh_testdir
- # Workaround backups because of non-idempotent upstream:
- $(foreach file, $(WORKAROUND_REMOVED_FILES) $(WORKAROUND_MODIFIED_FILES), \
- cp -f -a $(file) $(file)-tmp;)
-
# ./configure
LDFLAGS="-Wl,--as-needed" CFLAGS="$(CFLAGS)" ./configure $(confflags) --prefix=/usr --with-history
echo "all:" > example/Makefile
@@ -63,11 +56,6 @@ clean:
-rm -f example/Makefile
rm COPYING && cp Copyright COPYING
- # Restore workaround backups of removed and modified files
- -$(foreach file, $(WORKAROUND_REMOVED_FILES) $(WORKAROUND_MODIFIED_FILES), \
- test -r $(file)-tmp && \
- mv -f $(file)-tmp $(file);)
-
-test -r /usr/share/misc/config.sub && \
cp -f /usr/share/misc/config.sub config.sub
-test -r /usr/share/misc/config.guess && \
@@ -173,7 +161,7 @@ binary-arch: build install
fi;)
dh_compress -a -Xexamples/
dh_fixperms -a
- dh_makeshlibs -a -V 'libxml2 (>= 2.6.31)' -- -c4
+ dh_makeshlibs -a -V 'libxml2 (>= 2.6.32)' -- -c4
dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a