summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAron Xu <aron@debian.org>2012-05-30 07:53:34 +0800
committerAron Xu <aron@debian.org>2012-05-30 08:03:41 +0800
commit51232e5c5703732ae0b457a9d35795fcea95bc34 (patch)
tree76b4e1abf2764e72b8f554204a21dc746c922d7b /debian/rules
parent936d5a6eba4da892d8fc4ff044f71f1640ee30a0 (diff)
downloadlibxml2-51232e5c5703732ae0b457a9d35795fcea95bc34.tar.gz
Better handling of build variables.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 3 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index ab24f8e..c85dbff 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,19 +1,17 @@
#!/usr/bin/make -f
-export DH_VERBOSE=1
# The versions of python currently supported
PYVERS=$(shell pyversions -s)
# The current default version of python
PYVER=$(shell pyversions -d)
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
CFLAGS = `dpkg-buildflags --get CFLAGS` -Wall
LDFLAGS = `dpkg-buildflags --get LDFLAGS` -Wl,--as-needed
CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -fno-strict-aliasing
-endif
-
TARGETS := main $(PYVERS) $(PYVERS:%=%-dbg)
WITH_UDEB := $(shell dpkg-vendor --derives-from Ubuntu && echo yes)