summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2007-11-21 19:23:35 +0100
committerMike Hommey <glandium@debian.org>2007-11-21 19:23:35 +0100
commitda09f43b6859985f9106a733d225fc921a3fa3c8 (patch)
treef8d32cddc34c5aa193f5d92dde7194bc00d41630 /debian/rules
parent100424703f645c8a1f98781435630886b95bea5b (diff)
downloadlibxml2-da09f43b6859985f9106a733d225fc921a3fa3c8.tar.gz
* debian/libxml2.symbols: Add a symbols file to benefit from the new
features in dpkg-shlibdeps. * debian/control: Build depend on debhelper (>= 5.0.61) and dpkg-dev (>= 1.14.9), accordingly. * debian/rules: + Apply rules suggested in autotools-dev documentation. + Add -Wl,--as-needed to LDFLAGS so that useless dependencies are not added. * Makefile.am, Makefile.in: Don't build noinst targets.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5f0b20f..e57b8de 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,13 @@
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+ confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+ confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
# The versions of python currently supported
PYVERS=$(shell pyversions -s)
# The current default version of python
@@ -33,7 +40,7 @@ build-stamp:
cp -f -a $(file) $(file)-tmp;)
# ./configure
- CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --with-history
+ LDFLAGS="-Wl,--as-needed" CFLAGS="$(CFLAGS)" ./configure $(confflags) --prefix=/usr --with-history
echo "all:" > example/Makefile
echo "install:" >> example/Makefile
echo "distclean:" >> example/Makefile