summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAron Xu <aron@debian.org>2012-06-03 18:32:33 +0800
committerAron Xu <aron@debian.org>2012-06-03 18:32:51 +0800
commit0b9f0939fc73d49fa7e56e95090cf30020feff4e (patch)
treef2dc26e39e66924cb44e976decb7e5701c10eb7c /debian
parent69ec6d32a9718d4a44d9bc15ff62f2bfbda9d14b (diff)
downloadlibxml2-0b9f0939fc73d49fa7e56e95090cf30020feff4e.tar.gz
Restore xml2-config behaviour.
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/0002-modify-xml2-config-behaviour.patch78
-rw-r--r--debian/patches/0002-remove-useless-linking-commands.patch22
-rw-r--r--debian/patches/series2
3 files changed, 79 insertions, 23 deletions
diff --git a/debian/patches/0002-modify-xml2-config-behaviour.patch b/debian/patches/0002-modify-xml2-config-behaviour.patch
new file mode 100644
index 0000000..339b5b3
--- /dev/null
+++ b/debian/patches/0002-modify-xml2-config-behaviour.patch
@@ -0,0 +1,78 @@
+From: Aron Xu <aron@debian.org>
+Date: Sun, 3 Jun 2012 17:54:56 +0800
+Subject: [PATCH] modify xml2-config behaviour
+
+---
+ configure.in | 2 +-
+ xml2-config.1 | 3 ++-
+ xml2-config.in | 14 +++++++++++---
+ 3 files changed, 14 insertions(+), 5 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 0fb4983..e0fec4c 100644
+--- a/configure.in
++++ b/configure.in
+@@ -1360,7 +1360,7 @@ case "$host" in
+ *) M_LIBS="-lm"
+ ;;
+ esac
+-XML_LIBS="-lxml2 $Z_LIBS $THREAD_LIBS $ICONV_LIBS $M_LIBS $LIBS"
++XML_LIBS="-lxml2"
+ XML_LIBTOOLLIBS="libxml2.la"
+ AC_SUBST(WITH_ICONV)
+
+diff --git a/xml2-config.1 b/xml2-config.1
+index 8a25962..bfda630 100644
+--- a/xml2-config.1
++++ b/xml2-config.1
+@@ -9,11 +9,12 @@ xml-config - script to get information about the installed version of GNOME-XML
+ linker flags that should be used to compile and link programs that use
+ \fIGNOME-XML\fP.
+ .SH OPTIONS
+-.l
+ \fIxml-config\fP accepts the following options:
+ .TP 8
+ .B \-\-version
+ Print the currently installed version of \fIGNOME-XML\fP on the standard output.
++Add the \fB\-\-static\fP option to print the linker flags that are necessary
++to \fBstatically\fP link a \fIGNOME-XML\fP program.
+ .TP 8
+ .B \-\-libs
+ Print the linker flags that are necessary to link a \fIGNOME-XML\fP program.
+diff --git a/xml2-config.in b/xml2-config.in
+index 2989325..ce647e0 100644
+--- a/xml2-config.in
++++ b/xml2-config.in
+@@ -15,6 +15,8 @@ Known values for OPTION are:
+ --prefix=DIR change libxml prefix [default $prefix]
+ --exec-prefix=DIR change libxml exec prefix [default $exec_prefix]
+ --libs print library linking information
++ add --static to print static library linking
++ information
+ --cflags print pre-processor and compiler flags
+ --modules module support enabled
+ --help display this help and exit
+@@ -86,13 +88,19 @@ while test $# -gt 0; do
+ then
+ if [ "@XML_LIBDIR@" = "-L/usr/lib" -o "@XML_LIBDIR@" = "-L/usr/lib64" ]
+ then
+- echo @XML_LIBS@
++ LIBS="@XML_LIBS@"
+ else
+- echo @XML_LIBDIR@ @XML_LIBS@
++ LIBS="@XML_LIBDIR@ @XML_LIBS@"
+ fi
+ else
+- echo @XML_LIBDIR@ @XML_LIBS@ @WIN32_EXTRA_LIBADD@
++ LIBS="@XML_LIBDIR@ @XML_LIBS@ @WIN32_EXTRA_LIBADD@"
+ fi
++ if [ "$2" = "--static" ]
++ then
++ shift
++ LIBS="${LIBS} @Z_LIBS@ @BASE_THREAD_LIBS@ @THREAD_LIBS@ @ICONV_LIBS@ @M_LIBS@ @LIBS@"
++ fi
++ echo ${LIBS}
+ ;;
+
+ *)
+--
diff --git a/debian/patches/0002-remove-useless-linking-commands.patch b/debian/patches/0002-remove-useless-linking-commands.patch
deleted file mode 100644
index afc02e6..0000000
--- a/debian/patches/0002-remove-useless-linking-commands.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From: Aron Xu <aron@debian.org>
-Date: Sun, 3 Jun 2012 17:54:56 +0800
-Subject: [PATCH] remove useless linking commands
-
----
- configure.in | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index 0fb4983..e0fec4c 100644
---- a/configure.in
-+++ b/configure.in
-@@ -1360,7 +1360,7 @@ case "$host" in
- *) M_LIBS="-lm"
- ;;
- esac
--XML_LIBS="-lxml2 $Z_LIBS $THREAD_LIBS $ICONV_LIBS $M_LIBS $LIBS"
-+XML_LIBS="-lxml2"
- XML_LIBTOOLLIBS="libxml2.la"
- AC_SUBST(WITH_ICONV)
-
---
diff --git a/debian/patches/series b/debian/patches/series
index 94f46b9..31310df 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,2 @@
0001-restore-generated-html.patch
-0002-remove-useless-linking-commands.patch
+0002-modify-xml2-config-behaviour.patch