summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAron Xu <aron@debian.org>2012-09-22 23:46:31 +0800
committerAron Xu <aron@debian.org>2012-09-22 23:46:31 +0800
commit2d5a4f75b287d546d438bf3b47e31ee9cee2cd36 (patch)
tree795ce645cd8bebd085eac497fb1f0421d690b6e4 /debian
parent722877371bc7239645650a5257fc93fa722ba665 (diff)
downloadlibxml2-2d5a4f75b287d546d438bf3b47e31ee9cee2cd36.tar.gz
Add patch for rand_seed should be static in dict.c
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/0002-rand_seed-should-be-static-in-dict.c.patch28
-rw-r--r--debian/patches/series1
3 files changed, 31 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 9f7c378..333a933 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,8 @@
libxml2 (2.9.0+dfsg1-1) experimental; urgency=low
* New upstream release.
- * Remove patches applied upstream.
+ * Remove old patches applied upstream, cherry-pick one
+ upstream post release patch.
* Update symbols.
* Update std-ver 3.9.3 -> 3.9.4, no change required.
diff --git a/debian/patches/0002-rand_seed-should-be-static-in-dict.c.patch b/debian/patches/0002-rand_seed-should-be-static-in-dict.c.patch
new file mode 100644
index 0000000..163a846
--- /dev/null
+++ b/debian/patches/0002-rand_seed-should-be-static-in-dict.c.patch
@@ -0,0 +1,28 @@
+From: Wouter Van Rooy <rooywo@vasco.com>
+Date: Fri, 14 Sep 2012 14:39:42 +0800
+Subject: rand_seed should be static in dict.c
+
+For https://bugzilla.gnome.org/show_bug.cgi?id=683933
+rand_seed should be a static variable in dict.c
+
+We ran into a problem with another library that exports rand_seed as a
+function. Combined with 2.7.8 this was not a problem but later versions
+have this problem.
+---
+ dict.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dict.c b/dict.c
+index 9935a25..164c7f2 100644
+--- a/dict.c
++++ b/dict.c
+@@ -143,7 +143,7 @@ static int xmlDictInitialized = 0;
+ /*
+ * Internal data for random function, protected by xmlDictMutex
+ */
+-unsigned int rand_seed = 0;
++static unsigned int rand_seed = 0;
+ #endif
+ #endif
+
+--
diff --git a/debian/patches/series b/debian/patches/series
index d300eac..9df6060 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-modify-xml2-config-and-pkgconfig-behaviour.patch
+0002-rand_seed-should-be-static-in-dict.c.patch