summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAron Xu <aron@debian.org>2012-10-28 03:42:50 +0800
committerAron Xu <aron@debian.org>2012-10-28 03:43:44 +0800
commit5e04e2af468d0d7e161928e14fff6f0a10e78844 (patch)
tree42e4f2871eab39ccb91d29e93996a495c820e710 /debian
parentec092ba70d4522615ecd608c1657ec4f5846c1c9 (diff)
downloadlibxml2-5e04e2af468d0d7e161928e14fff6f0a10e78844.tar.gz
Remove -L call from xml2-config, add notes in man
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/patches/0001-modify-xml2-config-and-pkgconfig-behaviour.patch19
2 files changed, 14 insertions, 6 deletions
diff --git a/debian/control b/debian/control
index 0892d2a..9ac1283 100644
--- a/debian/control
+++ b/debian/control
@@ -67,6 +67,7 @@ Package: libxml2-dev
Architecture: any
Section: libdevel
Depends: libxml2 (= ${binary:Version}), ${misc:Depends}
+Suggests: pkg-config
Multi-Arch: same
Description: Development files for the GNOME XML library
XML is a metalanguage to let you design your own markup language.
diff --git a/debian/patches/0001-modify-xml2-config-and-pkgconfig-behaviour.patch b/debian/patches/0001-modify-xml2-config-and-pkgconfig-behaviour.patch
index a7ecf7c..e4deba2 100644
--- a/debian/patches/0001-modify-xml2-config-and-pkgconfig-behaviour.patch
+++ b/debian/patches/0001-modify-xml2-config-and-pkgconfig-behaviour.patch
@@ -5,9 +5,9 @@ Subject: modify xml2-config and pkgconfig behaviour
---
configure.in | 2 +-
libxml-2.0-uninstalled.pc.in | 3 ++-
- xml2-config.1 | 2 ++
+ xml2-config.1 | 4 ++++
xml2-config.in | 22 ++++++++++------------
- 4 files changed, 15 insertions(+), 14 deletions(-)
+ 4 files changed, 17 insertions(+), 14 deletions(-)
diff --git a/configure.in b/configure.in
index 3d5f48b..836695c 100644
@@ -35,10 +35,17 @@ index cab6834..af16ebc 100644
+Libs.private: @BASE_THREAD_LIBS@ @THREAD_LIBS@ @Z_LIBS@ @ICONV_LIBS@ @M_LIBS@ @LIBS@
Cflags: -I${includedir} @XML_INCLUDEDIR@ @XML_CFLAGS@
diff --git a/xml2-config.1 b/xml2-config.1
-index 8cf9858..bfda630 100644
+index 8cf9858..7b4195d 100644
--- a/xml2-config.1
+++ b/xml2-config.1
-@@ -13,6 +13,8 @@ linker flags that should be used to compile and link programs that use
+@@ -8,11 +8,15 @@ xml-config - script to get information about the installed version of GNOME-XML
+ \fIxml-config\fP is a tool that is used to determine the compile and
+ linker flags that should be used to compile and link programs that use
+ \fIGNOME-XML\fP.
++It is highly recommended to use pkg-config instead because building in a
++multi-arch environment is not well supported in this script.
+ .SH OPTIONS
+ \fIxml-config\fP accepts the following options:
.TP 8
.B \-\-version
Print the currently installed version of \fIGNOME-XML\fP on the standard output.
@@ -48,7 +55,7 @@ index 8cf9858..bfda630 100644
.B \-\-libs
Print the linker flags that are necessary to link a \fIGNOME-XML\fP program.
diff --git a/xml2-config.in b/xml2-config.in
-index 1957486..123729f 100644
+index 1957486..b764d83 100644
--- a/xml2-config.in
+++ b/xml2-config.in
@@ -15,6 +15,8 @@ Known values for OPTION are:
@@ -76,7 +83,7 @@ index 1957486..123729f 100644
- echo @XML_LIBDIR@ @XML_LIBS@ @MODULE_PLATFORM_LIBS@ @WIN32_EXTRA_LIBADD@
- fi
- ;;
-+ LIBS="@XML_LIBDIR@ @XML_LIBS@ @WIN32_EXTRA_LIBADD@"
++ LIBS="@XML_LIBS@ @WIN32_EXTRA_LIBADD@"
+ if [ "$2" = "--static" ]
+ then
+ shift