summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAron Xu <aron@debian.org>2012-11-12 09:56:04 +0800
committerAron Xu <aron@debian.org>2012-11-12 09:56:04 +0800
commit730248e31b460fe2bc5709258f538e97af7108b1 (patch)
treebaed10f182f316eeb2a84b20fcc42d2039476b05 /debian
parent7704c13bf375f388979e3b1c7ea59211552d4f03 (diff)
downloadlibxml2-730248e31b460fe2bc5709258f538e97af7108b1.tar.gz
Fix udeb building
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 5087e7a..433a41a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,5 @@
#!/usr/bin/make -f
+export DH_VERBOSE=1
# The versions of python currently supported
PYVERS=$(shell pyversions -s)
@@ -24,7 +25,7 @@ $(if $(shell grep -q libxml2-udeb debian/control && echo yes),$(shell sed -i /li
export DH_OPTIONS = -Nlibxml2-udeb
endif
-CONFIGURE_FLAGS := --with-history CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" --cache-file="$(CURDIR)/builddir/config.cache"
+CONFIGURE_FLAGS := --disable-silent-rules --with-history CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" --cache-file="$(CURDIR)/builddir/config.cache"
override_dh_auto_configure: $(TARGETS:%=doconfigure-%)
@@ -33,7 +34,8 @@ doconfigure-%:
doconfigure-main: CONFIGURE_FLAGS += --without-python
doconfigure-python%: CONFIGURE_FLAGS += --with-python=/usr/bin/$*
-doconfigure-udeb: CONFIGURE_FLAGS += --without-history --with-minimum --with-tree --with-output
+#doconfigure-udeb: CONFIGURE_FLAGS += --without-history --with-minimum --with-tree --with-output
+doconfigure-udeb: CONFIGURE_FLAGS += --without-history --with-tree --with-output
override_dh_auto_build: $(TARGETS:%=dobuild-%)