summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniel Schepler <dschepler@gmail.com>2014-07-09 04:32:55 +0800
committerAron Xu <aron@debian.org>2014-07-09 04:52:33 +0800
commit8fe5303118a603f08165a91cf7890e3349a0d0a6 (patch)
tree86fcf25e16a010aaf7b2edb1ce4c7390494a8e49 /debian
parentafaa94f1cb45b89b143ae93652c6c74301c38213 (diff)
downloadlibxml2-8fe5303118a603f08165a91cf7890e3349a0d0a6.tar.gz
Patch to bootstrap without python (Closes: #738080)
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 2b32c75..9faf17d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,6 +27,11 @@ $(if $(shell grep -q libxml2-udeb debian/control && echo yes),$(shell sed -i /li
export DH_OPTIONS = -Nlibxml2-udeb
endif
+ifeq ($(DEB_BUILD_PROFILE),stage1)
+DH_OPTIONS += -Npython-libxml2 -Npython-libxml2-dbg
+export DH_OPTIONS
+endif
+
CONFIGURE_FLAGS := --disable-silent-rules --with-history CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" --cache-file="$(CURDIR)/builddir/config.cache"
override_dh_auto_configure: $(TARGETS:%=doconfigure-%)
@@ -105,14 +110,18 @@ override_dh_installchangelogs:
override_dh_install:
dh_install -Npython-libxml2-dbg -Nlibxml2-udeb
+ifneq ($(DEB_BUILD_PROFILE),stage1)
dh_install -ppython-libxml2-dbg --sourcedir=debian/tmp-dbg
+endif
dh_install -plibxml2-udeb --sourcedir=debian/tmp-udeb
sed -i -e 's,/lib/$(DEB_HOST_MULTIARCH),/lib,' debian/libxml2-dev/usr/bin/xml2-config
override_dh_strip:
dh_strip -a --dbg-package=libxml2-dbg -Nlibxml2-udeb -Nlibxml2-utils -Nlibxml2-utils-dbg -Npython-libxml2 -Npython-libxml2-dbg
dh_strip -plibxml2-utils --dbg-package=libxml2-utils-dbg
+ifneq ($(DEB_BUILD_PROFILE),stage1)
dh_strip -ppython-libxml2 --dbg-package=python-libxml2-dbg
+endif
$(foreach python, $(filter-out $(PYVER), $(PYVERS)),\
cd $(CURDIR)/debian/python-libxml2/usr/lib/pyshared; \
if diff $(python)/libxml2mod.so $(PYVER)/libxml2mod.so > /dev/null 2>&1; then \
@@ -125,6 +134,10 @@ override_dh_makeshlibs:
dh_makeshlibs -a $(if $(WITH_UDEB),--add-udeb=libxml2-udeb )-V 'libxml2 (>= 2.7.4)' -- -c4
%:
+ifeq ($(DEB_BUILD_PROFILE),stage1)
+ dh $@ --with autoreconf
+else
dh $@ --with autoreconf,python2
+endif