summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAron Xu <aron@debian.org>2013-06-09 00:18:53 +0800
committerAron Xu <aron@debian.org>2013-06-09 00:18:53 +0800
commitf63fd461538ac3079e2ae56e60ab007ed12c9e35 (patch)
treee74eb80ecdb87226ed506def1397883f5dd8413e /debian
parente4509c89a96178245b631c42a3fc645e2962b582 (diff)
downloadlibxml2-f63fd461538ac3079e2ae56e60ab007ed12c9e35.tar.gz
Remove patches applied upstream
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/0002-rand_seed-should-be-static-in-dict.c.patch28
-rw-r--r--debian/patches/0003-Fix-a-thread-portability-problem.patch34
-rw-r--r--debian/patches/0004-link-libxml2mod-first.patch24
-rw-r--r--debian/patches/0005-Fix-potential-out-of-bound-access.patch22
-rw-r--r--debian/patches/series4
5 files changed, 0 insertions, 112 deletions
diff --git a/debian/patches/0002-rand_seed-should-be-static-in-dict.c.patch b/debian/patches/0002-rand_seed-should-be-static-in-dict.c.patch
deleted file mode 100644
index 163a846..0000000
--- a/debian/patches/0002-rand_seed-should-be-static-in-dict.c.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From: Wouter Van Rooy <rooywo@vasco.com>
-Date: Fri, 14 Sep 2012 14:39:42 +0800
-Subject: rand_seed should be static in dict.c
-
-For https://bugzilla.gnome.org/show_bug.cgi?id=683933
-rand_seed should be a static variable in dict.c
-
-We ran into a problem with another library that exports rand_seed as a
-function. Combined with 2.7.8 this was not a problem but later versions
-have this problem.
----
- dict.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/dict.c b/dict.c
-index 9935a25..164c7f2 100644
---- a/dict.c
-+++ b/dict.c
-@@ -143,7 +143,7 @@ static int xmlDictInitialized = 0;
- /*
- * Internal data for random function, protected by xmlDictMutex
- */
--unsigned int rand_seed = 0;
-+static unsigned int rand_seed = 0;
- #endif
- #endif
-
---
diff --git a/debian/patches/0003-Fix-a-thread-portability-problem.patch b/debian/patches/0003-Fix-a-thread-portability-problem.patch
deleted file mode 100644
index 07e3583..0000000
--- a/debian/patches/0003-Fix-a-thread-portability-problem.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Friedrich Haubensak <hsk@fli-leibniz.de>
-Date: Wed, 12 Sep 2012 17:34:53 +0200
-Subject: Fix a thread portability problem
-
-cannot compile libxml2-2.9.0 using studio 12.1 compiler on solaris 10
-
-I.M.O. structure initializer (as PTHREAD_ONCE_INIT) cannot be used in
-a structure assignment anyway
----
- threads.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/threads.c b/threads.c
-index f206149..7e85a26 100644
---- a/threads.c
-+++ b/threads.c
-@@ -146,6 +146,7 @@ struct _xmlRMutex {
- static pthread_key_t globalkey;
- static pthread_t mainthread;
- static pthread_once_t once_control = PTHREAD_ONCE_INIT;
-+static pthread_once_t once_control_init = PTHREAD_ONCE_INIT;
- static pthread_mutex_t global_init_lock = PTHREAD_MUTEX_INITIALIZER;
- #elif defined HAVE_WIN32_THREADS
- #if defined(HAVE_COMPILER_TLS)
-@@ -915,7 +916,7 @@ xmlCleanupThreads(void)
- #ifdef HAVE_PTHREAD_H
- if ((libxml_is_threaded) && (pthread_key_delete != NULL))
- pthread_key_delete(globalkey);
-- once_control = PTHREAD_ONCE_INIT;
-+ once_control = once_control_init;
- #elif defined(HAVE_WIN32_THREADS) && !defined(HAVE_COMPILER_TLS) && (!defined(LIBXML_STATIC) || defined(LIBXML_STATIC_FOR_DLL))
- if (globalkey != TLS_OUT_OF_INDEXES) {
- xmlGlobalStateCleanupHelperParams *p;
---
diff --git a/debian/patches/0004-link-libxml2mod-first.patch b/debian/patches/0004-link-libxml2mod-first.patch
deleted file mode 100644
index 6b5a18c..0000000
--- a/debian/patches/0004-link-libxml2mod-first.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: YunQiang Su <wzssyqa@gmail.com>
-Date: Sun, 28 Oct 2012 03:29:05 +0800
-Subject: link libxml2mod first
-
----
- python/Makefile.am | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/python/Makefile.am b/python/Makefile.am
-index 4a8b5d5..10724ec 100644
---- a/python/Makefile.am
-+++ b/python/Makefile.am
-@@ -24,8 +24,8 @@ AM_CPPFLAGS = \
- python_LTLIBRARIES = libxml2mod.la
-
- libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c
--libxml2mod_la_LIBADD = $(top_builddir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS) -lpython$(PYTHON_VERSION)
--libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version
-+libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version \
-+ $(top_builddir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS) -lpython$(PYTHON_VERSION)
-
- BUILT_SOURCES = libxml2-export.c libxml2-py.h libxml2-py.c
-
---
diff --git a/debian/patches/0005-Fix-potential-out-of-bound-access.patch b/debian/patches/0005-Fix-potential-out-of-bound-access.patch
deleted file mode 100644
index 1e6396c..0000000
--- a/debian/patches/0005-Fix-potential-out-of-bound-access.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From: Daniel Veillard <veillard@redhat.com>
-Date: Mon, 29 Oct 2012 02:39:55 +0000
-Subject: Fix potential out of bound access
-
----
- parser.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/parser.c b/parser.c
-index 192eaed..4519a70 100644
---- a/parser.c
-+++ b/parser.c
-@@ -4075,7 +4075,7 @@ xmlParseAttValueComplex(xmlParserCtxtPtr ctxt, int *attlen, int normalize) {
- goto error;
-
- if ((in_space) && (normalize)) {
-- while (buf[len - 1] == 0x20) len--;
-+ while ((len > 0) && (buf[len - 1] == 0x20)) len--;
- }
- buf[len] = 0;
- if (RAW == '<') {
---
diff --git a/debian/patches/series b/debian/patches/series
index cd4a7d3..d300eac 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,5 +1 @@
0001-modify-xml2-config-and-pkgconfig-behaviour.patch
-0002-rand_seed-should-be-static-in-dict.c.patch
-0003-Fix-a-thread-portability-problem.patch
-0004-link-libxml2mod-first.patch
-0005-Fix-potential-out-of-bound-access.patch