summaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
authorAron Xu <aron@debian.org>2014-07-09 04:01:07 +0800
committerAron Xu <aron@debian.org>2014-07-09 04:01:07 +0800
commit7042e17490515a990a45aa7237d11bc49ab0eaf0 (patch)
tree62b661911406394bbeaca8951d660bb6d8aac0de /example/Makefile.am
parent2c8fe012ef1ff6e0613480dd182dec099aa9636e (diff)
downloadlibxml2-7042e17490515a990a45aa7237d11bc49ab0eaf0.tar.gz
Imported Upstream version 2.8.0+dfsg1
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
index 488ee6e..9eb6a76 100644
--- a/example/Makefile.am
+++ b/example/Makefile.am
@@ -1,7 +1,10 @@
noinst_PROGRAMS = gjobread
-AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(srcdir)/include
-AM_CFLAGS = $(THREAD_CFLAGS) $(Z_CFLAGS)
-LDADD = $(RDL_LIBS) $(STATIC_BINARIES) $(top_builddir)/libxml2.la $(THREAD_LIBS) $(Z_LIBS) $(ICONV_LIBS) -lm $(WIN32_EXTRA_LIBADD)
+INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I@srcdir@/include @THREAD_CFLAGS@ @Z_CFLAGS@
+DEPS = $(top_builddir)/libxml2.la
+LDADDS = @STATIC_BINARIES@ $(top_builddir)/libxml2.la @THREAD_LIBS@ @Z_LIBS@ $(ICONV_LIBS) -lm @WIN32_EXTRA_LIBADD@
gjobread_SOURCES=gjobread.c
+gjobread_LDFLAGS=
+gjobread_DEPENDENCIES= $(DEPS)
+gjobread_LDADD= @RDL_LIBS@ $(LDADDS)