summaryrefslogtreecommitdiff
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorMike Hommey <mh@glandium.org>2004-09-10 05:26:00 +0000
committerMike Hommey <mh@glandium.org>2004-09-10 05:26:00 +0000
commit09deb06614c3408ec0816a3c88920138bae2083c (patch)
treea1b841a7dc28eecb98ca361c9371ecd1449a1908 /python/Makefile.am
parentc14c53a3645d81281058d4bb4cff24fa8d6faf33 (diff)
downloadlibxml2-09deb06614c3408ec0816a3c88920138bae2083c.tar.gz
Load /tmp/tmp.BmUFjT/libxml2-2.6.13 intoupstream/2.6.13
packages/libxml2/branches/upstream/current.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index f473421..27feef0 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -23,7 +23,7 @@ EXTRA_DIST = \
libxml2-python-api.xml \
$(DOCS)
-libxml2mod_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/.libs
+libxml2mod_la_LDFLAGS = @CYGWIN_EXTRA_LDFLAGS@ @WIN32_EXTRA_LDFLAGS@ -module -avoid-version -L$(top_builddir)/.libs
if WITH_PYTHON
mylibs = \
@@ -34,7 +34,7 @@ all-local: libxml2.py
python_LTLIBRARIES = libxml2mod.la
libxml2mod_la_SOURCES = libxml.c types.c libxml2-py.c
-libxml2mod_la_LIBADD = $(mylibs)
+libxml2mod_la_LIBADD = $(mylibs) @CYGWIN_EXTRA_PYTHON_LIBADD@
libxml2.py: $(srcdir)/libxml.py $(srcdir)/libxml2class.py
cat $(srcdir)/libxml.py $(srcdir)/libxml2class.py > libxml2.py
@@ -69,5 +69,5 @@ else
all:
endif
tests test: all
- cd tests && $(MAKE) tests
+ cd tests && $(MAKE) MAKEFLAGS+=--silent tests