summaryrefslogtreecommitdiff
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2008-04-09 10:33:41 +0200
committerMike Hommey <glandium@debian.org>2008-04-09 10:33:41 +0200
commit88f9c7ca80bfbc9a5429fc632b90d6c4a2a2787d (patch)
treee12ef38cd8eb205c495e5718852d758b95e3a3c6 /python/Makefile.am
parentfc760252aba4054a612dd20b803d0c7c19713064 (diff)
downloadlibxml2-88f9c7ca80bfbc9a5429fc632b90d6c4a2a2787d.tar.gz
Load /tmp/libxml2-2.6.32 intoupstream/2.6.32.dfsg
libxml2/branches/upstream/current.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am46
1 files changed, 16 insertions, 30 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 667c2c8..23898fa 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -9,21 +9,17 @@ INCLUDES = \
-I$(top_builddir)/include \
-I$(top_builddir)/$(subdir)
-DOCS_DIR = $(datadir)/doc/libxml2-python-$(LIBXML_VERSION)
+docsdir = $(datadir)/doc/libxml2-python-$(LIBXML_VERSION)
# libxml2class.txt is generated
-DOCS = ${srcdir}/TODO
+dist_docs_DATA = TODO
EXTRA_DIST = \
- libxml.c \
- types.c \
setup.py \
setup.py.in \
generator.py \
libxml_wrap.h \
libxml.py \
- drv_libxml2.py \
- libxml2-python-api.xml \
- $(DOCS)
+ libxml2-python-api.xml
libxml2mod_la_LDFLAGS = @CYGWIN_EXTRA_LDFLAGS@ @WIN32_EXTRA_LDFLAGS@ -module -avoid-version
@@ -31,29 +27,23 @@ if WITH_PYTHON
mylibs = \
$(top_builddir)/libxml2.la
-all-local: libxml2.py
-
python_LTLIBRARIES = libxml2mod.la
-libxml2mod_la_SOURCES = libxml.c types.c libxml2-py.c
+libxml2mod_la_SOURCES = libxml.c types.c
+nodist_libxml2mod_la_SOURCES = libxml2-py.c
libxml2mod_la_LIBADD = $(mylibs) @CYGWIN_EXTRA_PYTHON_LIBADD@
+libxml.c: libxml2-py.h # to generate before to compile
+
+
libxml2.py: $(srcdir)/libxml.py libxml2class.py
- cat $(srcdir)/libxml.py libxml2class.py > libxml2.py
-
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(pythondir)
- @INSTALL@ -m 0644 libxml2.py $(DESTDIR)$(pythondir)
- @INSTALL@ -m 0644 $(srcdir)/drv_libxml2.py $(DESTDIR)$(pythondir)
- $(mkinstalldirs) $(DESTDIR)$(DOCS_DIR)
- @(for doc in $(DOCS) ; \
- do @INSTALL@ -m 0644 $$doc $(DESTDIR)$(DOCS_DIR) ; done)
-
-uninstall-local:
- @(for doc in $(DOCS) ; \
- do rm $(DESTDIR)$(DOCS_DIR)/`basename $$doc` ; done)
- rm $(DESTDIR)$(pythondir)/drv_libxml2.py
- rm $(DESTDIR)$(pythondir)/libxml2.py
+ cat $(srcdir)/libxml.py libxml2class.py > $@
+
+python_DATA = \
+ libxml2.py
+
+dist_python_DATA = \
+ drv_libxml2.py
GENERATE = generator.py
API_DESC = $(top_srcdir)/doc/libxml2-api.xml $(srcdir)/libxml2-python-api.xml
@@ -70,12 +60,8 @@ $(GENERATED): gen_prog
gen_prog: $(srcdir)/$(GENERATE) $(API_DESC)
$(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
touch gen_prog
-
-$(libxml2mod_la_OBJECTS): $(GENERATED)
-
-else
-all:
endif
+
tests test: all
cd tests && $(MAKE) MAKEFLAGS+=--silent tests