summaryrefslogtreecommitdiff
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorMike Hommey <mh@glandium.org>2005-02-05 12:06:19 +0000
committerMike Hommey <mh@glandium.org>2005-02-05 12:06:19 +0000
commita7457388701e6ccba9091ba3ec09505dc903b758 (patch)
tree80a7d0fba3968fee73cc71a62ffe1af039396f29 /python/Makefile.am
parentf51dd67f3a3f472af0620391eb588eeca4533689 (diff)
downloadlibxml2-a7457388701e6ccba9091ba3ec09505dc903b758.tar.gz
Load /tmp/tmp.5kkLmZ/libxml2-2.6.17 intoupstream/2.6.17
packages/libxml2/branches/upstream/current.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index fa13310..c37c0c2 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -6,7 +6,8 @@ SUBDIRS= . tests
INCLUDES = \
-I$(PYTHON_INCLUDES) \
-I$(top_srcdir)/include \
- -I$(top_builddir)/include
+ -I$(top_builddir)/include \
+ -I$(top_builddir)/$(subdir)
DOCS_DIR = $(datadir)/doc/libxml2-python-$(LIBXML_VERSION)
# libxml2class.txt is generated
@@ -37,8 +38,8 @@ python_LTLIBRARIES = libxml2mod.la
libxml2mod_la_SOURCES = libxml.c types.c libxml2-py.c
libxml2mod_la_LIBADD = $(mylibs) @CYGWIN_EXTRA_PYTHON_LIBADD@
-libxml2.py: $(srcdir)/libxml.py $(srcdir)/libxml2class.py
- cat $(srcdir)/libxml.py $(srcdir)/libxml2class.py > libxml2.py
+libxml2.py: $(srcdir)/libxml.py libxml2class.py
+ cat $(srcdir)/libxml.py libxml2class.py > libxml2.py
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(pythondir)
@@ -50,18 +51,18 @@ install-data-local:
GENERATE = generator.py
API_DESC = $(top_srcdir)/doc/libxml2-api.xml $(srcdir)/libxml2-python-api.xml
-GENERATED= $(srcdir)/libxml2class.py \
- $(srcdir)/libxml2-export.c \
- $(srcdir)/libxml2class.txt \
- $(srcdir)/libxml2-py.c \
- $(srcdir)/libxml2-py.h
+GENERATED= libxml2class.py \
+ libxml2-export.c \
+ libxml2class.txt \
+ libxml2-py.c \
+ libxml2-py.h
CLEANFILES= $(GENERATED) gen_prog libxml2.py
$(GENERATED): gen_prog
gen_prog: $(srcdir)/$(GENERATE) $(API_DESC)
- cd $(srcdir) && $(PYTHON) $(GENERATE)
+ $(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
touch gen_prog
$(libxml2mod_la_OBJECTS): $(GENERATED)