summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2dd69a3..26de7d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,7 +118,7 @@ testReader_LDADD= $(LDADDS)
#testOOM_DEPENDENCIES = $(DEPS)
#testOOM_LDADD= $(LDADDS)
-check-local: tests
+check-local: all tests
testall : tests SVGtests SAXtests
@@ -906,7 +906,7 @@ Relaxtests: xmllint$(EXEEXT)
RelaxNGPythonTests:
@(if [ -x $(PYTHON) ] ; then \
- PYTHONPATH=$(top_builddir)/python:$(top_builddir)/python/.libs ; \
+ PYTHONPATH=$(top_builddir)/python:$(top_builddir)/python/.libs:$$PYTHONPATH ; \
export PYTHONPATH; \
echo "## Relax-NG Python based test suite 1" ; \
$(CHECKER) $(PYTHON) $(srcdir)/check-relaxng-test-suite.py ; \
@@ -916,7 +916,7 @@ RelaxNGPythonTests:
SchemasPythonTests:
@(if [ -x $(PYTHON) ] ; then \
- PYTHONPATH=$(top_builddir)/python:$(top_builddir)/python/.libs; \
+ PYTHONPATH=$(top_builddir)/python:$(top_builddir)/python/.libs:$$PYTHONPATH; \
export PYTHONPATH; \
echo "## XML Schemas datatypes Python based test suite" ; \
$(CHECKER) $(PYTHON) $(srcdir)/check-xsddata-test-suite.py ; \