summaryrefslogtreecommitdiff
path: root/debian/patches/0002-fix-python-multiarch-includes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-fix-python-multiarch-includes.patch')
-rw-r--r--debian/patches/0002-fix-python-multiarch-includes.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/debian/patches/0002-fix-python-multiarch-includes.patch b/debian/patches/0002-fix-python-multiarch-includes.patch
new file mode 100644
index 0000000..ff7c4fa
--- /dev/null
+++ b/debian/patches/0002-fix-python-multiarch-includes.patch
@@ -0,0 +1,35 @@
+From: Matthias Klose <doko@ubuntu.com>
+Date: Wed, 9 Jul 2014 05:30:24 +0800
+Subject: fix python multiarch includes
+
+---
+ python/Makefile.am | 2 +-
+ python/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/python/Makefile.am b/python/Makefile.am
+index 34aed96..8445ea5 100644
+--- a/python/Makefile.am
++++ b/python/Makefile.am
+@@ -19,7 +19,7 @@ if WITH_PYTHON
+ AM_CPPFLAGS = \
+ -I$(top_builddir)/include \
+ -I$(top_srcdir)/include \
+- -I$(PYTHON_INCLUDES)
++ $(PYTHON_INCLUDES)
+
+ python_LTLIBRARIES = libxml2mod.la
+
+diff --git a/python/Makefile.in b/python/Makefile.in
+index efdea43..23e7fa2 100644
+--- a/python/Makefile.in
++++ b/python/Makefile.in
+@@ -430,7 +430,7 @@ EXTRA_DIST = \
+ @WITH_PYTHON_TRUE@AM_CPPFLAGS = \
+ @WITH_PYTHON_TRUE@ -I$(top_builddir)/include \
+ @WITH_PYTHON_TRUE@ -I$(top_srcdir)/include \
+-@WITH_PYTHON_TRUE@ -I$(PYTHON_INCLUDES)
++@WITH_PYTHON_TRUE@ $(PYTHON_INCLUDES)
+
+ @WITH_PYTHON_TRUE@python_LTLIBRARIES = libxml2mod.la
+ @WITH_PYTHON_TRUE@libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c