summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 9 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 9acaf97..bd2dcba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,7 +13,7 @@ DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
CC = $(DEB_HOST_GNU_TYPE)-gcc
-CFLAGS = `dpkg-buildflags --get CFLAGS` -Wall
+CFLAGS = `dpkg-buildflags --get CFLAGS` -Wall -O3
LDFLAGS = `dpkg-buildflags --get LDFLAGS` -Wl,--as-needed
CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
@@ -47,10 +47,9 @@ debian/autoreconf.after:
doconfigure-%: debian/autoreconf.after
dh_auto_configure --builddirectory=builddir/$* -- $(CONFIGURE_FLAGS)
-doconfigure-main: CONFIGURE_FLAGS += --without-python
+doconfigure-main: CONFIGURE_FLAGS += --without-python --with-icu
doconfigure-python%: CONFIGURE_FLAGS += --with-python=/usr/bin/$*
-#doconfigure-udeb: CONFIGURE_FLAGS += --without-history --with-minimum --with-tree --with-output
-doconfigure-udeb: CONFIGURE_FLAGS += --without-history --with-tree --with-output --without-python
+doconfigure-udeb: CONFIGURE_FLAGS += --without-history --with-tree --with-output --without-python --without-icu
# For dyson we need 32-bit library, but we don't have 32-bit liblzma
doconfigure-32: CONFIGURE_FLAGS += --without-python --libdir=/usr/lib32 --without-lzma
@@ -72,6 +71,8 @@ dobuild-python%-dbg: BUILD_FLAGS += PYTHON_INCLUDES="$(shell $(DEB_HOST_GNU_TYPE
PYTHON_LIBS="$(shell $(DEB_HOST_GNU_TYPE)-python-dbg-config --ldflags)" \
CFLAGS="$(CFLAGS) -Wall -g -O0" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS) \
-L$(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)"
+
+#override_dh_auto_build: $(TARGETS:%=dobuild-%)
build-arch: $(TARGETS:%=dobuild-%)
build-indep:
build: build-arch build-indep
@@ -90,7 +91,6 @@ doinstall-32:
doinstall-main:
dh_auto_install --builddirectory=builddir/main
mv debian/tmp/usr/share/aclocal/libxml.m4 debian/tmp/usr/share/aclocal/libxml2.m4
-
# Properly install documentation in /usr/share/doc/libxml2-doc
install -d debian/tmp/usr/share/doc/libxml2-doc/examples
install -m 644 \
@@ -153,11 +153,12 @@ endif
override_dh_makeshlibs:
dh_makeshlibs -a $(if $(WITH_UDEB),--add-udeb=libxml2-udeb ) -- -c4
+override_dh_gencontrol:
+ dh_gencontrol -- -Vdep:libicudbg="`dpkg-query -f '$${Depends}' -W libicu-dev | sed 's/.*\(libicu[0-9]*\).*/\1/'`-dbg"
+
%:
ifeq ($(DEB_BUILD_PROFILE),stage1)
dh $@ --with autoreconf
else
- dh $@ --with autoreconf,python2
+ dh $@ --parallel --with autoreconf,python2
endif
-
-