summaryrefslogtreecommitdiff
path: root/libxml2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libxml2.spec')
-rw-r--r--libxml2.spec48
1 files changed, 43 insertions, 5 deletions
diff --git a/libxml2.spec b/libxml2.spec
index 54370be..152c3f0 100644
--- a/libxml2.spec
+++ b/libxml2.spec
@@ -1,6 +1,6 @@
Summary: Library providing XML and HTML support
Name: libxml2
-Version: 2.6.10
+Version: 2.6.11
Release: 1
License: MIT
Group: Development/Libraries
@@ -60,8 +60,46 @@ at parse time or later once the document has been modified.
%setup -q
%build
-%configure
-make
+#
+# try to use compiler profiling, based on Arjan van de Ven <arjanv@redhat.com>
+# initial test spec. This really doesn't work okay for most tests done.
+#
+GCC_VERSION=`gcc --version | grep "^gcc" | awk '{ print $3 }' | sed 's+\([0-9]\)\.\([0-9]\)\..*+\1\2+'`
+#if [ $GCC_VERSION -eq 32 ]
+#then
+# PROF_GEN='-fprofile-arcs'
+# PROF_USE='-fbranch-probabilities'
+#else if [ $GCC_VERSION -eq 33 ]
+#then
+# PROF_GEN='-fprofile-arcs'
+# PROF_USE='-fbranch-probabilities -ftracer'
+#else
+if [ $GCC_VERSION -ge 34 ]
+then
+ PROF_GEN='-fprofile-generate'
+ PROF_USE='-fprofile-use'
+fi
+#fi
+#fi
+
+if [ "$PROF_GEN" != "" ]
+then
+ # First generate a profiling version
+ CFLAGS="${RPM_OPT_FLAGS} ${PROF_GEN}" %configure
+ make
+ # Run a few sampling
+ make dba100000.xml
+ ./xmllint --noout dba100000.xml
+ ./xmllint --stream dba100000.xml
+ ./xmllint --noout --valid test/valid/REC-xml-19980210.xml
+ ./xmllint --stream --valid test/valid/REC-xml-19980210.xml
+ # Then generate code based on profile
+ CFLAGS="${RPM_OPT_FLAGS} ${PROF_USE}" %configure
+ make
+else
+ %configure
+ make
+fi
(cd doc/examples ; make clean)
gzip -9 ChangeLog
@@ -121,8 +159,8 @@ rm -fr %{buildroot}
%doc doc/python.html
%changelog
-* Mon May 17 2004 Daniel Veillard <veillard@redhat.com>
-- upstream release 2.6.10 see http://xmlsoft.org/news.html
+* Mon Jul 5 2004 Daniel Veillard <veillard@redhat.com>
+- upstream release 2.6.11 see http://xmlsoft.org/news.html
* Thu Jan 2 2003 Daniel Veillard <veillard@redhat.com>
- integrated drv_libxml2 xml.sax driver from Stéphane Bidoul