summaryrefslogtreecommitdiff
path: root/python/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'python/tests/Makefile.am')
-rw-r--r--python/tests/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/python/tests/Makefile.am b/python/tests/Makefile.am
index 95ebead..52c89fc 100644
--- a/python/tests/Makefile.am
+++ b/python/tests/Makefile.am
@@ -19,7 +19,6 @@ PYTESTS= \
xpath.py \
outbuf.py \
inbuf.py \
- input_callback.py \
resolver.py \
regexp.py \
reader.py \
@@ -56,11 +55,8 @@ XMLS= \
invalid.xml \
test.dtd
-CLEANFILES = core tmp.xml *.pyc
-
if WITH_PYTHON
tests: $(PYTESTS)
- @for f in $(XMLS) ; do test -f $$f || $(LN_S) $(srcdir)/$$f . ; done
@echo "## running Python regression tests"
-@(PYTHONPATH="..:../.libs:$(srcdir)/..:$$PYTHONPATH" ; \
export PYTHONPATH; \
@@ -73,3 +69,6 @@ tests: $(PYTESTS)
else
tests:
endif
+
+clean:
+ rm -f *.pyc core