summaryrefslogtreecommitdiff
path: root/debian/patches/force-link-pass.o.diff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-12-29 13:40:27 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-12-29 13:40:27 +0300
commitdf36a469d77312f6dc0dccf08252542c16cf3308 (patch)
treec7089deec82cde1a5ac416aff1daadb097225ba3 /debian/patches/force-link-pass.o.diff
downloadllvm-toolchain-3.8-df36a469d77312f6dc0dccf08252542c16cf3308.tar.gz
llvm-toolchain-3.8 (1:3.8.1-16)debian/3.8.1-16
Diffstat (limited to 'debian/patches/force-link-pass.o.diff')
-rw-r--r--debian/patches/force-link-pass.o.diff28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/patches/force-link-pass.o.diff b/debian/patches/force-link-pass.o.diff
new file mode 100644
index 0000000..f913491
--- /dev/null
+++ b/debian/patches/force-link-pass.o.diff
@@ -0,0 +1,28 @@
+Index: llvm-toolchain-snapshot_3.7~svn231588/tools/bugpoint/Makefile
+===================================================================
+--- llvm-toolchain-snapshot_3.7~svn231588.orig/tools/bugpoint/Makefile
++++ llvm-toolchain-snapshot_3.7~svn231588/tools/bugpoint/Makefile
+@@ -12,6 +12,9 @@ TOOLNAME := bugpoint
+ LINK_COMPONENTS := asmparser instrumentation scalaropts ipo linker bitreader \
+ bitwriter irreader vectorize objcarcopts codegen
+
++# Crappy workaround to make sure it links correctly.
++LLVMLibsOptions := ../../lib/IR/Release*/Pass.o
++
+ # Support plugins.
+ NO_DEAD_STRIP := 1
+
+Index: llvm-toolchain-snapshot_3.7~svn231588/tools/opt/Makefile
+===================================================================
+--- llvm-toolchain-snapshot_3.7~svn231588.orig/tools/opt/Makefile
++++ llvm-toolchain-snapshot_3.7~svn231588/tools/opt/Makefile
+@@ -11,6 +11,9 @@ LEVEL := ../..
+ TOOLNAME := opt
+ LINK_COMPONENTS := bitreader bitwriter asmparser irreader instrumentation scalaropts objcarcopts ipo vectorize all-targets codegen passes
+
++# Crappy workaround to make sure it links correctly.
++LLVMLibsOptions := ../../lib/IR/Release*/Pass.o
++
+ # Support plugins.
+ NO_DEAD_STRIP := 1
+