summaryrefslogtreecommitdiff
path: root/debian/patches/0021-shared-lib-debian.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0021-shared-lib-debian.patch')
-rw-r--r--debian/patches/0021-shared-lib-debian.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/patches/0021-shared-lib-debian.patch b/debian/patches/0021-shared-lib-debian.patch
new file mode 100644
index 0000000..b6291fb
--- /dev/null
+++ b/debian/patches/0021-shared-lib-debian.patch
@@ -0,0 +1,26 @@
+Index: llvm-toolchain-snapshot_3.7~svn241915/tools/llvm-shlib/Makefile
+===================================================================
+--- llvm-toolchain-snapshot_3.7~svn241915.orig/tools/llvm-shlib/Makefile
++++ llvm-toolchain-snapshot_3.7~svn241915/tools/llvm-shlib/Makefile
+@@ -41,6 +41,12 @@ LLVMLibsOptions := $(IncludeInLibLlvm:$(
+ LLVMLibsPaths := $(IncludeInLibLlvm)
+
+ $(LibName.SO): $(LLVMLibsPaths)
++ $(Echo) Linking $(BuildMode) $(SharedLibKindMessage) \
++ $(LIBRARYNAME)$(SHLIBEXT)
++ $(Verb) $(Link) $(SharedLinkOptions) -o $@ $(ObjectsO) \
++ $(ProjLibsOptions) $(LLVMLibsOptions) $(LIBS)
++ mv $(LibName.SO) $(LibName.SO).1
++ ln -s $(notdir $(LibName.SO)).1 $(LibName.SO)
+
+ ifeq ($(HOST_OS),Darwin)
+ # set dylib internal version number to llvmCore submission number
+@@ -61,7 +67,7 @@ endif
+
+ ifeq ($(HOST_OS), $(filter $(HOST_OS), DragonFly Linux FreeBSD GNU/kFreeBSD GNU))
+ # Add soname to the library.
+- LLVMLibsOptions += -Wl,--soname,lib$(LIBRARYNAME)$(SHLIBEXT)
++ LLVMLibsOptions += -Wl,--soname,lib$(LIBRARYNAME)$(SHLIBEXT) -Wl,-Bsymbolic-functions
+ endif
+
+ ifeq ($(HOST_OS), $(filter $(HOST_OS), Linux GNU GNU/kFreeBSD))