summaryrefslogtreecommitdiff
path: root/debian/patches/18-soname.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/18-soname.patch')
-rw-r--r--debian/patches/18-soname.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/18-soname.patch b/debian/patches/18-soname.patch
new file mode 100644
index 0000000..fe812e0
--- /dev/null
+++ b/debian/patches/18-soname.patch
@@ -0,0 +1,21 @@
+Index: llvm-toolchain-snapshot_3.7~svn241915/clang/tools/libclang/Makefile
+===================================================================
+--- llvm-toolchain-snapshot_3.7~svn241915.orig/clang/tools/libclang/Makefile
++++ llvm-toolchain-snapshot_3.7~svn241915/clang/tools/libclang/Makefile
+@@ -14,6 +14,7 @@ EXPORTED_SYMBOL_FILE = $(PROJ_SRC_DIR)/l
+
+ LINK_LIBS_IN_SHARED = 1
+ SHARED_LIBRARY = 1
++SONAME_MAJOR=1
+
+ include $(CLANG_LEVEL)/../../Makefile.config
+ LINK_COMPONENTS := $(TARGETS_TO_BUILD) asmparser bitreader bitwriter core \
+@@ -36,7 +37,7 @@ include $(CLANG_LEVEL)/Makefile
+
+ # Add soname to the library.
+ ifeq ($(HOST_OS), $(filter $(HOST_OS), Linux FreeBSD GNU GNU/kFreeBSD))
+- LLVMLibsOptions += -Wl,-soname,lib$(LIBRARYNAME)$(SHLIBEXT)
++ LLVMLibsOptions += -Wl,-soname,lib$(LIBRARYNAME)-$(LLVM_VERSION_MAJOR).$(LLVM_VERSION_MINOR)$(SHLIBEXT).$(SONAME_MAJOR)
+ endif
+
+ ifeq ($(ENABLE_CLANG_ARCMT),1)