summaryrefslogtreecommitdiff
path: root/debian/patches/lldb-missing-install.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/lldb-missing-install.diff')
-rw-r--r--debian/patches/lldb-missing-install.diff22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/patches/lldb-missing-install.diff b/debian/patches/lldb-missing-install.diff
new file mode 100644
index 0000000..d8a7b9a
--- /dev/null
+++ b/debian/patches/lldb-missing-install.diff
@@ -0,0 +1,22 @@
+Index: llvm-toolchain-snapshot_5.0~svn294583/lldb/tools/argdumper/CMakeLists.txt
+===================================================================
+--- llvm-toolchain-snapshot_5.0~svn294583.orig/lldb/tools/argdumper/CMakeLists.txt
++++ llvm-toolchain-snapshot_5.0~svn294583/lldb/tools/argdumper/CMakeLists.txt
+@@ -8,3 +8,5 @@ add_lldb_tool(lldb-argdumper INCLUDE_IN_
+ lldbUtility
+ )
+
++install(TARGETS lldb-argdumper
++ RUNTIME DESTINATION bin)
+Index: llvm-toolchain-snapshot_5.0~svn294583/lldb/tools/lldb-server/CMakeLists.txt
+===================================================================
+--- llvm-toolchain-snapshot_5.0~svn294583.orig/lldb/tools/lldb-server/CMakeLists.txt
++++ llvm-toolchain-snapshot_5.0~svn294583/lldb/tools/lldb-server/CMakeLists.txt
+@@ -79,3 +79,7 @@ add_lldb_tool(lldb-server INCLUDE_IN_FRA
+ )
+
+ target_link_libraries(lldb-server ${LLDB_SYSTEM_LIBS})
++
++install(TARGETS lldb-server
++ RUNTIME DESTINATION bin)
++