summaryrefslogtreecommitdiff
path: root/debian/prepare-new-release.sh
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-12-02 17:06:08 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-12-02 17:06:08 +0300
commit18583eaa2c6fa769ce80605422fa10a60d353af7 (patch)
tree4b6730afc2006e86ae8b91c8c4cf52b313b5c188 /debian/prepare-new-release.sh
downloadllvm-toolchain-8-18583eaa2c6fa769ce80605422fa10a60d353af7.tar.gz
Import llvm-toolchain-8 (1:8.0.1-4)debian/8.0.1-4debian
Diffstat (limited to 'debian/prepare-new-release.sh')
-rw-r--r--debian/prepare-new-release.sh19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/prepare-new-release.sh b/debian/prepare-new-release.sh
new file mode 100644
index 0000000..c1d4788
--- /dev/null
+++ b/debian/prepare-new-release.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+ORIG_VERSION=7
+TARGET_VERSION=8
+ORIG_VERSION_2=7_0
+TARGET_VERSION_2=8_0
+ORIG_VERSION_3=70
+TARGET_VERSION_3=80
+
+LIST=`ls debian/control debian/orig-tar.sh debian/rules debian/patches/clang-analyzer-force-version.diff debian/patches/clang-format-version.diff debian/patches/python-clangpath.diff debian/patches/scan-build-clang-path.diff debian/patches/lldb-libname.diff debian/patches/fix-scan-view-path.diff debian/patches/lldb-addversion-suffix-to-llvm-server-exec.patch debian/patches/clang-tidy-run-bin.diff debian/patches/fix-scan-view-path.diff debian/qualify-clang.sh debian/README debian/patches/clang-analyzer-force-version.diff debian/patches/clang-tidy-run-bin.diff debian/tests/control`
+for F in $LIST; do
+ sed -i -e "s|$ORIG_VERSION_3|$TARGET_VERSION_3|g" $F
+ sed -i -e "s|$ORIG_VERSION_2|$TARGET_VERSION_2|g" $F
+ sed -i -e "s|$ORIG_VERSION|$TARGET_VERSION|g" $F
+done
+
+echo "once you copy the old version into a new branch"
+echo "edit debian/control, update the VCS links"
+echo "edit debian/control, update the source pkg name"
+echo "edit debian/changelog, update the source pkg name"