summaryrefslogtreecommitdiff
path: root/debian/patches/lldb/lldb-link-atomic-cmake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/lldb/lldb-link-atomic-cmake.patch')
-rw-r--r--debian/patches/lldb/lldb-link-atomic-cmake.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/patches/lldb/lldb-link-atomic-cmake.patch b/debian/patches/lldb/lldb-link-atomic-cmake.patch
new file mode 100644
index 0000000..f4f2cab
--- /dev/null
+++ b/debian/patches/lldb/lldb-link-atomic-cmake.patch
@@ -0,0 +1,27 @@
+Description: Link with -latomic when mips* processor is detected
+Author: Gianfranco Costamagna <locutusofborg@debian.org>
+Last-Update: 2016-07-27
+
+---
+ lldb/cmake/LLDBDependencies.cmake | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+Index: llvm-toolchain-snapshot_8~svn349138/lldb/source/Utility/CMakeLists.txt
+===================================================================
+--- llvm-toolchain-snapshot_8~svn349138.orig/lldb/source/Utility/CMakeLists.txt
++++ llvm-toolchain-snapshot_8~svn349138/lldb/source/Utility/CMakeLists.txt
+@@ -32,6 +32,14 @@ endif()
+
+ list(APPEND LLDB_SYSTEM_LIBS ${system_libs})
+
++if(CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "mips" OR
++ CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "mipsel" OR
++ CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "mips64el" OR
++ CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "powerpcspe")
++ list(APPEND LLDB_SYSTEM_LIBS atomic)
++endif()
++
++
+ if (LLVM_BUILD_STATIC)
+ if (NOT LLDB_DISABLE_PYTHON)
+ list(APPEND LLDB_SYSTEM_LIBS python2.7 util)